aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-dbd_sqlite
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2009-10-29 11:43:04 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2009-10-29 11:43:04 +0000
commitdfa7964dc2f4c6e63340c03452b787064d8a06c8 (patch)
treef703e6c4b70cea892ed094371131000c5188a070 /databases/ruby-dbd_sqlite
parentae162a468c3f123a7818da8161177d365243b404 (diff)
Notes
Diffstat (limited to 'databases/ruby-dbd_sqlite')
-rw-r--r--databases/ruby-dbd_sqlite/Makefile33
-rw-r--r--databases/ruby-dbd_sqlite/distinfo3
-rw-r--r--databases/ruby-dbd_sqlite/pkg-plist9
3 files changed, 13 insertions, 32 deletions
diff --git a/databases/ruby-dbd_sqlite/Makefile b/databases/ruby-dbd_sqlite/Makefile
index fffdeab8720b..d8100c00413a 100644
--- a/databases/ruby-dbd_sqlite/Makefile
+++ b/databases/ruby-dbd_sqlite/Makefile
@@ -6,44 +6,21 @@
#
PORTNAME= dbd_sqlite
-PORTVERSION= ${RUBY_DBI_PORTVERSION}
-PORTREVISION= 1
+PORTVERSION= 0.1.2
CATEGORIES= databases ruby
-MASTER_SITES= ${RUBY_DBI_MASTER_SITES}
-MASTER_SITE_SUBDIR= ${RUBY_DBI_MASTER_SITE_SUBDIR}
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= ruby-dbi
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ${RUBY_DBI_DISTNAME}
+DISTNAME= dbd-sqlite-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= SQLite driver for DBI-for-Ruby
LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2
-RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR}
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${PORTSDIR}/databases/ruby-dbi
USE_RUBY= yes
USE_RUBY_SETUP= yes
-SLAVE_PORT= yes
-MASTER_PORT= databases/ruby-dbi
-
-WRKSRC= ${RUBY_DBI_WRKSRC}
-CONFIGURE_ARGS= --with=ext/${PORTNAME}
-
-DOCS_EN= ext/${PORTNAME}/README
-
-.include "${.CURDIR}/../ruby-dbi/Makefile.common"
-
-post-patch:
- ${RUBY} -i- -pe "gsub 'dir_config \'sqlite\'', 'dir_config \'sqlite\', \'${LOCALBASE}\''" \
- ${WRKSRC}/ext/${PORTNAME}/extconf.rb
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
-.endif
-
.include <bsd.port.mk>
diff --git a/databases/ruby-dbd_sqlite/distinfo b/databases/ruby-dbd_sqlite/distinfo
new file mode 100644
index 000000000000..f13a57e55f67
--- /dev/null
+++ b/databases/ruby-dbd_sqlite/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/dbd-sqlite-0.1.2.tar.gz) = 1ff9dbdc4157843024db1ca193efe966
+SHA256 (ruby/dbd-sqlite-0.1.2.tar.gz) = b06909b0733fdb4ee82a457e7fd9e9c37fcc5adac5a64b82426a79dc203fbc85
+SIZE (ruby/dbd-sqlite-0.1.2.tar.gz) = 52681
diff --git a/databases/ruby-dbd_sqlite/pkg-plist b/databases/ruby-dbd_sqlite/pkg-plist
index 11f98966554a..ce2f725be03e 100644
--- a/databases/ruby-dbd_sqlite/pkg-plist
+++ b/databases/ruby-dbd_sqlite/pkg-plist
@@ -1,4 +1,5 @@
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
-%%RUBY_SITEARCHLIBDIR%%/DBD/SQLite/SQLite.so
-@dirrm %%RUBY_SITEARCHLIBDIR%%/DBD/SQLite
+%%RUBY_SITELIBDIR%%/dbd/SQLite.rb
+%%RUBY_SITELIBDIR%%/dbd/sqlite/database.rb
+%%RUBY_SITELIBDIR%%/dbd/sqlite/statement.rb
+@dirrm %%RUBY_SITELIBDIR%%/dbd/sqlite
+@dirrmtry %%RUBY_SITELIBDIR%%/dbd