aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-dbd_sqlrelay
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-11-15 13:23:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-11-15 13:23:38 +0000
commitea1365337bf5d1008989bc586f2de96db37a90f6 (patch)
tree5c70a0e3aa71b2997703b5e0c3c7b1891b430743 /databases/ruby-dbd_sqlrelay
parentc24a1a839bfeff576c8e4e79985c88db2eb7a33f (diff)
downloadports-ea1365337bf5d1008989bc586f2de96db37a90f6.tar.gz
ports-ea1365337bf5d1008989bc586f2de96db37a90f6.zip
Notes
Diffstat (limited to 'databases/ruby-dbd_sqlrelay')
-rw-r--r--databases/ruby-dbd_sqlrelay/Makefile31
-rw-r--r--databases/ruby-dbd_sqlrelay/pkg-comment1
-rw-r--r--databases/ruby-dbd_sqlrelay/pkg-descr4
-rw-r--r--databases/ruby-dbd_sqlrelay/pkg-plist2
4 files changed, 38 insertions, 0 deletions
diff --git a/databases/ruby-dbd_sqlrelay/Makefile b/databases/ruby-dbd_sqlrelay/Makefile
new file mode 100644
index 000000000000..92e5b8c54850
--- /dev/null
+++ b/databases/ruby-dbd_sqlrelay/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: dbd_sqlrelay for DBD-for-Ruby
+# Date created: 15 November 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbd_sqlrelay
+PORTVERSION= ${RUBY_DBI_PORTVERSION}
+CATEGORIES= databases ruby
+MASTER_SITES= ${RUBY_DBI_MASTER_SITES}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_DBI_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR} \
+ ${RUBY_SITEARCHLIBDIR}/SQLRelay.so:${.CURDIR}/../ruby-sqlrelay
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+WRKSRC= ${RUBY_DBI_WRKSRC}
+CONFIGURE_ARGS= --with=lib/${PORTNAME}
+
+DOCS_EN= lib/${PORTNAME}/doc/*
+
+.include "${.CURDIR}/../ruby-dbi/Makefile.common"
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-dbd_sqlrelay/pkg-comment b/databases/ruby-dbd_sqlrelay/pkg-comment
new file mode 100644
index 000000000000..c4d951be6163
--- /dev/null
+++ b/databases/ruby-dbd_sqlrelay/pkg-comment
@@ -0,0 +1 @@
+SQLRelay driver for DBI-for-Ruby
diff --git a/databases/ruby-dbd_sqlrelay/pkg-descr b/databases/ruby-dbd_sqlrelay/pkg-descr
new file mode 100644
index 000000000000..d2c872591c06
--- /dev/null
+++ b/databases/ruby-dbd_sqlrelay/pkg-descr
@@ -0,0 +1,4 @@
+This is the SQLRelay driver for DBI-for-Ruby.
+
+Author: Rainer Perl <rainer.perl@sprytech.com>
+WWW: http://www.ruby-projects.org/dbi/
diff --git a/databases/ruby-dbd_sqlrelay/pkg-plist b/databases/ruby-dbd_sqlrelay/pkg-plist
new file mode 100644
index 000000000000..ae8c8de9ab74
--- /dev/null
+++ b/databases/ruby-dbd_sqlrelay/pkg-plist
@@ -0,0 +1,2 @@
+%%RUBY_SITELIBDIR%%/DBD/SQLRelay/SQLRelay.rb
+@dirrm %%RUBY_SITELIBDIR%%/DBD/SQLRelay