aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-postgres/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-04-07 11:51:41 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-04-07 11:51:41 +0000
commitb1c59538fc35d442e62c7023a52a63ab7e13bc53 (patch)
treeab7ba35742cf3f0d8b730601f35f0e900affab25 /databases/ruby-postgres/Makefile
parent84d63d8e684a927527989ec48c7fbdcaf820b440 (diff)
downloadports-b1c59538fc35d442e62c7023a52a63ab7e13bc53.tar.gz
ports-b1c59538fc35d442e62c7023a52a63ab7e13bc53.zip
Notes
Diffstat (limited to 'databases/ruby-postgres/Makefile')
-rw-r--r--databases/ruby-postgres/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/databases/ruby-postgres/Makefile b/databases/ruby-postgres/Makefile
new file mode 100644
index 000000000000..55f49862c3ba
--- /dev/null
+++ b/databases/ruby-postgres/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: ruby-postgres
+# Date created: 19 April 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgres
+PORTVERSION= 0.7.9.2008.01.28
+CATEGORIES= databases ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ruby-pg
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Ruby interface to PostgreSQL library
+
+USE_PGSQL= yes
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+CONFIGURE_ARGS= --with-pgsql-include-dir="${LOCALBASE}/include"
+INSTALL_TARGET= site-install
+WRKSRC= ${WRKDIR}/${PORTNAME}/ext
+
+DOCS_EN= ChangeLog README doc/postgres.html
+DOCS_JA= README.ja doc/postgres.jp.html
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../sample/*.rb ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>