aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-xapian/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-14 22:40:46 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-14 22:40:46 +0000
commit6b9eb105af4ab65fae58c42e7734157ea7402cb8 (patch)
treed82325d38ba8d6cc496622dc5fa9851f003cc872 /databases/ruby-xapian/Makefile
parent5713da2bc79744917b6a3fe9ee23c43ba5a50a5c (diff)
downloadports-6b9eb105af4ab65fae58c42e7734157ea7402cb8.tar.gz
ports-6b9eb105af4ab65fae58c42e7734157ea7402cb8.zip
Notes
Diffstat (limited to 'databases/ruby-xapian/Makefile')
-rw-r--r--databases/ruby-xapian/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/databases/ruby-xapian/Makefile b/databases/ruby-xapian/Makefile
index 9140eb33d3b0..cea781715be8 100644
--- a/databases/ruby-xapian/Makefile
+++ b/databases/ruby-xapian/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xapian
-PORTVERSION= 1.4.9
-PORTREVISION= 1
+PORTVERSION= 1.4.10
DISTVERSIONPREFIX= bindings-
CATEGORIES= databases ruby
MASTER_SITES= https://oligarchy.co.uk/xapian/${PORTVERSION}/ \
@@ -28,10 +27,20 @@ PORTSCOUT= limitw:1,even
USES= compiler:c++11-lang libtool tar:xz
USE_RUBY= yes
-CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
- --enable-static --with-ruby \
- --without-csharp --without-java --without-lua --without-perl \
- --without-php --without-python --without-python3 --without-tcl
+CONFIGURE_ARGS= --datarootdir=${DATADIR} \
+ --docdir=${DOCSDIR} \
+ --enable-shared \
+ --enable-static \
+ --with-ruby \
+ --without-csharp \
+ --without-java \
+ --without-lua \
+ --without-perl \
+ --without-php \
+ --without-php7 \
+ --without-python \
+ --without-python3 \
+ --without-tcl
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_CXXSTD= c++11