aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-activerecord4
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-09-14 02:06:58 +0000
committerSteve Wills <swills@FreeBSD.org>2014-09-14 02:06:58 +0000
commit28071e639803800705a6938642ba75b31f925b45 (patch)
tree80b3dcb025ec943583a478981072ebc0ef107aa8 /databases/rubygem-activerecord4
parentec6354100bcad612065a1c296b7176385d726ed5 (diff)
downloadports-28071e639803800705a6938642ba75b31f925b45.tar.gz
ports-28071e639803800705a6938642ba75b31f925b45.zip
Notes
Diffstat (limited to 'databases/rubygem-activerecord4')
-rw-r--r--databases/rubygem-activerecord4/Makefile23
-rw-r--r--databases/rubygem-activerecord4/distinfo2
-rw-r--r--databases/rubygem-activerecord4/pkg-descr8
3 files changed, 33 insertions, 0 deletions
diff --git a/databases/rubygem-activerecord4/Makefile b/databases/rubygem-activerecord4/Makefile
new file mode 100644
index 000000000000..efc930c7d9a7
--- /dev/null
+++ b/databases/rubygem-activerecord4/Makefile
@@ -0,0 +1,23 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= activerecord
+PORTVERSION= 4.1.6
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 4
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Object-relational mapping layer for Rails MVC Framework
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-activemodel4>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-activemodel4 \
+ rubygem-activesupport4>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport4 \
+ rubygem-arel>=5.0.0:${PORTSDIR}/databases/rubygem-arel
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activerecord4/distinfo b/databases/rubygem-activerecord4/distinfo
new file mode 100644
index 000000000000..f611da1f8e36
--- /dev/null
+++ b/databases/rubygem-activerecord4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/activerecord-4.1.6.gem) = 87262b9e83b76ea4adaaf7941de0472eda1f1097159e2894aea7edc7d5134797
+SIZE (rubygem/activerecord-4.1.6.gem) = 314368
diff --git a/databases/rubygem-activerecord4/pkg-descr b/databases/rubygem-activerecord4/pkg-descr
new file mode 100644
index 000000000000..a3b3e25dfd1a
--- /dev/null
+++ b/databases/rubygem-activerecord4/pkg-descr
@@ -0,0 +1,8 @@
+Action Record
+
+In Rails, the model is handled by what's called a object-relational
+mapping layer entitled Active Record. This layer allows you to present
+the data from database rows as objects and embellish these data objects
+with business logic methods.
+
+WWW: http://www.rubyonrails.org