aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-sqlite3/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-06-26 03:47:13 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-06-26 03:47:13 +0000
commit703bbb782630b13db9404cf2c4e9907b02370792 (patch)
tree050da9323d4879e7f6fcdfd9c1dd180a12e0f228 /databases/rubygem-sqlite3/Makefile
parent14b084463461cfccecafc273b23661bace0955ab (diff)
Add ruby-sqlite, (another) Ruby interface to the SQLite DB engine.
Notes
Notes: svn path=/head/; revision=83620
Diffstat (limited to 'databases/rubygem-sqlite3/Makefile')
-rw-r--r--databases/rubygem-sqlite3/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/databases/rubygem-sqlite3/Makefile b/databases/rubygem-sqlite3/Makefile
new file mode 100644
index 000000000000..e15082239aa7
--- /dev/null
+++ b/databases/rubygem-sqlite3/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: sqlite-ruby
+# Date created: 26 June 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlite
+PORTVERSION= 1.0
+CATEGORIES= databases ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}-ruby
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby interface to the SQLite DB engine
+
+LIB_DEPENDS= sqlite.2:${.CURDIR}/../sqlite
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/samples/* ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}/
+.endif
+
+.include <bsd.port.mk>