aboutsummaryrefslogtreecommitdiff
path: root/databases/sixpack/Makefile
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2001-07-10 11:09:59 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2001-07-10 11:09:59 +0000
commita9f84711ca18db71dbc34eaa43212c7dadd034b7 (patch)
tree28e7cec670b539965f096091e285bb2a280cae56 /databases/sixpack/Makefile
parentb9d78ac47f4ba4b5035bbccebe6a1ae137945c69 (diff)
Notes
Diffstat (limited to 'databases/sixpack/Makefile')
-rw-r--r--databases/sixpack/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/databases/sixpack/Makefile b/databases/sixpack/Makefile
new file mode 100644
index 000000000000..292f6f67a932
--- /dev/null
+++ b/databases/sixpack/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sixpack
+# Date created: July 10th 2001
+# Whom: des
+#
+# $FreeBSD$
+#
+
+PORTNAME= sixpack
+PORTVERSION= 0.99.001216
+CATEGORIES= databases
+MASTER_SITES= http://www.santafe.edu/~dirk/sixpack/Download/
+
+MAINTAINER= des@FreeBSD.org
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget \
+ ptksh:${PORTSDIR}/x11-toolkits/p5-Tk
+
+NO_BUILD= yes
+
+USE_PERL5= yes
+
+#MAN8= porteasy.8
+
+post-extract:
+ (cd ${WRKSRC} && ${TAR} zxf bp-0.2.97.tar.gz)
+
+do-configure:
+ ${PERL} -p -i -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/install
+ ${PERL} -p -i -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/install
+ ${PERL} -p -i -e 's|%%DOCSDIR%%|${DOCSDIR}|' ${WRKSRC}/install
+
+do-install:
+ (cd ${WRKSRC} && ${SH} install with-bp with-mod)
+
+.include <bsd.port.mk>