aboutsummaryrefslogtreecommitdiff
path: root/databases/slony1v2/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2014-07-08 13:25:24 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2014-07-08 13:25:24 +0000
commit403d5e11a875249f9ec7cc1ce6de076a0118b9d9 (patch)
tree1ad3a84afa9ab053198a3b4a9f56d8e85513a69e /databases/slony1v2/Makefile
parent80c6af6ba896892ee01dfe85e3c3411e3bb1463a (diff)
downloadports-403d5e11a875249f9ec7cc1ce6de076a0118b9d9.tar.gz
ports-403d5e11a875249f9ec7cc1ce6de076a0118b9d9.zip
Notes
Diffstat (limited to 'databases/slony1v2/Makefile')
-rw-r--r--databases/slony1v2/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 47f1874a6d04..d54d785d5425 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= slony1v2
-PORTVERSION= 2.2.2
+PORTVERSION= 2.2.3
CATEGORIES= databases
MASTER_SITES= http://main.slony.info/downloads/2.2/source/
DISTNAME= slony1-${PORTVERSION}
@@ -16,10 +16,10 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
GNU_CONFIGURE= yes
-USES= bison gmake
+USES= bison gmake shebangfix tar:bzip2
USE_PGSQL= yes
-USE_BZIP2= yes
USE_RC_SUBR= slon
+SHEBANG_FILES= tools/altperl/slonik_restart_node.pl
SUB_FILES= pkg-message slon-mkservice.sh
SUB_LIST+= NAME=slon
@@ -79,6 +79,10 @@ post-patch:
done
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/slon
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/slonik
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/slony_logshipper
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/*.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}/adminguide
.for _file in ${DOCS}