aboutsummaryrefslogtreecommitdiff
path: root/databases/slony1v2
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-06-28 22:07:53 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-06-28 22:07:53 +0000
commit957493e83b61b7b153eef1d02f8380f004f00d3a (patch)
tree0688c46a2c7e3cd95fe0de9fe79fc9f4008ae12f /databases/slony1v2
parent10b5ded080351531c82acebc0da4d8d004a7ded0 (diff)
downloadports-957493e83b61b7b153eef1d02f8380f004f00d3a.tar.gz
ports-957493e83b61b7b153eef1d02f8380f004f00d3a.zip
Notes
Diffstat (limited to 'databases/slony1v2')
-rw-r--r--databases/slony1v2/Makefile62
-rw-r--r--databases/slony1v2/distinfo2
-rw-r--r--databases/slony1v2/files/extra-GNUmakefile.in11
-rw-r--r--databases/slony1v2/files/patch-builddocs14
-rw-r--r--databases/slony1v2/pkg-descr13
-rw-r--r--databases/slony1v2/pkg-message8
6 files changed, 110 insertions, 0 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
new file mode 100644
index 000000000000..b2598a9d4d48
--- /dev/null
+++ b/databases/slony1v2/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: slony1
+# Date created: 20 Jun 2004
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= slony1
+PORTVERSION= 1.0.0.b3
+CATEGORIES= databases
+MASTER_SITES= http://developer.postgresql.org/~wieck/slony1/download/
+DISTNAME= slony1-1.0.0.beta3
+
+MAINTAINER= hsn@netmag.cz
+COMMENT= PostgreSQL master to multiple slaves replication system
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/databases/postgresql7:configure
+.if ! defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/pnmtops:${PORTSDIR}/graphics/netpbm \
+ ${LOCALBASE}/bin/djpeg:${PORTSDIR}/graphics/jpeg \
+ ${LOCALBASE}/bin/ps2pdf:${PORTSDIR}/print/ghostscript-gnu
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-GNUmakefile.in
+.endif
+RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql7
+
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+PGSQL_SRC= `cd ${PORTSDIR}/databases/postgresql7; make -V WRKSRC`
+CONFIGURE_ARGS= --with-pgsourcetree=${PGSQL_SRC}
+
+PLIST_FILES= bin/slon bin/slonik bin/slony_setup.pl \
+ lib/postgresql/slony1_funcs.so lib/postgresql/xxid.so \
+ share/postgresql/slony1_base.sql \
+ share/postgresql/slony1_funcs.sql \
+ share/postgresql/slony1_base.v73.sql \
+ share/postgresql/slony1_base.v74.sql \
+ share/postgresql/slony1_funcs.v73.sql \
+ share/postgresql/slony1_funcs.v74.sql \
+ share/postgresql/xxid.v73.sql \
+ share/postgresql/xxid.v74.sql
+PORTDOCS= *.pdf howto/*.txt COPYRIGHT README
+
+pre-configure:
+ cd ${PGSQL_SRC}/src/interfaces/libpq && ${GMAKE} all
+ cd ${PGSQL_SRC}/src/port && ${GMAKE} all
+
+do-install:
+ cd ${WRKSRC} && ${GMAKE} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/tools/slony_setup.pl ${PREFIX}/bin
+.if ! defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/concept/Slony-I-concept.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/implementation/Slony-I-implementation.pdf ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/howto
+ ${INSTALL_DATA} ${WRKSRC}/doc/howto/*.txt ${DOCSDIR}/howto
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/databases/slony1v2/distinfo b/databases/slony1v2/distinfo
new file mode 100644
index 000000000000..5a98eeb64aa4
--- /dev/null
+++ b/databases/slony1v2/distinfo
@@ -0,0 +1,2 @@
+MD5 (slony1-1.0.0.beta3.tar.gz) = ec82bf0a0374a232f87ff71ddfc7be7c
+SIZE (slony1-1.0.0.beta3.tar.gz) = 317494
diff --git a/databases/slony1v2/files/extra-GNUmakefile.in b/databases/slony1v2/files/extra-GNUmakefile.in
new file mode 100644
index 000000000000..304d79893b6a
--- /dev/null
+++ b/databases/slony1v2/files/extra-GNUmakefile.in
@@ -0,0 +1,11 @@
+--- GNUmakefile.in.orig Thu Jun 10 11:09:18 2004
++++ GNUmakefile.in Mon Jun 28 02:16:04 2004
+@@ -25,7 +25,7 @@
+ $(wildcard makefiles/*)
+
+
+-SUBDIRS = src doc
++SUBDIRS = src
+
+ all:
+ for subdir in $(SUBDIRS) ; do \
diff --git a/databases/slony1v2/files/patch-builddocs b/databases/slony1v2/files/patch-builddocs
new file mode 100644
index 000000000000..3dfeb8ecc058
--- /dev/null
+++ b/databases/slony1v2/files/patch-builddocs
@@ -0,0 +1,14 @@
+--- doc/Makefile.orig Thu Mar 18 20:32:21 2004
++++ doc/Makefile Wed Jun 23 17:30:53 2004
+@@ -15,9 +15,9 @@
+
+ DISTFILES = Makefile
+
+-all install installdirs:
++install installdirs:
+
+-clean distclean maintainer-clean:
++all clean distclean maintainer-clean:
+ for subdir in $(SUBDIRS) ; do \
+ $(MAKE) -C $$subdir $@ ; \
+ done
diff --git a/databases/slony1v2/pkg-descr b/databases/slony1v2/pkg-descr
new file mode 100644
index 000000000000..cf3c4368fdee
--- /dev/null
+++ b/databases/slony1v2/pkg-descr
@@ -0,0 +1,13 @@
+Slony-I will be a "master to multiple slaves" replication
+system with cascading and failover.
+
+The big picture for the development of Slony-I is to build
+a master-slave system that includes all features and
+capabilities needed to replicate large databases to a
+reasonably limited number of slave systems.
+
+Slony-I is planned as a system for data centers and backup
+sites, where the normal mode of operation is that all nodes
+are available.
+
+WWW: http://www.slony.org/
diff --git a/databases/slony1v2/pkg-message b/databases/slony1v2/pkg-message
new file mode 100644
index 000000000000..868751ad5e6f
--- /dev/null
+++ b/databases/slony1v2/pkg-message
@@ -0,0 +1,8 @@
+For running slony you need:
+ slony system user
+ slony postgresql superuser
+ postgresql with TCP/IP communication enabled
+
+There is a perl script slony_setup.pl which helps you to create initial
+configuration. Installing this package do not makes any needed system
+changes.