aboutsummaryrefslogtreecommitdiff
path: root/databases/spatialite/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-05-24 01:30:23 +0000
committerWen Heping <wen@FreeBSD.org>2012-05-24 01:30:23 +0000
commit52b4e22cc81e2cb17c1fc6a9998bd351e8b60b1b (patch)
tree8702eb9b46ff5988179e6d2cc96ec14ce0093ea9 /databases/spatialite/Makefile
parenta6216715a1589b502d3b2142bbe9c2c6f5d32afe (diff)
downloadports-52b4e22cc81e2cb17c1fc6a9998bd351e8b60b1b.tar.gz
ports-52b4e22cc81e2cb17c1fc6a9998bd351e8b60b1b.zip
Notes
Diffstat (limited to 'databases/spatialite/Makefile')
-rw-r--r--databases/spatialite/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/databases/spatialite/Makefile b/databases/spatialite/Makefile
index 92e7f48ccd0d..ad3b724f3fa6 100644
--- a/databases/spatialite/Makefile
+++ b/databases/spatialite/Makefile
@@ -6,27 +6,32 @@
#
PORTNAME= spatialite
-PORTVERSION= 2.2
-PORTREVISION= 7
+PORTVERSION= 3.0.1
CATEGORIES= databases geography
-MASTER_SITES= http://www.gaia-gis.it/${PORTNAME}-${PORTVERSION}/
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+DISTNAME= lib${PORTNAME}-${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Spatial Extensions for SQLite
LIB_DEPENDS= geos_c.8:${PORTSDIR}/graphics/geos \
proj.7:${PORTSDIR}/graphics/proj \
- iconv.3:${PORTSDIR}/converters/libiconv
+ freexl.1:${PORTSDIR}/textproc/freexl
+EXTRACT_SUFX = .tar.gz
+WRKSRC= ${WRKDIR}/lib${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
-CONFIGURE_ARGS+=CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_SQLITE= yes
+USE_ICONV= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+=CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
post-patch:
- @${REINPLACE_CMD} -e 's#-ldl##g' ${WRKSRC}/src/sqlite3/Makefile.in
- @${REINPLACE_CMD} -e 's#-ldl##g' ${WRKSRC}/src/shell/Makefile.in
-
+ @${REINPLACE_CMD} -e 's|-ldl| |' ${WRKSRC}/src/Makefile.am
+ @${REINPLACE_CMD} -e 's|-ldl| |' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|-ldl| |' ${WRKSRC}/configure
.include <bsd.port.mk>