aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlclient
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-04-09 07:44:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-04-09 07:44:41 +0000
commit06f79b66f2eb028c4ab81977dcb1e010ef9cf946 (patch)
treeb7aed86ac84412d11603ce23b7893d46f0d7475b /databases/sqlclient
parent5c3f57fd49a53ee36e7a7bc6263e4dd1fd331c27 (diff)
downloadports-06f79b66f2eb028c4ab81977dcb1e010ef9cf946.tar.gz
ports-06f79b66f2eb028c4ab81977dcb1e010ef9cf946.zip
Notes
Diffstat (limited to 'databases/sqlclient')
-rw-r--r--databases/sqlclient/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/databases/sqlclient/Makefile b/databases/sqlclient/Makefile
index 9a3fe1b181de..6b7db35b2795 100644
--- a/databases/sqlclient/Makefile
+++ b/databases/sqlclient/Makefile
@@ -13,24 +13,20 @@ COMMENT= Lightweight database abstraction layer
LICENSE= LGPL21
-USE_GNUSTEP= yes
-USE_GNUSTEP_BASE= yes
-USE_GNUSTEP_CONFIGURE= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LOCAL_LIBS+= Performance:${PERFORMANCE_PORT}
-USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
-USES+= pgsql
+LIB_DEPENDS= libPerformance.so:${PORTSDIR}/devel/performance \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3
+
+USES= gnustep pgsql
+USE_GNUSTEP= base build
+GNU_CONFIGURE= yes
+USE_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
USE_MYSQL=yes
-USE_SQLITE=yes
-LDFLAGS+= -lpthread
+LDFLAGS+= -pthread
MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${GNUSTEP_LOCAL_ROOT}
DEFAULT_LIBVERSION= 1.5
DEFAULT_LIBVERSION2= 1.5.0
PLIST_SUB+= LIBVERSION2=${DEFAULT_LIBVERSION2}
PLIST_SUB+= MAJORLIBVERSION2=${DEFAULT_LIBVERSION2:C/([0-9]).*/\1/1}
-PERFORMANCE_PORT?= devel/performance
-
.include <bsd.port.mk>