aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 21:51:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 21:51:43 +0000
commit5e34f29bc83de1e8d1945cba6c2df4cb5a2d7a72 (patch)
treed8adf73a5c043a0c8cc9655b3619027ba54c1f24 /databases/sqlite2/Makefile
parent8fec686c29f419dc24441aa8f58c29b4a9991eee (diff)
downloadports-5e34f29bc83de1e8d1945cba6c2df4cb5a2d7a72.tar.gz
ports-5e34f29bc83de1e8d1945cba6c2df4cb5a2d7a72.zip
Notes
Diffstat (limited to 'databases/sqlite2/Makefile')
-rw-r--r--databases/sqlite2/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index 45525057e510..816948a3ba32 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= SQL database engine in a C library
-USES= gmake pkgconfig
+USES= gmake pkgconfig readline
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
@@ -19,12 +19,14 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
DOCSDIR= ${PREFIX}/share/doc/sqlite2
EXAMPLESDIR= ${PREFIX}/share/examples/sqlite2
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}2
-
EXTRACT_AFTER_ARGS= --exclude CVS
OPTIONS_DEFINE= TCL THREADS DOCS
+.if !exists(/usr/lib/libreadline.so)
+MAKE_ARGS= READLINE_FLAGS="-DHAVE_READLINE=1 -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+.endif
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTCL}