aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-11 21:54:45 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-11 21:54:45 +0000
commited98d435ba4a92a059c4eaa3a87b06c3b6daf11b (patch)
treee228cb2b9957706dc61a701b8e562b2c3a1de034 /databases/sqlite2/Makefile
parent778554627428496faf4df403225eee72d5d3f1e2 (diff)
downloadports-ed98d435ba4a92a059c4eaa3a87b06c3b6daf11b.tar.gz
ports-ed98d435ba4a92a059c4eaa3a87b06c3b6daf11b.zip
Notes
Diffstat (limited to 'databases/sqlite2/Makefile')
-rw-r--r--databases/sqlite2/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index b4f20bcdd6d5..3732da434b3c 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -3,18 +3,18 @@
PORTNAME= sqlite
PORTVERSION= 2.8.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= SQL database engine in a C library
-USES= gmake pkgconfig readline
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+USES= gmake libtool pkgconfig readline
USE_LDCONFIG= YES
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
+CONFIGURE_ARGS= --with-hints=freebsd.hints
DOCSDIR= ${PREFIX}/share/doc/sqlite2
EXAMPLESDIR= ${PREFIX}/share/examples/sqlite2
@@ -55,7 +55,7 @@ MAKE_ENV+= TCL_VER=${TCL_VER}
post-patch:
@${REINPLACE_CMD} -e "s/tclsh \$$(TOP)/\$$(TCLSH) \$$(TOP)/g" \
- -e "s|\./libtool|${LIBTOOL}|g" ${WRKSRC}/Makefile.in
+ ${WRKSRC}/Makefile.in
.if ${PORT_OPTIONS:MTCL} || !empty(PORT_OPTIONS:MDOCS)
@${ECHO} "config_TARGET_TCL_INC=\"-I${TCL_INCLUDEDIR}\"" \
> ${WRKSRC}/freebsd.hints