aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite34/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-02-10 00:07:20 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-02-10 00:07:20 +0000
commit300435f077a71bf83897fa137a66b63acdf20b6c (patch)
tree5a048a3fce89ae98787c88fd5d7c12e0a93f19cd /databases/sqlite34/Makefile
parent382d742fc3b8eb853f737f3febf87044898cd516 (diff)
- Update to 3.3.3 [1]
- Reorganize Makefile Submitted by: cokane [1]
Notes
Notes: svn path=/head/; revision=155614
Diffstat (limited to 'databases/sqlite34/Makefile')
-rw-r--r--databases/sqlite34/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/databases/sqlite34/Makefile b/databases/sqlite34/Makefile
index 0c84e6203704..7901074ba9a6 100644
--- a/databases/sqlite34/Makefile
+++ b/databases/sqlite34/Makefile
@@ -11,7 +11,7 @@
# If you want to build the TCL wrapper, you have to define WITH_TCLWRAPPER=yes.
PORTNAME= sqlite
-PORTVERSION= 3.2.8
+PORTVERSION= 3.3.3
CATEGORIES= databases
MASTER_SITES= http://www.sqlite.org/
@@ -21,25 +21,24 @@ COMMENT= An SQL database engine in a C library w/ Tcl wrapper
USE_GMAKE= YES
USE_GNOME= pkgconfig
USE_AUTOTOOLS= libtool:15
-HAS_CONFIGURE= YES
-USE_REINPLACE= YES
INSTALLS_SHLIB= YES
-
+GNU_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-PORTDOCS= *
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}3
+
+OPTIONS= TCLWRAPPER "TCL wrapper for SQLITE" off
+
DOCSDIR= ${PREFIX}/share/doc/sqlite3
EXAMPLESDIR= ${PREFIX}/share/examples/sqlite3
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}3
+PORTDOCS= *
# Defaults, for building the docs:
TCL_V?= 8.4
MAKE_ARGS+= TCLSH=tclsh${TCL_V}
MAKE_ENV+= TCL_VER=${TCL_V}
-OPTIONS= TCLWRAPPER "TCL wrapper for SQLITE" off
-
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)