aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite3
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:43:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:43:46 +0000
commit14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3 (patch)
tree761cd23e07e2b5224d73f540985d84eede599029 /databases/sqlite3
parent7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0 (diff)
downloadports-14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3.tar.gz
ports-14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3.zip
Notes
Diffstat (limited to 'databases/sqlite3')
-rw-r--r--databases/sqlite3/Makefile73
1 files changed, 37 insertions, 36 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 052c9e0dd0eb..b12d43d35901 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -17,29 +17,32 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
CONFLICTS= sqlite34-[0-9]* sqlcipher-*
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= build
USE_LDCONFIG= YES
GNU_CONFIGURE= YES
MAKE_JOBS_UNSAFE= yes
# Compilation Options For SQLite http://www.sqlite.org/compile.html
-OPTIONS= \
- FTS3 "Enable FTS3/4 (Full Text Search) module" on \
- ICU "Enable built with ICU" off \
- RTREE "Enable R*Tree module (${RTREE_INT})" off \
- RAMTABLE "Store temporary tables in RAM = ${TEMP_STORE}" off \
- UPD_DEL_LIMIT "ORDER BY and LIMIT on UPDATE and DELETE" off \
- URI "Enable use the URI filename" on \
- SOUNDEX "Enables the soundex() SQL function" off \
- METADATA "Enable column metadata" on \
- STAT3 "Help SQLite to chose a better query plan" off \
- DIRECT_READ "File is read directly from disk" off \
- MEMMAN "Allows it to release unused memory" off \
- SECURE_DELETE "Overwrite deleted information with zeros" on \
- UNLOCK_NOTIFY "Enable notification on unlocking" on \
- THREADSAFE "Build thread-safe library" on \
- EXTENSION "Allow loadable extensions" on \
+OPTIONS_DEFINE= FTS3 ICU RTREE RAMTABLE UPD_DEL_LIMIT URI SOUNDEX METADATA \
+ STAT3 DIRECT_READ MEMMAN SECURE_DELETE UNLOCK_NOTIFY THREADSAFE \
+ EXTENSION
+OPTIONS_DEFAULT= FTS3 SECURE_DELETE THREADSAFE EXTENSION
+FTS3_DESC= Enable FTS3/4 (Full Text Search) module
+ICU_DESC= Enable built with ICU
+RTREE_DESC= Enable R*Tree module (${RTREE_INT})
+RAMTABLE_DESC= Store temporary tables in RAM = ${TEMP_STORE}
+UPD_DEL_LIMIT_DESC= ORDER BY and LIMIT on UPDATE and DELETE
+URI_DESC= Enable use the URI filename
+SOUNDEX_DESC= Enables the soundex() SQL function
+METADATA_DESC= Enable column metadata
+STAT3_DESC= Help SQLite to chose a better query plan
+DIRECT_READ_DESC= File is read directly from disk
+MEMMAN_DESC= Allows it to release unused memory
+SECURE_DELETE_DESC= Overwrite deleted information with zeros
+UNLOCK_NOTIFY_DESC= Enable notification on unlocking
+THREADSAFE_DESC= Build thread-safe library
+EXTENSION_DESC= Allow loadable extensions
.include <bsd.port.options.mk>
@@ -55,7 +58,7 @@ MAN1= sqlite3.1
# Some devices are compelled to use an older file system with 8+3 filename
# restrictions for backwards compatibility, or due to other non-technical factors.
# http://www.sqlite.org/shortnames.html
-.if defined(WITH_NAME83)
+.if ${PORT_OPTIONS:MNAME83}
CPPFLAGS+= -DSQLITE_ENABLE_8_3_NAMES=1
.endif
@@ -72,35 +75,35 @@ CPPFLAGS+= -DSQLITE_DEFAULT_FILE_PERMISSIONS=${DEFAULT_FILE_PERMISSIONS}
CPPFLAGS+= -DSQLITE_DEFAULT_TEMP_CACHE_SIZE=${TEMP_CACHE_SIZE}
.endif
-.if defined(WITH_MEMMAN)
+.if ${PORT_OPTIONS:MMEMMAN}
CPPFLAGS+= -DSQLITE_ENABLE_MEMORY_MANAGEMENT=1
.endif
-.if defined(WITH_UPD_DEL_LIMIT)
+.if ${PORT_OPTIONS:MUPD_DEL_LIMIT}
CPPFLAGS+= -DSQLITE_ENABLE_UPDATE_DELETE_LIMIT=1
.endif
-.if defined(WITH_URI)
+.if ${PORT_OPTIONS:MURI}
CPPFLAGS+= -DSQLITE_USE_URI=1
.endif
-.if defined(WITH_SOUNDEX)
+.if ${PORT_OPTIONS:MSOUNDEX}
CPPFLAGS+= -DSQLITE_SOUNDEX=1
.endif
-.if defined(WITH_STAT3)
+.if ${PORT_OPTIONS:MSTAT3}
CPPFLAGS+= -DSQLITE_ENABLE_STAT3=1
.endif
-.if defined(WITH_DIRECT_READ)
+.if ${PORT_OPTIONS:MDIRECT_READ}
CPPFLAGS+= -DSQLITE_DIRECT_OVERFLOW_READ=1
.endif
-.if defined(WITH_FTS3)
+.if ${PORT_OPTIONS:MFTS3}
CPPFLAGS+= -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_FTS3_PARENTHESIS=1 -DSQLITE_ENABLE_FTS4=1
.endif
-.if defined(WITH_RTREE)
+.if ${PORT_OPTIONS:MRTREE}
CPPFLAGS+= -DSQLITE_ENABLE_RTREE=1
.ifdef RTREE_INT
CPPFLAGS+= -DSQLITE_RTREE_INT_ONLY=1
@@ -110,7 +113,7 @@ RTREE_INT= "float"
.endif
.endif
-.if defined(WITH_ICU)
+.if ${PORT_OPTIONS:MICU}
BUILD_DEPENDS+= ${LOCALBASE}/bin/icu-config:${PORTSDIR}/devel/icu
LIB_DEPENDS+= icudata:${PORTSDIR}/devel/icu
CPPFLAGS+= -DSQLITE_ENABLE_ICU=1
@@ -120,41 +123,39 @@ LDFLAGS+= `${LOCALBASE}/bin/icu-config --ldflags`
# Use an in-ram database for temporary tables (never,no,yes,always),
# which is equivalent of TEMP_STORE=[0,1,2,3], default = 1.
-.if defined(WITH_RAMTABLE)
+.if ${PORT_OPTIONS:MRAMTABLE}
TEMP_STORE?= 2
CPPFLAGS+= -DSQLITE_TEMP_STORE=${TEMP_STORE}
.endif
-.if defined(WITH_SECURE_DELETE)
+.if ${PORT_OPTIONS:MSECURE_DELETE}
CPPFLAGS+= -DSQLITE_SECURE_DELETE=1
.endif
-.if defined(WITH_UNLOCK_NOTIFY)
+.if ${PORT_OPTIONS:MUNLOCK_NOTIFY}
CPPFLAGS+= -DSQLITE_ENABLE_UNLOCK_NOTIFY=1
.endif
-.if !defined(WITHOUT_METADATA)
+.if ${PORT_OPTIONS:MMETADATA}
CPPFLAGS+= -DSQLITE_ENABLE_COLUMN_METADATA=1
.endif
-.if !defined(WITHOUT_THREADSAFE)
+.if ${PORT_OPTIONS:MTHREADSAFE}
CONFIGURE_ARGS+= --enable-threadsafe
LDFLAGS+= ${PTHREAD_LIBS}
.else
CONFIGURE_ARGS+= --disable-threadsafe
.endif
-.if !defined(WITHOUT_EXTENSION)
+.if ${PORT_OPTIONS:MEXTENSION}
CONFIGURE_ARGS+= --enable-dynamic-extensions
.else
CONFIGURE_ARGS+= --disable-dynamic-extensions
.endif
-.include <bsd.port.pre.mk>
-
post-install:
.if !defined(NO_INSTALL_MANPAGES)
@${INSTALL_MAN} ${WRKSRC}/sqlite3.1 ${MANPREFIX}/man/man1
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>