aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite3
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-12-25 17:17:36 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-12-25 17:17:36 +0000
commitdfb7ea9e3f70948e138845ae7b159bae20bde1ba (patch)
tree21a37829ec03784228800698f9cfbb064d58ee20 /databases/sqlite3
parent686c692667cfe8c84b2fc7415a8ddd640eef2072 (diff)
Notes
Diffstat (limited to 'databases/sqlite3')
-rw-r--r--databases/sqlite3/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index bf9268108eb3..7c73f98571f5 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -18,11 +18,6 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-# Platform Configuration
-CFLAGS+= -Os
-CPPFLAGS+= -DHAVE_ISNAN=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_USLEEP=1
-CPPFLAGS+= ${OSVERSION<1000000:?:-DHAVE_STRCHRNUL=1}
-
MAKE_JOBS_UNSAFE= yes
# Compilation Options For SQLite https://www.sqlite.org/compile.html
@@ -174,6 +169,7 @@ ICU_LIB_DEPENDS= libicudata.so:devel/icu
ICU_CPPFLAGS= `${LOCALBASE}/bin/icu-config --cppflags` -DSQLITE_ENABLE_ICU=1
ICU_LIBS= `${LOCALBASE}/bin/icu-config --ldflags`
+UNICODE61_CPPFLAGS= ""
UNICODE61_CPPFLAGS_OFF= -DSQLITE_DISABLE_FTS3_UNICODE=1
READLINES_CONFIGURE_ON= --enable-readline
@@ -197,6 +193,15 @@ UNKNOWN_SQL_CPPFLAGS= -DSQLITE_ENABLE_UNKNOWN_SQL_FUNCTION=1
.include <bsd.port.options.mk>
+# Platform Configuration
+.if !defined(WITH_DEBUG)
+CFLAGS+= -Os
+.endif
+CPPFLAGS+= -DHAVE_ISNAN=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_USLEEP=1
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000029)
+CPPFLAGS+= -DHAVE_STRCHRNUL=1
+.endif
+
post-configure:
@${ECHO_MSG} "===> CONFIGURE_ARGS=${CONFIGURE_ARGS}"
@${ECHO_MSG} "===> CPPFLAGS=${CPPFLAGS}"