aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlrelay/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-10-27 17:54:01 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-10-27 17:54:01 +0000
commit6236125065fee2fc8e68f88560f5e6ffe0cef405 (patch)
treeb65c0390a881db41a819bdb684db0d720fe255dc /databases/sqlrelay/Makefile
parent2abe6efce7b02564679f3ea83537704cc7d84d09 (diff)
downloadports-6236125065fee2fc8e68f88560f5e6ffe0cef405.tar.gz
ports-6236125065fee2fc8e68f88560f5e6ffe0cef405.zip
Notes
Diffstat (limited to 'databases/sqlrelay/Makefile')
-rw-r--r--databases/sqlrelay/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index a6f24eb34f37..f93341310c2e 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -7,7 +7,6 @@
PORTNAME= ${SQLRELAY_PORTNAME}
PORTVERSION= ${SQLRELAY_PORTVERSION}
-PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://www.firstworks.com/downloads/sqlrelay/
@@ -17,6 +16,7 @@ LIB_DEPENDS= rudiments.0:${PORTSDIR}/devel/rudiments \
xml2.5:${PORTSDIR}/textproc/libxml2 \
iconv.3:${PORTSDIR}/converters/libiconv
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
@@ -136,10 +136,14 @@ post-extract:
${LN} -s ${LOCALBASE}/lib ${WRKDIR}/prefixes/libxml/lib
post-patch:
- ${PERL} -i -p \
- -e 's,/usr/local\b,${PREFIX},g;' \
- -e 's,\bgtk-config\b,${GTK_CONFIG:T},g;' \
+ ${REINPLACE_CMD} -E \
+ -e 's,/usr/local[[:>:]],${PREFIX},g;' \
+ -e 's,[[:<:]]gtk-config[[:>:]],${GTK_CONFIG:T},g;' \
${WRKSRC}/configure
+ ${REINPLACE_CMD} -E \
+ -e 's,\.so\.\$$\(SQLR_VERSION\),\.so\.$$(basename $$(SQLR_VERSION)),g;' \
+ ${WRKSRC}/src/api/c/src/Makefile \
+ ${WRKSRC}/src/api/c++/src/Makefile
post-install:
.if !defined(NOPORTDOCS)