aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlrelay/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-09-22 20:20:20 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-09-22 20:20:20 +0000
commitaf1ec3bd95114789b2cb53f5acd8a247cf83a8a2 (patch)
tree07dbbb23ec1fb865da9d8605956a2242184d75bb /databases/sqlrelay/Makefile
parentb83e28eedf02f1a5366e5ccd55490f7cc128cdef (diff)
downloadports-af1ec3bd95114789b2cb53f5acd8a247cf83a8a2.tar.gz
ports-af1ec3bd95114789b2cb53f5acd8a247cf83a8a2.zip
Notes
Diffstat (limited to 'databases/sqlrelay/Makefile')
-rw-r--r--databases/sqlrelay/Makefile50
1 files changed, 45 insertions, 5 deletions
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index c70459498791..774d30bb9570 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -3,20 +3,18 @@
PORTNAME= ${SQLRELAY_PORTNAME}
PORTVERSION= ${SQLRELAY_PORTVERSION}
-PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pi@FreeBSD.org
COMMENT= Persistent DB connection pooling/proxying/load balancing system
LIB_DEPENDS= librudiments.so:${PORTSDIR}/devel/rudiments
-BROKEN= Does not build
WANT_GNOME= yes
-USES= gmake
-USE_AUTOTOOLS= autoconf libtool
+USES= gmake autoreconf libtool
CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
CONFIGURE_ENV= ${SQLRELAY_CONFIGURE_ENV}
CONFIGURE_ARGS= ${SQLRELAY_CONFIGURE_ARGS} \
--disable-tcl \
@@ -26,12 +24,48 @@ CONFIGURE_ARGS= ${SQLRELAY_CONFIGURE_ARGS} \
--disable-php \
--disable-python \
--disable-ruby \
+ --disable-erlang \
--disable-zope
MAKE_JOBS_UNSAFE=yes
USE_LDCONFIG= yes
PORTDOCS= *
+TOSTRIP= bin/sqlr-start \
+ bin/sqlr-listener \
+ bin/sqlr-connection \
+ bin/sqlr-scaler \
+ bin/sqlr-cachemanager \
+ bin/sqlr-fields \
+ bin/sqlr-query \
+ bin/sqlr-export \
+ bin/sqlr-import \
+ bin/sqlr-pwdenc \
+ bin/sqlr-status \
+ bin/sqlrsh \
+ lib/libsqlrutil.so.0.0.0 \
+ lib/libsqlrclient.so.0.0.0 \
+ lib/libsqlrclientwrapper.so.0.0.0 \
+ lib/libpqsqlrelay.so.0.0.0 \
+ lib/libmysql3sqlrelay.so.0.0.0 \
+ lib/libmysql40sqlrelay.so.0.0.0 \
+ lib/libmysql41sqlrelay.so.0.0.0 \
+ lib/libmysql50sqlrelay.so.0.0.0 \
+ lib/libmysql51sqlrelay.so.0.0.0 \
+ lib/libsqlrserver.so.0.0.0 \
+ libexec/sqlrelay/sqlrquery_sqlrcmdgstat.so \
+ libexec/sqlrelay/sqlrquery_sqlrcmdcstat.so \
+ libexec/sqlrelay/sqlrlogger_debug.so \
+ libexec/sqlrelay/sqlrlogger_slowqueries.so \
+ libexec/sqlrelay/sqlrlogger_custom_nw.so \
+ libexec/sqlrelay/sqlrlogger_custom_sc.so \
+ libexec/sqlrelay/sqlrpwdenc_rot.so \
+ libexec/sqlrelay/sqlrpwdenc_md5.so \
+ libexec/sqlrelay/sqlrpwdenc_crypt.so \
+ libexec/sqlrelay/sqlrauth_default.so \
+ libexec/sqlrelay/sqlrauth_sqlrelay.so \
+ libexec/sqlrelay/sqlrconnection_router.so
+
.include "${.CURDIR}/Makefile.common"
OPTIONS_DEFINE= MYSQL ODBC ORACLE PGSQL SQLITE3 FREETDS FIREBIRD DOCS
@@ -54,6 +88,7 @@ CONFIGURE_ARGS+= --without-gdbm-prefix \
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql-prefix="${LOCALBASE}"
+TOSTRIP+= libexec/sqlrelay/sqlrconnection_mysql.so
.else
CONFIGURE_ARGS+= --disable-mysql
.endif
@@ -102,4 +137,9 @@ post-patch:
post-configure:
@${REINPLACE_CMD} 's,-Werror,,' ${WRKSRC}/config.mk
+post-stage:
+.for f in ${TOSTRIP}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${f}
+.endfor
+
.include <bsd.port.mk>