aboutsummaryrefslogtreecommitdiff
path: root/databases/tarantool/Makefile
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-02 15:41:28 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-02 15:41:28 +0000
commit4ca7312e0e4f57600720f8e2c8ef343d5b03920a (patch)
tree26979d4606efbbd4c17c134fbb041aa7ebe768da /databases/tarantool/Makefile
parent2f2516d4df04f9ee2e7e9bbe7214ad2e476e6261 (diff)
downloadports-4ca7312e0e4f57600720f8e2c8ef343d5b03920a.tar.gz
ports-4ca7312e0e4f57600720f8e2c8ef343d5b03920a.zip
Notes
Diffstat (limited to 'databases/tarantool/Makefile')
-rw-r--r--databases/tarantool/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
new file mode 100644
index 000000000000..05cc4e32203a
--- /dev/null
+++ b/databases/tarantool/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: tarantool
+# Date created: 2011-11-25
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tarantool
+PORTVERSION= 1.3.5
+CATEGORIES= databases
+MASTER_SITES= http://launchpadlibrarian.net/71705094/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Tarantool, is a high performance key/value storage server
+
+LICENSE= BSD
+
+ONLY_FOR_ARCHS= i386
+
+USE_CMAKE= yes
+ARCH= i386
+USE_RC_SUBR= ${PORTNAME}
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DOCSDIR%%|${DOCSDIR}|g' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|%%ETCDIR%%|${ETCDIR}|g' \
+ ${WRKSRC}/test/CMakeLists.txt
+ @${RM} ${WRKSRC}/test/lib/server.py \
+ ${WRKSRC}/test/lib/silverbox.py \
+ ${WRKSRC}/test/lib/tarantool_admin.py \
+ ${WRKSRC}/test/lib/tarantool_feeder_server.py \
+ ${WRKSRC}/test/lib/tarantool_server.py \
+ ${WRKSRC}/test/lib/*.orig
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>