aboutsummaryrefslogtreecommitdiff
path: root/databases/tcl-Mysql
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2014-07-13 16:40:24 +0000
committerMikhail Teterin <mi@FreeBSD.org>2014-07-13 16:40:24 +0000
commitb485957452eff61cf2fee748b60cdc0cba05bc51 (patch)
tree72ec3ce2a9df9e608b25e45b8030f95841ad085f /databases/tcl-Mysql
parentbb4b3c10ff8d71a585d12d28251c1865fa5e7978 (diff)
Notes
Diffstat (limited to 'databases/tcl-Mysql')
-rw-r--r--databases/tcl-Mysql/Makefile1
-rw-r--r--databases/tcl-Mysql/files/patch-const-error9
2 files changed, 8 insertions, 2 deletions
diff --git a/databases/tcl-Mysql/Makefile b/databases/tcl-Mysql/Makefile
index dd258f036ff0..da89fb0ff1a9 100644
--- a/databases/tcl-Mysql/Makefile
+++ b/databases/tcl-Mysql/Makefile
@@ -16,7 +16,6 @@ OPTIONS_DEFINE= DOCS
PATCH_DEPENDS= rcsdiff:${PORTSDIR}/devel/rcs
-BROKEN= Does not build
USE_MYSQL= 41+
USES= tcl
TCL_NODOT= tcl${TCL_VER:S/.//}
diff --git a/databases/tcl-Mysql/files/patch-const-error b/databases/tcl-Mysql/files/patch-const-error
index 63de9b834062..110053695b5b 100644
--- a/databases/tcl-Mysql/files/patch-const-error
+++ b/databases/tcl-Mysql/files/patch-const-error
@@ -7,7 +7,14 @@
+ const char *getErrorMsg();
};
--- sql-interface.h Mon Sep 14 06:52:41 1998
-+++ sql-interface.h Wed Nov 10 17:43:15 2004
++++ sql-interface.h 2014-07-13 12:30:48.000000000 -0400
+@@ -13,4 +13,6 @@
+ #define SQL_INTERFACE_H
+
++#include <cstddef>
++
+ class Sql_row;
+
@@ -54,5 +54,5 @@
// Get the error message, if there was one, for the last message