aboutsummaryrefslogtreecommitdiff
path: root/databases/tcl-Mysql
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-18 21:44:45 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-18 21:44:45 +0000
commitaeb00f7e3f873c9c3d3ab20a8e5c4bfabe3e3854 (patch)
treeabb561387365128bce35f43412af8003ffa8a462 /databases/tcl-Mysql
parenta669fb35244e3939c2545c3a1ba2072a01987315 (diff)
downloadports-aeb00f7e3f873c9c3d3ab20a8e5c4bfabe3e3854.tar.gz
ports-aeb00f7e3f873c9c3d3ab20a8e5c4bfabe3e3854.zip
Notes
Diffstat (limited to 'databases/tcl-Mysql')
-rw-r--r--databases/tcl-Mysql/Makefile1
-rw-r--r--databases/tcl-Mysql/files/patch-aa14
-rw-r--r--databases/tcl-Mysql/files/patch-ab52
3 files changed, 60 insertions, 7 deletions
diff --git a/databases/tcl-Mysql/Makefile b/databases/tcl-Mysql/Makefile
index 5f495e57ae0f..79162d67b0ac 100644
--- a/databases/tcl-Mysql/Makefile
+++ b/databases/tcl-Mysql/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tcl-sql
PORTVERSION= 20000114
+PORTREVISION= 1
CATEGORIES= databases ${TCL_NODOT}
MASTER_SITES= http://www.binevolve.com/~tdarugar/tcl-sql/download/
EXTRACT_SUFX= .tgz
diff --git a/databases/tcl-Mysql/files/patch-aa b/databases/tcl-Mysql/files/patch-aa
index e6007cc1ea7e..954548f7ab1d 100644
--- a/databases/tcl-Mysql/files/patch-aa
+++ b/databases/tcl-Mysql/files/patch-aa
@@ -109,7 +109,7 @@ same queries.
+ if (objc == 1) {
+ Tcl_WrongNumArgs(interp, 1, objv, "command ?handle?");
return TCL_ERROR;
-@@ -133,75 +93,84 @@
+@@ -133,58 +93,58 @@
Manager_sql *mgr = (Manager_sql *)clientData;
- int res = TCL_OK;
+ int res;
@@ -207,17 +207,17 @@ same queries.
- res = selectdbCmd(interp, conn, argv[3]);
- } else {
- Tcl_AppendResult(interp, "sql: unknown sql command: ", argv[1], NULL);
-- return TCL_ERROR;
+ // take care of the command:
+ if (subcommand < Disconnect && subcommand > Query) {
+ /* get the "result handle" returned previously */
-+ if (Tcl_GetIntFromObj(NULL, objv[3], &res) != TCL_OK ||
++ if (objc < 4) res = 0; /* oddly, this is how it was -- bug? */
++ else if (Tcl_GetIntFromObj(NULL, objv[3], &res) != TCL_OK ||
+ res < 0) {
+ Tcl_SetObjResult(interp, objv[3]);
+ Tcl_AppendResult(interp, ": invalid result"
+ " handle", NULL);
-+ return TCL_OK;
- }
+ return TCL_ERROR;
+@@ -192,16 +152,26 @@
}
-
- return res;
@@ -256,7 +256,7 @@ same queries.
+ }
+ return TCL_ERROR; /* not reachable */
}
-@@ -226,7 +195,7 @@
+@@ -226,7 +196,7 @@
- Tcl_CreateCommand (interp, "sql", SqlCmd ,(ClientData) s,
- (Tcl_CmdDeleteProc*) NULL);
@@ -266,5 +266,5 @@ same queries.
- // Provide a package called Sample
- if (Tcl_PkgProvide(interp, "Sql", "1.0") == TCL_ERROR)
+ // Provide a package called ``sql''
-+ if (Tcl_PkgProvide(interp, "sql", "1.0") == TCL_ERROR)
++ if (Tcl_PkgProvide(interp, "sql", "1.1") == TCL_ERROR)
return TCL_ERROR;
diff --git a/databases/tcl-Mysql/files/patch-ab b/databases/tcl-Mysql/files/patch-ab
new file mode 100644
index 000000000000..30ad95fb26ca
--- /dev/null
+++ b/databases/tcl-Mysql/files/patch-ab
@@ -0,0 +1,52 @@
+--- docs/api.html Wed Jul 22 21:54:38 1998
++++ docs/api.html Wed Jul 19 17:19:34 2000
+@@ -1,2 +1,5 @@
++<HTML>
++<HEAD>
+ <title>Generic Tcl Database Interface API</title>
++</HEAD>
+ <BODY BGCOLOR="#ffffff" LINK="#0000ff" ALINK="#ff0000" TEXT="#000000">
+@@ -55,3 +58,3 @@
+ statement). Use with <code><font color="#000099">fetchrow</font></code> and <code><font color="#000099">endquery</font></code>. <br>
+- <code><font color="#000099">sql query $conn "select * from sample where x > 3"</font></code>
++ <code><font color="#000099">set query [sql query $conn "select * from sample where x &gt; 3"]</font></code>
+
+@@ -62,3 +65,3 @@
+ is returned.<br>
+- <code><font color="#000099">while {[set row [sql fetchrow $conn]] != ""} { puts $row }</font></code>
++ <code><font color="#000099">while {[set row [sql fetchrow $conn $query]] != ""} { puts $row }</font></code>
+
+@@ -66,4 +69,4 @@
+ <p>
+-<hr width=50%>
+-<a name=sample><h3>Sample Usage:</h3></a>
++<hr width="50%">
++<h3><a name=sample>Sample Usage:</a></h3>
+ Also see
+@@ -86,3 +89,3 @@
+ # Put some dummy data in:
+-for {set i 0} {$i < 10} {incr i} {
++for {set i 0} {$i &lt; 10} {incr i} {
+ sql exec $conn "insert into junk values ($i, $i.01, 'xx $i xx')"
+@@ -91,5 +94,5 @@
+ # Do a select and display the results
+-sql query $conn "select * from junk where i > 3"
++set query [sql query $conn "select * from junk where i &gt; 3"]
+
+-while {[set row [sql fetchrow $conn]] != ""} {
++while {[set row [sql fetchrow $conn $query]] != ""} {
+ puts "row = $row"
+@@ -97,3 +100,3 @@
+
+-sql endquery $conn
++sql endquery $conn $query
+
+@@ -113 +116,3 @@
+ </pre>
++</BODY>
++</HTML>
+
+>Release-Note:
+>Audit-Trail:
+>Unformatted:
+