aboutsummaryrefslogtreecommitdiff
path: root/databases/tdb/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-12 13:02:16 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-12 13:02:16 +0000
commitadffaf811e9df31fd3a7ff90ed37189c453ca0f8 (patch)
treee37c254e250bbc236b2c63167c6248c1daf6d022 /databases/tdb/Makefile
parent9bb5b1e725db3b2af174864d9b2ef89216a981a7 (diff)
add tdb 1.0.6
Trivial Database
Notes
Notes: svn path=/head/; revision=67861
Diffstat (limited to 'databases/tdb/Makefile')
-rw-r--r--databases/tdb/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/databases/tdb/Makefile b/databases/tdb/Makefile
new file mode 100644
index 000000000000..cd9cf7a0596f
--- /dev/null
+++ b/databases/tdb/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: tdb
+# Date created: Oct 12, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tdb
+PORTVERSION= 1.0.6
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm
+
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+
+MAN3= tdb.3 tdb_chainlock.3 tdb_close.3 tdb_delete.3 tdb_error.3 \
+ tdb_exists.3 tdb_fetch.3 tdb_firstkey.3 tdb_open.3 tdb_store.3 \
+ tdb_traverse.3
+
+.include <bsd.port.mk>