aboutsummaryrefslogtreecommitdiff
path: root/databases/tdb
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2019-06-19 22:44:25 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2019-06-19 22:44:25 +0000
commit29295bfeff58bd68d5b82a8066e0bd5a414c56ca (patch)
tree3d5b39d4f9e3f1553f8b24d82f2326e712e59d10 /databases/tdb
parent77b718fdacbf07f1359f175642a6f524cef29c41 (diff)
downloadports-29295bfeff58bd68d5b82a8066e0bd5a414c56ca.tar.gz
ports-29295bfeff58bd68d5b82a8066e0bd5a414c56ca.zip
Notes
Diffstat (limited to 'databases/tdb')
-rw-r--r--databases/tdb/Makefile48
-rw-r--r--databases/tdb/distinfo6
-rw-r--r--databases/tdb/files/patch-buildtools__wafsamba__samba_autoconf.py52
-rw-r--r--databases/tdb/files/patch-buildtools__wafsamba__samba_python.py40
-rw-r--r--databases/tdb/files/patch-buildtools_wafsamba_samba__autoconf.py36
-rw-r--r--databases/tdb/files/patch-buildtools_wafsamba_samba__install.py (renamed from databases/tdb/files/patch-buildtools__wafsamba__samba_install.py)2
-rw-r--r--databases/tdb/files/patch-buildtools_wafsamba_wscript (renamed from databases/tdb/files/patch-buildtools__wafsamba__wscript)4
-rw-r--r--databases/tdb/files/patch-lib_replace_wscript (renamed from databases/tdb/files/patch-lib__replace__wscript)8
-rw-r--r--databases/tdb/files/patch-wscript4
9 files changed, 60 insertions, 140 deletions
diff --git a/databases/tdb/Makefile b/databases/tdb/Makefile
index a3053026e894..081d980af63d 100644
--- a/databases/tdb/Makefile
+++ b/databases/tdb/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= tdb
-PORTVERSION= 1.3.16
+PORTVERSION= 1.4.0
PORTREVISION= 0
-PORTEPOCH= 1
+PORTEPOCH= 0
CATEGORIES= databases
MASTER_SITES= SAMBA
@@ -14,6 +14,8 @@ LICENSE= GPLv3
IGNORE_NONTHREAD_PYTHON=needs port lang/python${PYTHON_SUFFIX} to be build with THREADS support
+CONFLICTS_INSTALL= tdb1-*
+
#FLAVORS= default nopython debug
#nopython_PKGNAMESUFFIX= -nopython
#debug_PKGNAMESUFFIX= -debug
@@ -21,7 +23,7 @@ IGNORE_NONTHREAD_PYTHON=needs port lang/python${PYTHON_SUFFIX} to be build with
#debug_CONFLICTS= tdb tdb-nopython
#default_CONFLICTS= tdb-nopython tdb-debug
-USES= compiler pkgconfig waf
+USES= compiler gettext-runtime pkgconfig waf
USE_LDCONFIG= yes
WAF_CMD= buildtools/bin/waf
CONFIGURE_LOG= bin/config.log
@@ -33,9 +35,13 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
--disable-rpath \
--without-gettext
-OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFINE= MANPAGES DEBUG
MANPAGES_DESC= Build and install manpages (requires textproc/docbook-xsl)
+DEBUG_CONFIGURE_ON= --verbose --enable-debug
+DEBUG_MAKE_ARGS= --verbose
+DEBUG_FLAGS= -g -ggdb3 -O0 -DTDB_TRACE=1
+
.include <bsd.port.options.mk>
TDB_BINS= bin/tdbbackup \
@@ -49,42 +55,15 @@ PLIST_FILES+= include/tdb.h \
lib/libtdb.so.1 \
${PKGCONFIGDIR}/tdb.pc
-.if defined(SAMBA4_DEBUG)
-CFLAGS+= -DTDB_TRACE=1
-.endif
.if defined(NO_PYTHON)
-USES+= python:2.7,build
+USES+= python:2.7+,build,test
CONFIGURE_ARGS+= --disable-python
.else
-USES+= python:2.7
+USES+= python:3.4+
PLIST_FILES+= ${PYTHON_SITELIBDIR}/tdb.so \
${PYTHON_SITELIBDIR}/_tdb_text.py
-# XXX: This is a gross hack to make port use both Python 2.7+ and 3.3+
-# This is not officially supported, use at your own risk
-.if defined(WITH_SAMBA4_PYTHON3) && ${WITH_SAMBA4_PYTHON3:M3\.[0-9]}
-SAMBA4_PYTHON3_VERSION= ${WITH_SAMBA4_PYTHON3}
-SAMBA4_PYTHON3= python${SAMBA4_PYTHON3_VERSION}
-SAMBA4_PYTHON3_VER= ${SAMBA4_PYTHON3_VERSION:C/\.//}
-.if !exists(${PORTSDIR}/lang/python${SAMBA4_PYTHON3_VER})
-.error unsupported or unknown Python version ${SAMBA4_PYTHON3_VERSION}
-.endif
-BUILD_DEPENDS+= ${SAMBA4_PYTHON3}:lang/python${SAMBA4_PYTHON3_VER}
-RUN_DEPENDS+= ${SAMBA4_PYTHON3}:lang/python${SAMBA4_PYTHON3_VER}
-# cpython-36m
-SAMBA4_PYTHON3_SO_ABI!= [ ! -f "${LOCALBASE}/bin/${SAMBA4_PYTHON3}" ] || ${LOCALBASE}/bin/${SAMBA4_PYTHON3} -c 'import sysconfig; print(sysconfig.get_config_var("SOABI") or "")' 2>/dev/null
-SAMBA4_PYTHON3_SITELIBDIR=lib/python${SAMBA4_PYTHON3_VERSION}/site-packages
-
-CONFIGURE_ENV+= PYTHON3_SO_ABI_FLAG=.${SAMBA4_PYTHON3_SO_ABI}
-CONFIGURE_ARGS+= --extra-python=${LOCALBASE}/bin/${SAMBA4_PYTHON3}
-
-PLIST_SUB+= SAMBA4_PYTHON3_SO_ABI=${SAMBA4_PYTHON3_SO_ABI} \
- SAMBA4_PYTHON3_SITELIBDIR=${SAMBA4_PYTHON3_SITELIBDIR}
-
-PLIST_FILES+= ${SAMBA4_PYTHON3_SITELIBDIR}/tdb.${SAMBA4_PYTHON3_SO_ABI}.so \
- ${SAMBA4_PYTHON3_SITELIBDIR}/_tdb_text.py
-.endif
.endif
.include <bsd.port.pre.mk>
@@ -134,9 +113,6 @@ post-install:
.endfor
.if !defined(NO_PYTHON)
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/tdb.so
-.if defined(SAMBA4_PYTHON3)
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SAMBA4_PYTHON3_SITELIBDIR}/tdb.${SAMBA4_PYTHON3_SO_ABI}.so
-.endif
.endif
.include <bsd.port.post.mk>
diff --git a/databases/tdb/distinfo b/databases/tdb/distinfo
index 29eabcef3e9b..fea996a869b6 100644
--- a/databases/tdb/distinfo
+++ b/databases/tdb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531611906
-SHA256 (tdb-1.3.16.tar.gz) = 6a3fc2616567f23993984ada3cea97d953a27669ffd1bfbbe961f26e0cf96cc5
-SIZE (tdb-1.3.16.tar.gz) = 504330
+TIMESTAMP = 1560369252
+SHA256 (tdb-1.4.0.tar.gz) = c1a0729c5400fb495465fa4bd953ae290db43c28dacd0506aef50dc482132d35
+SIZE (tdb-1.4.0.tar.gz) = 696994
diff --git a/databases/tdb/files/patch-buildtools__wafsamba__samba_autoconf.py b/databases/tdb/files/patch-buildtools__wafsamba__samba_autoconf.py
deleted file mode 100644
index c92d308462be..000000000000
--- a/databases/tdb/files/patch-buildtools__wafsamba__samba_autoconf.py
+++ /dev/null
@@ -1,52 +0,0 @@
---- buildtools/wafsamba/samba_autoconf.py.orig 2016-10-07 04:45:35 UTC
-+++ buildtools/wafsamba/samba_autoconf.py
-@@ -548,7 +548,7 @@ def library_flags(self, libs):
-
-
- @conf
--def CHECK_LIB(conf, libs, mandatory=False, empty_decl=True, set_target=True, shlib=False):
-+def CHECK_LIB(conf, libs, mandatory=False, empty_decl=True, set_target=True, shlib=False, msg=None):
- '''check if a set of libraries exist as system libraries
-
- returns the sublist of libs that do exist as a syslib or []
-@@ -568,11 +568,29 @@ int foo()
- ret.append(lib)
- continue
-
-+ if msg is None:
-+ msg = 'Checking for library %s' % lib
-+
- (ccflags, ldflags, cpppath) = library_flags(conf, lib)
-+
- if shlib:
-- res = conf.check(features='c cshlib', fragment=fragment, lib=lib, uselib_store=lib, ccflags=ccflags, ldflags=ldflags, uselib=lib.upper(), mandatory=False)
-+ res = conf.check(features='c cshlib',
-+ fragment=fragment,
-+ lib=lib,
-+ uselib_store=lib,
-+ ccflags=ccflags,
-+ ldflags=ldflags,
-+ uselib=lib.upper(),
-+ mandatory=False,
-+ msg=msg)
- else:
-- res = conf.check(lib=lib, uselib_store=lib, ccflags=ccflags, ldflags=ldflags, uselib=lib.upper(), mandatory=False)
-+ res = conf.check(lib=lib,
-+ uselib_store=lib,
-+ ccflags=ccflags,
-+ ldflags=ldflags,
-+ uselib=lib.upper(),
-+ mandatory=False,
-+ msg=msg)
-
- if not res:
- if mandatory:
-@@ -873,7 +891,7 @@ def SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS(c
- conf.env.undefined_ldflags = conf.ADD_LDFLAGS('-Wl,-no-undefined', testflags=True)
-
- if not sys.platform.startswith("openbsd") and conf.env.undefined_ignore_ldflags == []:
-- if conf.CHECK_LDFLAGS(['-undefined', 'dynamic_lookup']):
-+ if conf.CHECK_LDFLAGS(['-undefined', 'dynamic_lookup'] + conf.env.WERROR_CFLAGS):
- conf.env.undefined_ignore_ldflags = ['-undefined', 'dynamic_lookup']
-
- @conf
diff --git a/databases/tdb/files/patch-buildtools__wafsamba__samba_python.py b/databases/tdb/files/patch-buildtools__wafsamba__samba_python.py
deleted file mode 100644
index 429ec5e778f9..000000000000
--- a/databases/tdb/files/patch-buildtools__wafsamba__samba_python.py
+++ /dev/null
@@ -1,40 +0,0 @@
---- buildtools/wafsamba/samba_python.py.orig 2018-01-13 09:07:51 UTC
-+++ buildtools/wafsamba/samba_python.py
-@@ -76,17 +76,35 @@ def SAMBA_CHECK_PYTHON_HEADERS(conf, man
-
- def _check_python_headers(conf, mandatory):
- try:
-+ from python import _get_python_variables
- Configure.ConfigurationError
- conf.check_python_headers(mandatory=mandatory)
-+ conf.env['PYTHON_SO_ABI'] = _get_python_variables(
-+ conf.env['PYTHON'],
-+ ["get_config_var('SOABI') or ''"],
-+ ['from distutils.sysconfig import get_config_var']
-+ )[0]
- except Configure.ConfigurationError:
- if mandatory:
- raise
-
- if conf.env['PYTHON_VERSION'] > '3':
-- abi_pattern = os.path.splitext(conf.env['pyext_PATTERN'])[0]
-- conf.env['PYTHON_SO_ABI_FLAG'] = abi_pattern % ''
-+ '''Be caucious here - conf parameter is PYTHON_SO_ABI_FLAG,
-+ while environment variable is PYTHON3_SO_ABI_FLAG'''
-+ override_PYTHON_SO_ABI_FLAG = os.getenv('PYTHON3_SO_ABI_FLAG', None)
-+ if override_PYTHON_SO_ABI_FLAG is not None:
-+ conf.env['PYTHON_SO_ABI_FLAG'] = override_PYTHON_SO_ABI_FLAG
-+ conf.env['pyext_PATTERN'] = '%%s%s.%s' % (conf.env['PYTHON_SO_ABI_FLAG'], conf.env['SHLIBEXT'])
-+ if not conf.env['PYTHON_SO_ABI_FLAG']:
-+ if conf.env['PYTHON_SO_ABI']:
-+ conf.env['PYTHON_SO_ABI_FLAG'] = '.'+conf.env['PYTHON_SO_ABI']
-+ conf.env['pyext_PATTERN'] = '%%s%s.%s' % (conf.env['PYTHON_SO_ABI_FLAG'], conf.env['SHLIBEXT'])
-+ else:
-+ abi_pattern = os.path.splitext(conf.env['pyext_PATTERN'])[0]
-+ conf.env['PYTHON_SO_ABI_FLAG'] = abi_pattern % ''
- else:
- conf.env['PYTHON_SO_ABI_FLAG'] = ''
-+
- conf.env['PYTHON_LIBNAME_SO_ABI_FLAG'] = (
- conf.env['PYTHON_SO_ABI_FLAG'].replace('_', '-'))
-
diff --git a/databases/tdb/files/patch-buildtools_wafsamba_samba__autoconf.py b/databases/tdb/files/patch-buildtools_wafsamba_samba__autoconf.py
new file mode 100644
index 000000000000..7af1145c6754
--- /dev/null
+++ b/databases/tdb/files/patch-buildtools_wafsamba_samba__autoconf.py
@@ -0,0 +1,36 @@
+--- buildtools/wafsamba/samba_autoconf.py.orig 2019-02-26 06:44:21 UTC
++++ buildtools/wafsamba/samba_autoconf.py
+@@ -573,7 +573,7 @@ def library_flags(self, libs):
+
+
+ @conf
+-def CHECK_LIB(conf, libs, mandatory=False, empty_decl=True, set_target=True, shlib=False):
++def CHECK_LIB(conf, libs, mandatory=False, empty_decl=True, set_target=True, shlib=False, msg=None):
+ '''check if a set of libraries exist as system libraries
+
+ returns the sublist of libs that do exist as a syslib or []
+@@ -593,11 +593,14 @@ int foo()
+ ret.append(lib)
+ continue
+
++ if msg is None:
++ msg = 'Checking for library %s' % lib
++
+ (ccflags, ldflags, cpppath) = library_flags(conf, lib)
+ if shlib:
+- res = conf.check(features='c cshlib', fragment=fragment, lib=lib, uselib_store=lib, cflags=ccflags, ldflags=ldflags, uselib=lib.upper(), mandatory=False)
++ res = conf.check(features='c cshlib', fragment=fragment, lib=lib, uselib_store=lib, cflags=ccflags, ldflags=ldflags, uselib=lib.upper(), mandatory=False, msg=msg)
+ else:
+- res = conf.check(lib=lib, uselib_store=lib, cflags=ccflags, ldflags=ldflags, uselib=lib.upper(), mandatory=False)
++ res = conf.check(lib=lib, uselib_store=lib, cflags=ccflags, ldflags=ldflags, uselib=lib.upper(), mandatory=False, msg=msg)
+
+ if not res:
+ if mandatory:
+@@ -925,6 +928,5 @@ def SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS(c
+ conf.env.undefined_ldflags = conf.ADD_LDFLAGS('-Wl,-no-undefined', testflags=True)
+
+ if not sys.platform.startswith("openbsd") and conf.env.undefined_ignore_ldflags == []:
+- if conf.CHECK_LDFLAGS(['-undefined', 'dynamic_lookup']):
++ if conf.CHECK_LDFLAGS(['-undefined', 'dynamic_lookup'] + conf.env.WERROR_CFLAGS):
+ conf.env.undefined_ignore_ldflags = ['-undefined', 'dynamic_lookup']
+-
diff --git a/databases/tdb/files/patch-buildtools__wafsamba__samba_install.py b/databases/tdb/files/patch-buildtools_wafsamba_samba__install.py
index 95f250a86218..a852de2f200c 100644
--- a/databases/tdb/files/patch-buildtools__wafsamba__samba_install.py
+++ b/databases/tdb/files/patch-buildtools_wafsamba_samba__install.py
@@ -1,4 +1,4 @@
---- buildtools/wafsamba/samba_install.py.orig 2015-12-10 11:01:40 UTC
+--- buildtools/wafsamba/samba_install.py.orig 2019-02-14 11:21:38 UTC
+++ buildtools/wafsamba/samba_install.py
@@ -118,7 +118,7 @@ def install_library(self):
inst_name = bld.make_libname(t.target)
diff --git a/databases/tdb/files/patch-buildtools__wafsamba__wscript b/databases/tdb/files/patch-buildtools_wafsamba_wscript
index 9399a316c14e..b525397fbee9 100644
--- a/databases/tdb/files/patch-buildtools__wafsamba__wscript
+++ b/databases/tdb/files/patch-buildtools_wafsamba_wscript
@@ -1,6 +1,6 @@
---- buildtools/wafsamba/wscript.orig 2017-04-28 11:57:26 UTC
+--- buildtools/wafsamba/wscript.orig 2019-02-26 06:44:21 UTC
+++ buildtools/wafsamba/wscript
-@@ -76,10 +76,10 @@ def set_options(opt):
+@@ -82,10 +82,10 @@ def options(opt):
opt.add_option('--with-libiconv',
help='additional directory to search for libiconv',
diff --git a/databases/tdb/files/patch-lib__replace__wscript b/databases/tdb/files/patch-lib_replace_wscript
index d6d32b6c3dca..ba3eb912e5d7 100644
--- a/databases/tdb/files/patch-lib__replace__wscript
+++ b/databases/tdb/files/patch-lib_replace_wscript
@@ -1,11 +1,11 @@
---- lib/replace/wscript.orig 2017-08-24 11:27:53 UTC
+--- lib/replace/wscript.orig 2019-02-26 06:44:21 UTC
+++ lib/replace/wscript
-@@ -81,7 +81,7 @@ def configure(conf):
- conf.CHECK_HEADERS('sys/atomic.h')
+@@ -119,7 +119,7 @@ def configure(conf):
+ conf.CHECK_HEADERS('sys/atomic.h stdatomic.h')
conf.CHECK_HEADERS('libgen.h')
- if conf.CHECK_CFLAGS('-Wno-format-truncation'):
+ if conf.CHECK_CFLAGS(['-Wno-format-truncation'] + conf.env.WERROR_CFLAGS):
conf.define('HAVE_WNO_FORMAT_TRUNCATION', '1')
- # Check for process set name support
+ if conf.CHECK_CFLAGS('-Wno-unused-function'):
diff --git a/databases/tdb/files/patch-wscript b/databases/tdb/files/patch-wscript
index c1b8d4560be8..4869b58adf01 100644
--- a/databases/tdb/files/patch-wscript
+++ b/databases/tdb/files/patch-wscript
@@ -1,6 +1,6 @@
---- wscript.orig 2017-08-24 11:29:08 UTC
+--- wscript.orig 2019-02-26 07:02:52 UTC
+++ wscript
-@@ -115,7 +115,7 @@ def build(bld):
+@@ -121,7 +121,7 @@ def build(bld):
COMMON_SRC = bld.SUBDIR('common', COMMON_FILES)
if bld.env.standalone_tdb: