aboutsummaryrefslogtreecommitdiff
path: root/databases/tokyocabinet/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-17 06:35:19 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-17 06:35:19 +0000
commitfddc819e255c51e748112a243c3d94c5e7eee951 (patch)
tree93a370cb95fefe6b68b32409ceade90ff602a21c /databases/tokyocabinet/Makefile
parent6b963d91b63bdce4e1613c1f71ad1d187cc2b020 (diff)
downloadports-fddc819e255c51e748112a243c3d94c5e7eee951.tar.gz
ports-fddc819e255c51e748112a243c3d94c5e7eee951.zip
Notes
Diffstat (limited to 'databases/tokyocabinet/Makefile')
-rw-r--r--databases/tokyocabinet/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/databases/tokyocabinet/Makefile b/databases/tokyocabinet/Makefile
index e396fee71e12..7310c3bddbaa 100644
--- a/databases/tokyocabinet/Makefile
+++ b/databases/tokyocabinet/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= tokyocabinet
-PORTVERSION= 1.4.17
+PORTVERSION= 1.4.20
CATEGORIES= databases
MASTER_SITES= SF
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= A modern implementation of DBM
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --enable-off64
GNU_CONFIGURE= yes
@@ -40,6 +40,7 @@ OPTIONS= DEBUG "Debugging support" off \
SWAB "Swapping byte-orders build" off \
UYIELD "Detecting race conditions" off \
ZLIB "Disable ZLIB compression" off \
+ BZIP2 "BZIP2 compression" on \
PTHREAD "Disable POSIX thread support" off
.include <bsd.port.pre.mk>
@@ -72,6 +73,9 @@ CONFIGURE_ARGS+= --enable-uyield
.if defined(WITH_ZLIB)
CONFIGURE_ARGS+= --disable-zlib
.endif
+.if defined(WITHOUT_BZIP2)
+CONFIGURE_ARGS+= --disable-bzip
+.endif
.if defined(WITH_PTHREAD)
CONFIGURE_ARGS+= --disable-pthread
.endif
@@ -79,7 +83,7 @@ CONFIGURE_ARGS+= --disable-pthread
CONFIGURE_ARGS+= --disable-shared
.endif
-SHLIB_VER= 8.8.0
+SHLIB_VER= 8.11.0
SHLIB_VER_MAJ= 8
PLIST_SUB+= SHLIB_VER=${SHLIB_VER} SHLIB_VER_MAJ=${SHLIB_VER_MAJ}