aboutsummaryrefslogtreecommitdiff
path: root/databases/tokyocabinet
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-01-29 15:21:41 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-01-29 15:21:41 +0000
commit502894209c7be6ef51dfbff1ae7a4caaf704b7a2 (patch)
tree82200d24ca7f4f5c00115a48b80956cc3be954da /databases/tokyocabinet
parent39774ec8c3742a916ae72ca08a9c0c263448e919 (diff)
downloadports-502894209c7be6ef51dfbff1ae7a4caaf704b7a2.tar.gz
ports-502894209c7be6ef51dfbff1ae7a4caaf704b7a2.zip
Notes
Diffstat (limited to 'databases/tokyocabinet')
-rw-r--r--databases/tokyocabinet/Makefile82
-rw-r--r--databases/tokyocabinet/distinfo6
-rw-r--r--databases/tokyocabinet/pkg-plist34
3 files changed, 98 insertions, 24 deletions
diff --git a/databases/tokyocabinet/Makefile b/databases/tokyocabinet/Makefile
index d3a6bef86318..aa9f9dd923b9 100644
--- a/databases/tokyocabinet/Makefile
+++ b/databases/tokyocabinet/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= tokyocabinet
-PORTVERSION= 1.1.6
+PORTVERSION= 1.1.10
CATEGORIES= databases
MASTER_SITES= SF
-MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gslin@gslin.org
COMMENT= A modern implementation of DBM
@@ -19,9 +18,62 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-MAN1= tcbmgr.1 tcbmttest.1 tcbtest.1 tchmgr.1 tchmttest.1 \
- tchtest.1 tcucodec.1 tcumttest.1 tcutest.1
-MAN3= tcbdb.3 tchdb.3 tcutil.3 tokyocabinet.3
+DOCSDIR?= ${PREFIX}/share/doc/${PORTNAME}
+EXAMPLESDIR?= ${PREFIX}/share/examples/${PORTNAME}
+MAN1= tcamgr.1 tcatest.1 tcbmgr.1 tcbmttest.1 tcbtest.1 \
+ tchmgr.1 tchmttest.1 tchtest.1 tcucodec.1 tcumttest.1 \
+ tcutest.1
+MAN3= tcadb.3 tcbdb.3 tchdb.3 tcutil.3 tokyocabinet.3
+DOCS= COPYING ChangeLog README THANKS
+BINS= tcamgr tcatest tcbmgr tcbmttest tcbtest tchmgr tchmttest \
+ tchtest tcucodec tcumttest tcutest
+LIBS= libtokyocabinet.a libtokyocabinet.so libtokyocabinet.so.1 \
+ libtokyocabinet.so.1.29.0
+INCLUDES= tcbdb.h tchdb.h tcutil.h
+
+OPTIONS= DEBUG "Debugging support" off \
+ DEVEL "Development build" off \
+ PROFILE "Profiling build" off \
+ OFF64 "Use to compile on 64-bit system" off \
+ FASTEST "Fastest run" off \
+ SWAB "Swapping byte-orders build" off \
+ UYIELD "Detecting race conditions" off \
+ ZLIB "Disable ZLIB compression" off \
+ PTHREAD "Disable POSIX thread support" off \
+ SHARED "Avoid to build shared libraries" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+.if defined(WITH_DEVEL)
+CONFIGURE_ARGS+= --enable-devel
+.endif
+.if defined(WITH_PROFILE)
+CONFIGURE_ARGS+= --enable-profile
+.endif
+.if defined(WITH_OFF64)
+CONFIGURE_ARGS+= --enable-off64
+.endif
+.if defined(WITH_FASTEST)
+CONFIGURE_ARGS+= --enable-fastest
+.endif
+.if defined(WITH_SWAB)
+CONFIGURE_ARGS+= --enable-swab
+.endif
+.if defined(WITH_UYIELD)
+CONFIGURE_ARGS+= --enable-uyield
+.endif
+.if defined(WITH_ZLIB)
+CONFIGURE_ARGS+= --disable-zlib
+.endif
+.if defined(WITH_PTHREAD)
+CONFIGURE_ARGS+= --disable-pthread
+.endif
+.if defined(WITH_SHARED)
+CONFIGURE_ARGS+= --disable-shared
+.endif
# Because gnomehack use "(libdir)" and it doesn't work, we need to patch
# it manually.
@@ -29,4 +81,22 @@ post-patch:
${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|@prefix@/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+do-install:
+ @${INSTALL_PROGRAM} ${BINS:S,^,${WRKSRC}/,} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${MAN1:S,^,${WRKSRC}/man/,} ${MAN1PREFIX}/man/man1
+ @${INSTALL_MAN} ${MAN3:S,^,${WRKSRC}/man/,} ${MAN3PREFIX}/man/man3
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} doc ${EXAMPLESDIR}/)
+.endif
+.for i in ${LIBS}
+ @${CP} ${WRKSRC}/${i} ${PREFIX}/lib/
+.endfor
+.for j in ${INCLUDES}
+ @${CP} ${WRKSRC}/${j} ${PREFIX}/include/
+.endfor
+ @${CP} ${WRKSRC}/tokyocabinet.pc ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/databases/tokyocabinet/distinfo b/databases/tokyocabinet/distinfo
index 159339ee1fa7..1e6433780cf9 100644
--- a/databases/tokyocabinet/distinfo
+++ b/databases/tokyocabinet/distinfo
@@ -1,3 +1,3 @@
-MD5 (tokyocabinet-1.1.6.tar.gz) = 25b86778713ef89d13570b2787815ea3
-SHA256 (tokyocabinet-1.1.6.tar.gz) = 188cecb014935de2fd11aa2e9ca13487378a3f18e35a4a9546489a85f8effa1a
-SIZE (tokyocabinet-1.1.6.tar.gz) = 312557
+MD5 (tokyocabinet-1.1.10.tar.gz) = 9be899393ff4cf8c63649594ac361ad6
+SHA256 (tokyocabinet-1.1.10.tar.gz) = 8e8adfa063f2bde2c403bfd4da0729fbc25c1e664dd60b4b9dee7d33964e5aca
+SIZE (tokyocabinet-1.1.10.tar.gz) = 339472
diff --git a/databases/tokyocabinet/pkg-plist b/databases/tokyocabinet/pkg-plist
index 6d16576f770a..2c487014c9e4 100644
--- a/databases/tokyocabinet/pkg-plist
+++ b/databases/tokyocabinet/pkg-plist
@@ -1,16 +1,6 @@
@comment $FreeBSD$
-%%DATADIR%%/COPYING
-%%DATADIR%%/ChangeLog
-%%DATADIR%%/THANKS
-%%DATADIR%%/doc/benchmark.pdf
-%%DATADIR%%/doc/common.css
-%%DATADIR%%/doc/icon16.png
-%%DATADIR%%/doc/index.html
-%%DATADIR%%/doc/index.ja.html
-%%DATADIR%%/doc/logo-ja.png
-%%DATADIR%%/doc/logo.png
-%%DATADIR%%/doc/spex-en.html
-%%DATADIR%%/doc/spex-ja.html
+bin/tcamgr
+bin/tcatest
bin/tcbmgr
bin/tcbmttest
bin/tcbtest
@@ -26,7 +16,21 @@ include/tcutil.h
lib/libtokyocabinet.a
lib/libtokyocabinet.so
lib/libtokyocabinet.so.1
-lib/libtokyocabinet.so.1.25.0
+lib/libtokyocabinet.so.1.29.0
libdata/pkgconfig/tokyocabinet.pc
-@dirrmtry %%DATADIR%%/doc
-@dirrmtry %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/benchmark.pdf
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/common.css
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/icon16.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/index.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/index.ja.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/logo-ja.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/logo.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/spex-en.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/doc/spex-ja.html
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/doc
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%