aboutsummaryrefslogtreecommitdiff
path: root/databases/tora
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-17 15:13:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-17 15:13:07 +0000
commitdf9862f335c4d74c3c6e5129188315639803a2b3 (patch)
treed92f8df111cabd6f829cc0418e30a03486b99dcd /databases/tora
parent93b5df38e3cdff0c7dbaf85f5a7d6b7ff73c2066 (diff)
downloadports-df9862f335c4d74c3c6e5129188315639803a2b3.tar.gz
ports-df9862f335c4d74c3c6e5129188315639803a2b3.zip
Notes
Diffstat (limited to 'databases/tora')
-rw-r--r--databases/tora/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/databases/tora/Makefile b/databases/tora/Makefile
index 45c2fbb0c1e3..3dc425b72e6c 100644
--- a/databases/tora/Makefile
+++ b/databases/tora/Makefile
@@ -23,7 +23,7 @@ OPTIONS_DEFAULT= PGSQL MYSQL
USE_AUTOTOOLS= aclocal automake autoconf autoheader libtoolize
USE_QT4= gui corelib sql xml network linguist moc_build uic_build rcc_build
-USES= gmake libtool
+USES= compiler:features gmake libtool makeinfo
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pcre=${LOCALBASE}
LDFLAGS+= -L${LOCALBASE}/lib
@@ -31,7 +31,11 @@ INSTALL_TARGET= install-strip
PREFIX2FIX= doc/help/preferences.texi doc/help/preferences.html
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 36
+USE_GCC= yes
+.endif
.if ${PORT_OPTIONS:MDOCS}
USES+= makeinfo
@@ -66,4 +70,4 @@ pre-configure:
${REINPLACE_CMD} -e 's|test doc|test|' ${WRKSRC}/Makefile.am
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>