aboutsummaryrefslogtreecommitdiff
path: root/databases/unixODBC/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-11-28 15:07:22 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-11-28 15:07:22 +0000
commitf7017a32c28e847c7ca576da04ab9e6a0dac19e8 (patch)
treed6340d96d1fe43799b051f6428e4d12fa6b7ec18 /databases/unixODBC/Makefile
parente70118daada7620b794da06880b5887893465450 (diff)
downloadports-f7017a32c28e847c7ca576da04ab9e6a0dac19e8.tar.gz
ports-f7017a32c28e847c7ca576da04ab9e6a0dac19e8.zip
Notes
Diffstat (limited to 'databases/unixODBC/Makefile')
-rw-r--r--databases/unixODBC/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/databases/unixODBC/Makefile b/databases/unixODBC/Makefile
index 245a923aaadd..0430355dda1f 100644
--- a/databases/unixODBC/Makefile
+++ b/databases/unixODBC/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= unixODBC
-PORTVERSION= 1.8.8
+PORTVERSION= 1.8.13
CATEGORIES= databases
MASTER_SITES= http://www.unixodbc.org/
@@ -14,11 +14,19 @@ MAINTAINER= ports@FreeBSD.org
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-.if defined(WITH_X)
-USE_XLIB= yes
-CONFIGURE_ARGS+=--enable-gui
+
+.if defined(WITH_GUI)
+USE_QT2= yes
+CONFIGURE_ENV= MOC="${X11BASE}/bin/moc2"
+CONFIGURE_ARGS= --enable-gui \
+ --with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib \
+ --with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
+PLIST_SUB= GUI:=""
.else
-CONFIGURE_ARGS+=--disable-gui
+CONFIGURE_ARGS= --disable-gui
+PLIST_SUB= GUI:="@comment "
.endif
.include <bsd.port.mk>