aboutsummaryrefslogtreecommitdiff
path: root/databases/unixODBC
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-01-06 16:10:40 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-01-06 16:10:40 +0000
commit8c5821e2fa74a98c90efdcaead2d8a04f5001165 (patch)
treed9eabbd37ed4f0d81d9176191f894a3080c7fb00 /databases/unixODBC
parent8073f81d694845394d580076b0b47502d0bbfc0a (diff)
downloadports-8c5821e2fa74a98c90efdcaead2d8a04f5001165.tar.gz
ports-8c5821e2fa74a98c90efdcaead2d8a04f5001165.zip
Notes
Diffstat (limited to 'databases/unixODBC')
-rw-r--r--databases/unixODBC/Makefile25
-rw-r--r--databases/unixODBC/distinfo2
-rw-r--r--databases/unixODBC/files/patch-aa56
-rw-r--r--databases/unixODBC/files/patch-ab47
-rw-r--r--databases/unixODBC/files/patch-ac48
-rw-r--r--databases/unixODBC/pkg-plist66
6 files changed, 180 insertions, 64 deletions
diff --git a/databases/unixODBC/Makefile b/databases/unixODBC/Makefile
index 0430355dda1f..e8e0cb86ae8d 100644
--- a/databases/unixODBC/Makefile
+++ b/databases/unixODBC/Makefile
@@ -6,27 +6,38 @@
#
PORTNAME= unixODBC
-PORTVERSION= 1.8.13
+PORTVERSION= 2.0.0
CATEGORIES= databases
MASTER_SITES= http://www.unixodbc.org/
MAINTAINER= ports@FreeBSD.org
+USE_AUTOMAKE= yes
+AUTOMAKE_ARGS= --include-deps
USE_LIBTOOL= yes
+CONFIGURE_ARGS= --enable-static --enable-shared
INSTALLS_SHLIB= yes
.if defined(WITH_GUI)
USE_QT2= yes
CONFIGURE_ENV= MOC="${X11BASE}/bin/moc2"
-CONFIGURE_ARGS= --enable-gui \
- --with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-includes=${LOCALBASE}/include \
- --with-extra-libs=${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-gui \
+ --with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib \
+ --with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
PLIST_SUB= GUI:=""
.else
-CONFIGURE_ARGS= --disable-gui
+CONFIGURE_ARGS+= --disable-gui
PLIST_SUB= GUI:="@comment "
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/unixODBC
+ ${TAR} -C ${WRKSRC}/doc --exclude '*Makefile*' -cf - . \
+ | ${TAR} -C ${PREFIX}/share/doc/unixODBC --unlink -xf -
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/doc/unixODBC
+.endif
+
.include <bsd.port.mk>
diff --git a/databases/unixODBC/distinfo b/databases/unixODBC/distinfo
index 14026af30db7..94083755d22d 100644
--- a/databases/unixODBC/distinfo
+++ b/databases/unixODBC/distinfo
@@ -1 +1 @@
-MD5 (unixODBC-1.8.13.tar.gz) = 732338e03ab52a7382968ef2a0f6dd51
+MD5 (unixODBC-2.0.0.tar.gz) = 7007bf0764d195b6adac268aff6e206b
diff --git a/databases/unixODBC/files/patch-aa b/databases/unixODBC/files/patch-aa
deleted file mode 100644
index d4f45fe5a00e..000000000000
--- a/databases/unixODBC/files/patch-aa
+++ /dev/null
@@ -1,56 +0,0 @@
---- configure.orig Tue Nov 14 20:11:45 2000
-+++ configure Sat Nov 25 14:16:03 2000
-@@ -2578,14 +2578,14 @@
-
-
- if test "x$thread" = "xtrue"; then
-- echo $ac_n "checking for pthread_mutex_lock in -lpthread""... $ac_c" 1>&6
--echo "configure:2583: checking for pthread_mutex_lock in -lpthread" >&5
-+ echo $ac_n "checking for pthread_mutex_lock in -pthread""... $ac_c" 1>&6
-+echo "configure:2583: checking for pthread_mutex_lock in -pthread" >&5
- ac_lib_var=`echo pthread'_'pthread_mutex_lock | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lpthread $LIBS"
-+LIBS="-pthread $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 2591 "configure"
- #include "confdefs.h"
-@@ -2619,7 +2619,7 @@
- #define $ac_tr_lib 1
- EOF
-
-- LIBS="-lpthread $LIBS"
-+ LIBS="-pthread $LIBS"
-
- else
- echo "$ac_t""no" 1>&6
-@@ -3323,7 +3323,7 @@
-
-
-
--LIBQT="-lqt"
-+LIBQT="-lqt2"
- if test $kde_qtver = 2; then
-
-
-@@ -3531,7 +3531,7 @@
-
- CXXFLAGS="$CXXFLAGS -I$qt_includes"
- LDFLAGS="$X_LDFLAGS"
--LIBS="-lqt -lXext -lX11 $LIBSOCKET"
-+LIBS="-lqt2 -lXext -lX11 $LIBSOCKET"
- LD_LIBRARY_PATH=
- export LD_LIBRARY_PATH
- LIBRARY_PATH=
-@@ -3695,7 +3695,7 @@
-
-
-
--LIB_QT='-lqt $(LIBPNG) -lXext $(LIB_X11)'
-+LIB_QT='-lqt2 $(LIBPNG) -lXext $(LIB_X11)'
-
-
-
diff --git a/databases/unixODBC/files/patch-ab b/databases/unixODBC/files/patch-ab
new file mode 100644
index 000000000000..f4b5fe3d8f8f
--- /dev/null
+++ b/databases/unixODBC/files/patch-ab
@@ -0,0 +1,47 @@
+--- aclocal.m4.orig Fri Jan 5 00:08:12 2001
++++ aclocal.m4 Sat Jan 6 06:48:33 2001
+@@ -518,7 +518,7 @@
+
+ CXXFLAGS="$CXXFLAGS -I$qt_includes"
+ LDFLAGS="$X_LDFLAGS"
+-LIBS="-lqt -lXext -lX11 $LIBSOCKET"
++LIBS="-lqt2 -lXext -lX11 $LIBSOCKET"
+ LD_LIBRARY_PATH=
+ export LD_LIBRARY_PATH
+ LIBRARY_PATH=
+@@ -565,7 +565,7 @@
+ [
+ AC_REQUIRE([K_PATH_X])
+ AC_REQUIRE([KDE_USE_QT])
+-LIBQT="-lqt"
++LIBQT="-lqt2"
+ if test $kde_qtver = 2; then
+
+ AC_REQUIRE([AC_FIND_PNG])
+@@ -704,7 +704,7 @@
+ AC_SUBST(QT_LDFLAGS)
+ AC_PATH_QT_MOC
+
+-LIB_QT='-lqt $(LIBPNG) -lXext $(LIB_X11)'
++LIB_QT='-lqt2 $(LIBPNG) -lXext $(LIB_X11)'
+ AC_SUBST(LIB_QT)
+
+ ])
+@@ -2587,7 +2587,7 @@
+
+ AC_DEFUN(KDE_CHECK_LIBPTHREAD,
+ [
+-AC_CHECK_LIB(pthread, pthread_create, [LIBPTHREAD="-lpthread"], LIBPTHREAD= )
++AC_CHECK_FUNC(c_r, pthread_create, [LIBPTHREAD="-pthread"], LIBPTHREAD= )
+ AC_SUBST(LIBPTHREAD)
+ ])
+
+@@ -2709,7 +2709,7 @@
+ kde_python_link_found=no
+ KDE_TRY_LINK_PYTHON(normal)
+ KDE_TRY_LINK_PYTHON(m, -lm)
+-KDE_TRY_LINK_PYTHON(pthread, $LIBPTHREAD)
++KDE_TRY_LINK_PYTHON(c_r, $LIBPTHREAD)
+ KDE_TRY_LINK_PYTHON(tcl, -ltcl)
+ KDE_TRY_LINK_PYTHON(m_and_thread, [$LIBPTHREAD -lm], [],
+ [AC_MSG_WARN([it seems, Python depends on another library.
diff --git a/databases/unixODBC/files/patch-ac b/databases/unixODBC/files/patch-ac
new file mode 100644
index 000000000000..46e725c8eeda
--- /dev/null
+++ b/databases/unixODBC/files/patch-ac
@@ -0,0 +1,48 @@
+--- configure.in.orig Fri Jan 5 00:07:39 2001
++++ configure.in Sat Jan 6 06:53:02 2001
+@@ -97,8 +97,8 @@
+ AC_DEFINE(HAVE_READLINE, 1)])
+ AC_SUBST(READLINE)
+
+-AC_CHECK_LIB(c, strcasecmp, [AC_DEFINE(HAVE_STRCASECMP, 1)])
+-AC_CHECK_LIB(c, strncasecmp, [AC_DEFINE(HAVE_STRNCASECMP, 1)])
++AC_CHECK_FUNC(c, strcasecmp, [AC_DEFINE(HAVE_STRCASECMP, 1)])
++AC_CHECK_FUNC(c, strncasecmp, [AC_DEFINE(HAVE_STRNCASECMP, 1)])
+
+ LIBADD_DL=
+ AC_CHECK_LIB(dl, dlopen, [AC_DEFINE(HAVE_LIBDL, 1) LIBADD_DL="-ldl"],
+@@ -121,25 +121,26 @@
+ AC_DEFINE(HAVE_LIBPTH,1)
+ else
+ AC_CHECK_LIB(pthread, pthread_mutex_lock )
+- AC_CHECK_LIB(pthread, pthread_mutex_lock,
++ AC_CHECK_FUNC(c_r, pthread_mutex_lock,
+ [
+ AC_DEFINE(HAVE_LIBPTHREAD,1)
+ if test "x$ac_cv_prog_gcc"="xyes"; then
+- CFLAGS="$CFLAGS -pthread"
++ LIBS="$LIBS -pthread"
++ AC_DEFINE(_THREAD_SAFE,1)
+ fi
+ ] )
+
+ AC_CHECK_LIB(thread, mutex_lock )
+- AC_CHECK_LIB(c, localtime_r, [AC_DEFINE(HAVE_LOCALTIME_R, 1)] )
++ AC_CHECK_FUNC(c, localtime_r, [AC_DEFINE(HAVE_LOCALTIME_R, 1)] )
+ fi
+ fi
+
+ if test "x$stats" = "xtrue"; then
+- AC_CHECK_LIB( c, ftok,[],[stats=false] )
+- AC_CHECK_LIB( c, semget,[],[stats=false] )
+- AC_CHECK_LIB( c, shmget,[],[stats=false] )
+- AC_CHECK_LIB( c, semop,[],[stats=false] )
+- AC_CHECK_LIB( c, snprintf, [AC_DEFINE(HAVE_SNPRINTF)],[stats=false] )
++ AC_CHECK_FUNC( c, ftok,[],[stats=false] )
++ AC_CHECK_FUNC( c, semget,[],[stats=false] )
++ AC_CHECK_FUNC( c, shmget,[],[stats=false] )
++ AC_CHECK_FUNC( c, semop,[],[stats=false] )
++ AC_CHECK_FUNC( c, snprintf, [AC_DEFINE(HAVE_SNPRINTF)],[stats=false] )
+ fi
+
+ if test "x$stats" = "xtrue"; then
diff --git a/databases/unixODBC/pkg-plist b/databases/unixODBC/pkg-plist
index 1dc833c7ee09..afacc995fd7d 100644
--- a/databases/unixODBC/pkg-plist
+++ b/databases/unixODBC/pkg-plist
@@ -11,6 +11,8 @@ include/odbcinstext.h
include/sql.h
include/sqlext.h
include/sqltypes.h
+include/sqlucode.h
+include/uodbc_stats.h
lib/libesoobS.a
lib/libesoobS.so
lib/libesoobS.so.1
@@ -65,3 +67,67 @@ lib/libtdsS.so.1
lib/libtemplate.a
lib/libtemplate.so
lib/libtemplate.so.1
+share/doc/unixODBC/AdministratorManual/index.html
+share/doc/unixODBC/AdministratorManual/odbcinst.html
+share/doc/unixODBC/AdministratorManual/php3.html
+share/doc/unixODBC/AdministratorManual/unixODBC.gif
+share/doc/unixODBC/AdministratorManual/unixODBCsetup.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/close.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/conne.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/dsn.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/gloss.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/index.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/intro.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/navi.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/odbc.css
+share/doc/unixODBC/ProgrammerManual/Tutorial/query.html
+share/doc/unixODBC/ProgrammerManual/Tutorial/resul.html
+share/doc/unixODBC/ProgrammerManual/index.html
+share/doc/unixODBC/ProgrammerManual/unixODBC.gif
+share/doc/unixODBC/UserManual/Figure1.gif
+share/doc/unixODBC/UserManual/Figure2.gif
+share/doc/unixODBC/UserManual/Figure3.gif
+share/doc/unixODBC/UserManual/Figure4.gif
+share/doc/unixODBC/UserManual/Figure6.gif
+share/doc/unixODBC/UserManual/My.sql
+share/doc/unixODBC/UserManual/StarOfficeDataGrid.gif
+share/doc/unixODBC/UserManual/index.html
+share/doc/unixODBC/UserManual/unixODBC.gif
+share/doc/unixODBC/index.html
+share/doc/unixODBC/lst/InternalStructure.gif
+share/doc/unixODBC/lst/InternalStructure.html
+share/doc/unixODBC/lst/InternalStructure.vsd
+share/doc/unixODBC/lst/InternalStructure2.gif
+share/doc/unixODBC/lst/InternalStructure2.html
+share/doc/unixODBC/lst/InternalStructure3.gif
+share/doc/unixODBC/lst/InternalStructure3.html
+share/doc/unixODBC/lst/InternalStructure4.gif
+share/doc/unixODBC/lst/InternalStructure4.html
+share/doc/unixODBC/lst/InternalStructure5.gif
+share/doc/unixODBC/lst/InternalStructure5.html
+share/doc/unixODBC/lst/InternalStructure6.gif
+share/doc/unixODBC/lst/InternalStructure6.html
+share/doc/unixODBC/lst/InternalStructure7.gif
+share/doc/unixODBC/lst/InternalStructure7.html
+share/doc/unixODBC/lst/InternalStructure8.gif
+share/doc/unixODBC/lst/InternalStructure8.html
+share/doc/unixODBC/lst/InternalStructure9.gif
+share/doc/unixODBC/lst/InternalStructure9.html
+share/doc/unixODBC/lst/back.gif
+share/doc/unixODBC/lst/next.gif
+share/doc/unixODBC/smallbook.gif
+share/doc/unixODBC/sqi/InternalStructure.gif
+share/doc/unixODBC/sqi/InternalStructure.html
+share/doc/unixODBC/sqi/InternalStructure.vsd
+share/doc/unixODBC/sqi/InternalStructure2.gif
+share/doc/unixODBC/sqi/InternalStructure2.html
+share/doc/unixODBC/sqi/back.gif
+share/doc/unixODBC/sqi/next.gif
+share/doc/unixODBC/unixODBC.gif
+@dirrm share/doc/unixODBC/sqi
+@dirrm share/doc/unixODBC/lst
+@dirrm share/doc/unixODBC/UserManual
+@dirrm share/doc/unixODBC/ProgrammerManual/Tutorial
+@dirrm share/doc/unixODBC/ProgrammerManual
+@dirrm share/doc/unixODBC/AdministratorManual
+@dirrm share/doc/unixODBC