aboutsummaryrefslogtreecommitdiff
path: root/databases/vfront
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-04-11 16:37:03 +0000
committerChris Rees <crees@FreeBSD.org>2012-04-11 16:37:03 +0000
commite12186a8981fceb9460bd4006ad9cd347c36d544 (patch)
tree1043daba34ef3e034e09409dc73a8c3544e83a01 /databases/vfront
parentdcc7bbb1a4ae93ef7aa801b4c816b85e0a625184 (diff)
downloadports-e12186a8981fceb9460bd4006ad9cd347c36d544.tar.gz
ports-e12186a8981fceb9460bd4006ad9cd347c36d544.zip
Notes
Diffstat (limited to 'databases/vfront')
-rw-r--r--databases/vfront/Makefile56
-rw-r--r--databases/vfront/distinfo2
-rw-r--r--databases/vfront/pkg-descr6
3 files changed, 64 insertions, 0 deletions
diff --git a/databases/vfront/Makefile b/databases/vfront/Makefile
new file mode 100644
index 000000000000..609f22c23e9e
--- /dev/null
+++ b/databases/vfront/Makefile
@@ -0,0 +1,56 @@
+# Ports collection Makefile for: vfront
+# Date created: 11th April 2012
+# Whom: crees
+#
+# $FreeBSD$
+#
+
+PORTNAME= vfront
+DISTVERSION= 0.96c
+CATEGORIES= databases www
+MASTER_SITES= SF/vfront/vfront/vfront-${DISTVERSION}
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Simple frontend for database data entry
+
+LICENSE= GPLv2
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/pkg-plist
+
+USE_PHP= yes
+
+OPTIONS+= MYSQL "Use MySQL databases" off
+OPTIONS+= PGSQL "Use PostgreSQL databases" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_MYSQL)
+USE_PHP+= mysqli
+USE_MYSQL= yes
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+USE_PGSQL= yes
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -i '' -e \
+ 's/\(AUTHORIZATION \\*"\)postgres\(\\*"\)/\1pgsql\2/' \
+ ${WRKSRC}/_install/vfront.postgres.sql \
+ ${WRKSRC}/_install/vfront.postgres.sql.php
+
+pre-install:
+ (cd ${WRKSRC} && \
+ ${FIND} * -type f | ${SED} 's,^,%%WWWDIR%%/,' > ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | \
+ ${SED} 's,^,@dirrmtry %%WWWDIR%%/,' >> ${PLIST})
+ @${ECHO_CMD} '@dirrmtry %%WWWDIR%%' >> ${PLIST}
+
+do-install:
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${WWWDIR})
+ ${CHOWN} -R ${WWWOWN} ${WWWDIR}
+ ${CHMOD} 700 ${WWWDIR}/conf
+
+.include <bsd.port.mk>
diff --git a/databases/vfront/distinfo b/databases/vfront/distinfo
new file mode 100644
index 000000000000..d8ddb5cdb650
--- /dev/null
+++ b/databases/vfront/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vfront-0.96c.tar.gz) = 6ff4ca953089c7337479fe857bac746605e5dcac4c878b89c5d0cfe7db790138
+SIZE (vfront-0.96c.tar.gz) = 4238620
diff --git a/databases/vfront/pkg-descr b/databases/vfront/pkg-descr
new file mode 100644
index 000000000000..5e5e8c8caf1f
--- /dev/null
+++ b/databases/vfront/pkg-descr
@@ -0,0 +1,6 @@
+VFront is a free, open source front-end for MySQL or PostgreSQL databases
+written in PHP and Javascript. With VFront you can create forms for managing
+your data in AJAX style, different rules and privileges for groups, report in
+XML, HTML, PDF, statistics and much more.
+
+WWW: http://www.vfront.org/