aboutsummaryrefslogtreecommitdiff
path: root/databases/virtuoso/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2006-12-11 20:25:03 +0000
committerMax Khon <fjoe@FreeBSD.org>2006-12-11 20:25:03 +0000
commit749b69c58d0a81e4f9f9d4d494a34f81cd1ca968 (patch)
treee2dfe27c1d86bd4c1598bc549244e51cb223417a /databases/virtuoso/Makefile
parentc7e00f34b9a74130f611dc240283ac32d4ac7381 (diff)
downloadports-749b69c58d0a81e4f9f9d4d494a34f81cd1ca968.tar.gz
ports-749b69c58d0a81e4f9f9d4d494a34f81cd1ca968.zip
Notes
Diffstat (limited to 'databases/virtuoso/Makefile')
-rw-r--r--databases/virtuoso/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 371bc0b498c6..1ec9c6216372 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -7,6 +7,7 @@
PORTNAME= virtuoso
PORTVERSION= 4.5.7
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,13 +20,14 @@ USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-readline\
--with-iodbc=${LOCALBASE}\
--enable-bpel-vad\
- --enable-krb\
--disable-jdbc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"\
LDFLAGS="-L${LOCALBASE}/lib"
+BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
LIB_DEPENDS= iodbc.3:${PORTSDIR}/databases/libiodbc
OPTIONS= IMAGEMAGICK "ImageMagick support" off\
+ KERBEROS "Kerberos extension" off\
OPENLDAP "OpenLDAP support" off
# JDBC "JDBC driver" off\
# PERL "Perl hosting" off
@@ -38,7 +40,6 @@ OPTIONS= IMAGEMAGICK "ImageMagick support" off\
post-patch:
${REINPLACE_CMD}\
-e 's,-lpthreads,${PTHREAD_LIBS},g'\
- -e 's,-lgssapi_krb5 -lk5crypto -lkrb5,-lasn1 -lroken -lcrypto -lcrypt,g'\
-e 's,-lruby,-lruby${RUBY_VER:S,.,,},g'\
${WRKSRC}/configure
@@ -64,6 +65,11 @@ PLIST_SUB+= WITH_IMAGEMAGICK="@comment "
#JAVA_BUILD= yes
#.endif
+.if defined(WITH_KERBEROS)
+CONFIGURE_ARGS+=--enable-krb=${LOCALBASE}
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
+.endif
+
# XXX broken (does not build, requires gc.h)
#.if defined(WITH_MONO)
#CONFIGURE_ARGS+=--enable-mono