aboutsummaryrefslogtreecommitdiff
path: root/databases/virtuoso/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 17:27:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 17:27:29 +0000
commitc4d4cacd63490d4b63e844ae298880332a388ba7 (patch)
tree3913b841cc9c2f98d7e4b2056eafc0d9980bf1c8 /databases/virtuoso/Makefile
parent5faefa6350cd172add279e339bd86a650313beb3 (diff)
downloadports-c4d4cacd63490d4b63e844ae298880332a388ba7.tar.gz
ports-c4d4cacd63490d4b63e844ae298880332a388ba7.zip
Notes
Diffstat (limited to 'databases/virtuoso/Makefile')
-rw-r--r--databases/virtuoso/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 839d67ee12bd..b664732887a3 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -28,6 +28,8 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"\
LDFLAGS="-L${LOCALBASE}/lib"
ONLY_FOR_ARCHS= i386
+CHECK_PORT= /usr/bin/nc -z localhost $$\1
+
OPTIONS= IMAGEMAGICK "ImageMagick support" off\
KERBEROS "Kerberos extension" off\
OPENLDAP "OpenLDAP support" off
@@ -56,13 +58,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 504000
-CHECK_PORT= ${LOCALBASE}/bin/nc -vz localhost $$\1 2>\&1 | ${GREP} open
-BUILD_DEPENDS+= ${NETCAT}:${PORTSDIR}/net/netcat
-.else
-CHECK_PORT= /usr/bin/nc -z localhost $$\1
-.endif
-
.if defined(WITH_IMAGEMAGICK)
CONFIGURE_ARGS+=--enable-imagemagick=${LOCALBASE}
LIB_DEPENDS+= MagickWand.1:${PORTSDIR}/graphics/ImageMagick