aboutsummaryrefslogtreecommitdiff
path: root/databases/virtuoso
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2007-01-11 18:09:02 +0000
committerMax Khon <fjoe@FreeBSD.org>2007-01-11 18:09:02 +0000
commit48617e032a8bb5bf2fc2700173fb43221935917f (patch)
treee46fca7682e31a39fe44985cc33b98c65d02bf2f /databases/virtuoso
parent0c96967e336a4842f5e9ea5d8e01c87cc065435d (diff)
downloadports-48617e032a8bb5bf2fc2700173fb43221935917f.tar.gz
ports-48617e032a8bb5bf2fc2700173fb43221935917f.zip
Notes
Diffstat (limited to 'databases/virtuoso')
-rw-r--r--databases/virtuoso/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 1ec9c6216372..0033cb82b425 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -7,7 +7,7 @@
PORTNAME= virtuoso
PORTVERSION= 4.5.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -42,6 +42,9 @@ post-patch:
-e 's,-lpthreads,${PTHREAD_LIBS},g'\
-e 's,-lruby,-lruby${RUBY_VER:S,.,,},g'\
${WRKSRC}/configure
+ ${FIND} ${WRKSRC} -name '*.sh' | ${XARGS} ${GREP} -l 'netstat -an.*grep LISTEN' |\
+ ${XARGS} ${REINPLACE_CMD}\
+ -e 's,netstat -an.*grep.*$$\([a-zA-Z0-9]*\).*grep LISTEN,${CHECK_PORT},'
pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
@@ -51,6 +54,17 @@ post-install:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+IGNORE= requires wchar_t
+.endif
+
+.if ${OSVERSION} < 504000
+CHECK_PORT= ${LOCALBASE}/bin/nc -vz localhost $$\1 2>\&1 | ${GREP} open
+BUILD_DEPENDS+= ${NETCAT}:${PORTSDIR}/net/netcat
+.else
+CHECK_PORT= /usr/bin/nc -z localhost $$\1
+.endif
+
.if defined(WITH_IMAGEMAGICK)
CONFIGURE_ARGS+=--enable-imagemagick=${LOCALBASE}
LIB_DEPENDS+= Magick.10:${PORTSDIR}/graphics/ImageMagick