aboutsummaryrefslogtreecommitdiff
path: root/databases/wmjsql
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-12-08 23:06:15 +0000
committerJohn Marino <marino@FreeBSD.org>2013-12-08 23:06:15 +0000
commita9dc382b761febe3db97bea216896030a1659edf (patch)
tree32e530ea1bf6dee34df510476d8dee2becab8bab /databases/wmjsql
parent08f342435d49d94edb5d5780db619af89e7f3038 (diff)
Notes
Diffstat (limited to 'databases/wmjsql')
-rw-r--r--databases/wmjsql/Makefile2
-rw-r--r--databases/wmjsql/files/patch-Makefile27
2 files changed, 28 insertions, 1 deletions
diff --git a/databases/wmjsql/Makefile b/databases/wmjsql/Makefile
index 000056634833..8c2cef594d6d 100644
--- a/databases/wmjsql/Makefile
+++ b/databases/wmjsql/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= MySQL server status displaying dockapp
USE_MYSQL= yes
-USE_GMAKE= yes
+USES= gmake
USE_XORG= xpm
ALL_TARGET= clean all
diff --git a/databases/wmjsql/files/patch-Makefile b/databases/wmjsql/files/patch-Makefile
new file mode 100644
index 000000000000..932322ab93a7
--- /dev/null
+++ b/databases/wmjsql/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig 2001-08-16 13:04:23.000000000 +0000
++++ Makefile
+@@ -25,20 +25,20 @@ all: ${name}
+ # ${name}
+
+ jDockApp.o: jDockApp/jDockApp_main.xpm jDockApp/jDockApp.c
+- cd $*; make $*.o
++ cd $*; $(MAKE) $*.o
+
+ xutils.o: xutils/xutils.c
+- cd $*; make $*.o
++ cd $*; $(MAKE) $*.o
+
+ jprintf.o: jDockApp/jprintf.c
+- cd jDockApp; make jprintf.o
++ cd jDockApp; $(MAKE) jprintf.o
+
+ ${name}: $(OBJS) ${name}.c
+ $(CC) $(CFLAGS) $(SYSTEM) -o ${name} $^ $(INCDIR) $(LIBDIR) $(LIBS)
+
+ install: all
+ sudo install ${owner} ${group} -s -m 755 ./${name} ${prefix}/${name}
+- make clean;
++ $(MAKE) clean;
+
+ clean:
+ rm -f *.o ${name} ${name}.c *.orig *.rej *.3