aboutsummaryrefslogtreecommitdiff
path: root/databases/xapian-bindings
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-23 18:56:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-23 18:56:53 +0000
commit16d60ffe42c7833cde4e8c5a53d656e0ba07447f (patch)
tree851d4856542b2a6b5615eeefd8d4e00270fe72f2 /databases/xapian-bindings
parent88d1cdc90f8328846f283f78089abfbb3282e1c1 (diff)
downloadports-16d60ffe42c7833cde4e8c5a53d656e0ba07447f.tar.gz
ports-16d60ffe42c7833cde4e8c5a53d656e0ba07447f.zip
Notes
Diffstat (limited to 'databases/xapian-bindings')
-rw-r--r--databases/xapian-bindings/Makefile67
1 files changed, 17 insertions, 50 deletions
diff --git a/databases/xapian-bindings/Makefile b/databases/xapian-bindings/Makefile
index 79cd1b35e875..0e26024ef7bf 100644
--- a/databases/xapian-bindings/Makefile
+++ b/databases/xapian-bindings/Makefile
@@ -16,65 +16,32 @@ LIB_DEPENDS= libxapian.so:${PORTSDIR}/databases/xapian-core
OPTIONS_DEFINE= DOCS LUA PERL PHP PYTHON RUBY
OPTIONS_DEFAULT=PHP PYTHON RUBY
+OPTIONS_SUB= yes
PORTSCOUT= limitw:1,even
CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
--without-csharp --without-java --without-tcl
GNU_CONFIGURE= yes
+MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
+
+LUA_CONFIGURE_ENV= LUA="${LUA_CMD}" LUA_INC="${LUA_INCDIR}" LUA_LIB="${LUA_MODLIBDIR}" LUA_SO=.so
+LUA_CONFIGURE_WITH= lua
+LUA_USE= LUA=5.1+
+PERL_CONFIGURE_ENV= PERL_LIB=${SITE_PERL}
+PERL_CONFIGURE_WITH= perl
+PERL_USES= perl5
+PHP_CONFIGURE_ENV= PHP_CONFIG=${LOCALBASE}/bin/php-config
+PHP_CONFIGURE_WITH= php
+PHP_USE= PHP=yes PHP_BUILD=yes
+PYTHON_CONFIGURE_ENV+= PYTHON_LIB=${PYTHON_SITELIBDIR}
+PYTHON_CONFIGURE_WITH= python
+PYTHON_USE= PYTHON=yes
+RUBY_CONFIGURE_WITH= ruby
+RUBY_USE= RUBY=yes RUBY_RDOC=no
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MLUA}
-CONFIGURE_ARGS+=--with-lua
-CONFIGURE_ENV+= LUA="${LUA_CMD}" LUA_INC="${LUA_INCDIR}" LUA_LIB="${LUA_MODLIBDIR}" LUA_SO=.so
-USE_LUA= 5.1+
-PLIST_SUB+= LUA=""
-.else
-PLIST_SUB+= LUA="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPERL}
-CONFIGURE_ARGS+=--with-perl
-CONFIGURE_ENV+= PERL_LIB="${SITE_PERL}"
-USES+= perl5
-PLIST_SUB+= PERL=""
-.else
-PLIST_SUB+= PERL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPHP}
-CONFIGURE_ARGS+=--with-php
-CONFIGURE_ENV+= PHP_CONFIG="${LOCALBASE}/bin/php-config"
-USE_PHP= yes
-USE_PHP_BUILD= yes
-PLIST_SUB+= PHP=""
-.else
-CONFIGURE_ARGS+=--without-php
-PLIST_SUB+= PHP="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-CONFIGURE_ARGS+=--with-python
-CONFIGURE_ENV+= PYTHON_LIB="${PYTHON_SITELIBDIR}"
-USE_PYTHON= yes
-PLIST_SUB+= PYTHON=""
-.else
-CONFIGURE_ARGS+=--without-python
-PLIST_SUB+= PYTHON="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MRUBY}
-CONFIGURE_ARGS+=--with-ruby
-USE_RUBY= yes
-USE_RUBY_RDOC= no
-PLIST_SUB+= RUBY=""
-.else
-CONFIGURE_ARGS+=--without-ruby
-PLIST_SUB+= RUBY="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lstdc++||g' ${WRKSRC}/configure
# do not install rdoc