aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-08-14 01:47:24 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-08-14 01:47:24 +0000
commit6e4232f1dae753b302e07293c73db749cce2fa8a (patch)
tree5482eb7dc861c36601e18fc60a26d831ca6109e4 /databases
parent2a3e3ee8fc42ea747728451ff507c68732bd05c3 (diff)
downloadports-6e4232f1dae753b302e07293c73db749cce2fa8a.tar.gz
ports-6e4232f1dae753b302e07293c73db749cce2fa8a.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Class-Validation/Makefile35
-rw-r--r--databases/p5-DBIx-Class-Validation/distinfo3
-rw-r--r--databases/p5-DBIx-Class-Validation/pkg-descr4
-rw-r--r--databases/p5-DBIx-Class-Validation/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e5c5a0bf3d1b..2b7ad24201e0 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -245,6 +245,7 @@
SUBDIR += p5-DBIx-Class-Loader
SUBDIR += p5-DBIx-Class-Schema-Loader
SUBDIR += p5-DBIx-Class-UUIDColumns
+ SUBDIR += p5-DBIx-Class-Validation
SUBDIR += p5-DBIx-Class-WebForm
SUBDIR += p5-DBIx-ContextualFetch
SUBDIR += p5-DBIx-DBSchema
diff --git a/databases/p5-DBIx-Class-Validation/Makefile b/databases/p5-DBIx-Class-Validation/Makefile
new file mode 100644
index 000000000000..84af769c327d
--- /dev/null
+++ b/databases/p5-DBIx-Class-Validation/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: databases/p5-DBIx-Class-Validation
+# Date created: 03 Aug 2007
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-Validation
+PORTVERSION= 0.02000
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Validate data before submitting to a database
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Install.pm:${PORTSDIR}/devel/p5-Module-Install \
+ ${SITE_PERL}/Data/FormValidator.pm:${PORTSDIR}/textproc/p5-Data-FormValidator \
+ ${SITE_PERL}/FormValidator/Simple.pm:${PORTSDIR}/textproc/p5-FormValidator-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ ${SITE_PERL}/DBIx/Class.pm:${PORTSDIR}/databases/p5-DBIx-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::Validation.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBIx-Class-Validation/distinfo b/databases/p5-DBIx-Class-Validation/distinfo
new file mode 100644
index 000000000000..ad0c3d572d9b
--- /dev/null
+++ b/databases/p5-DBIx-Class-Validation/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Class-Validation-0.02000.tar.gz) = af0ba38e3d5f665efdf28763600b3344
+SHA256 (DBIx-Class-Validation-0.02000.tar.gz) = 1e5753b5ac0259bac387c7de8181086818224ceb99e73f10b6825b6ee52c6e0c
+SIZE (DBIx-Class-Validation-0.02000.tar.gz) = 24829
diff --git a/databases/p5-DBIx-Class-Validation/pkg-descr b/databases/p5-DBIx-Class-Validation/pkg-descr
new file mode 100644
index 000000000000..5af06bf4bb9d
--- /dev/null
+++ b/databases/p5-DBIx-Class-Validation/pkg-descr
@@ -0,0 +1,4 @@
+Module that allows validation of data before submission to a
+database.
+
+WWW: http://search.cpan.org/dist/DBIx-Class-Validation/
diff --git a/databases/p5-DBIx-Class-Validation/pkg-plist b/databases/p5-DBIx-Class-Validation/pkg-plist
new file mode 100644
index 000000000000..b06b682cec7a
--- /dev/null
+++ b/databases/p5-DBIx-Class-Validation/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DBIx/Class/Validation.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/Validation/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/Validation
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx
+@dirrmtry %%SITE_PERL%%/DBIx/Class
+@dirrmtry %%SITE_PERL%%/DBIx