aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-28 09:36:56 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-28 09:36:56 +0000
commitec5d9a54d6ab26763058c7543a07c20471c88c83 (patch)
tree5b1656d091ca74a23ee2a9be5fc60e5f9fc374fb /databases
parentaaf6e1847df2bd9a00d7c66e1c514b17a6326239 (diff)
downloadports-ec5d9a54d6ab26763058c7543a07c20471c88c83.tar.gz
ports-ec5d9a54d6ab26763058c7543a07c20471c88c83.zip
Downgrade C++03 to C++98, actual default for GCC < 6
GCC 4.2 in base system doesn't support C++03: cc1plus: error: unrecognized command line option "-std=gnu++03"
Notes
Notes: svn path=/head/; revision=483249
Diffstat (limited to 'databases')
-rw-r--r--databases/fastdb/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 9a4e6b8c5f35..917b02ec25ce 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -12,10 +12,6 @@ COMMENT= Main Memory Relational Database Management System
LICENSE= MIT
-BROKEN_mips= fails to compile: unrecognized command line option "-std=gnu++03"
-BROKEN_mips64= fails to compile: unrecognized command line option "-std=gnu++03"
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-std=gnu++03"
-
USES= gmake dos2unix
USE_GCC= any
MAKE_ENV= OSTYPE="${OPSYS}"
@@ -31,7 +27,7 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= FastDB.htm
# The port does not build with C++11 or later (bug 219275).
-USE_CXXSTD= gnu++03
+USE_CXXSTD= gnu++98
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}