aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-01-04 15:53:39 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-01-04 15:53:39 +0000
commitb2c46c868cc96c81b525dff6d171894917d46f98 (patch)
treec66dd220e2259f4aa778ff1bb17f3f5de39db32d /databases
parente9ef928f2046c0f8ce94551ee6e9d9ec43bd08e4 (diff)
downloadports-b2c46c868cc96c81b525dff6d171894917d46f98.tar.gz
ports-b2c46c868cc96c81b525dff6d171894917d46f98.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/grass-i18n/Makefile3
-rw-r--r--databases/grass/Makefile3
-rw-r--r--databases/gtksql/Makefile3
-rw-r--r--databases/libgda2/Makefile3
-rw-r--r--databases/libgda3/Makefile3
-rw-r--r--databases/p5-DBD-Pg-13/Makefile4
-rw-r--r--databases/p5-DBD-Pg/Makefile4
-rw-r--r--databases/p5-Pg/Makefile6
-rw-r--r--databases/phppgadmin/Makefile3
-rw-r--r--databases/py-PyGreSQL/Makefile4
-rw-r--r--databases/py-psycopg/Makefile3
-rw-r--r--databases/ruby-postgres/Makefile4
-rw-r--r--databases/rubygem-postgres/Makefile4
-rw-r--r--databases/sqlrelay/Makefile4
-rw-r--r--databases/zpygresqlda/Makefile3
15 files changed, 37 insertions, 17 deletions
diff --git a/databases/grass-i18n/Makefile b/databases/grass-i18n/Makefile
index db0e52ecfc18..46aa1cf4e113 100644
--- a/databases/grass-i18n/Makefile
+++ b/databases/grass-i18n/Makefile
@@ -15,6 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= reg@FreeBSD.org
+POSTGRESQL_PORT?= databases/postgresql7
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -23,7 +24,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
iconv.3:${PORTSDIR}/converters/libiconv \
freetype.9:${PORTSDIR}/print/freetype2 \
gdbm.3:${PORTSDIR}/databases/gdbm \
- pq.2:${PORTSDIR}/databases/postgresql7 \
+ pq.3:${PORTSDIR}/${POSTGRESQL_PORT} \
odbc.1:${PORTSDIR}/databases/unixODBC \
lapack.3:${PORTSDIR}/math/lapack
BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83 \
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index db0e52ecfc18..46aa1cf4e113 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -15,6 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= reg@FreeBSD.org
+POSTGRESQL_PORT?= databases/postgresql7
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -23,7 +24,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
iconv.3:${PORTSDIR}/converters/libiconv \
freetype.9:${PORTSDIR}/print/freetype2 \
gdbm.3:${PORTSDIR}/databases/gdbm \
- pq.2:${PORTSDIR}/databases/postgresql7 \
+ pq.3:${PORTSDIR}/${POSTGRESQL_PORT} \
odbc.1:${PORTSDIR}/databases/unixODBC \
lapack.3:${PORTSDIR}/math/lapack
BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83 \
diff --git a/databases/gtksql/Makefile b/databases/gtksql/Makefile
index 10d7bfeed8db..96cd5765216e 100644
--- a/databases/gtksql/Makefile
+++ b/databases/gtksql/Makefile
@@ -19,6 +19,7 @@ WITH_MYSQL= yes
USE_X_PREFIX= yes
USE_GTK= yes
+POSTGRESQL_PORT?= databases/postgresql7
.include <bsd.port.pre.mk>
@@ -30,7 +31,7 @@ LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.if defined(WITH_PGSQL) || (exists(${LOCALBASE}/lib/libpq.a) \
&& !defined(WITHOUT_PGSQL))
HAVE_PGSQL= yes
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
pre-patch:
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index 5baad1b6a879..3387be688dd8 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -45,7 +45,8 @@ PLIST_SUB= MYSQL="@comment "
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= POSTGRES=""
.else
diff --git a/databases/libgda3/Makefile b/databases/libgda3/Makefile
index 5baad1b6a879..3387be688dd8 100644
--- a/databases/libgda3/Makefile
+++ b/databases/libgda3/Makefile
@@ -45,7 +45,8 @@ PLIST_SUB= MYSQL="@comment "
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= POSTGRES=""
.else
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index da5dab47fe33..431d0c26831b 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -15,9 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fjoe@freebsd.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
RUN_DEPENDS= ${BUILD_DEPENDS}
+POSTGRESQL_PORT?= databases/postgresql7
+
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index da5dab47fe33..431d0c26831b 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -15,9 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fjoe@freebsd.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
RUN_DEPENDS= ${BUILD_DEPENDS}
+POSTGRESQL_PORT?= databases/postgresql7
+
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
diff --git a/databases/p5-Pg/Makefile b/databases/p5-Pg/Makefile
index 90b52da5d0bb..891e2d2ab470 100644
--- a/databases/p5-Pg/Makefile
+++ b/databases/p5-Pg/Makefile
@@ -13,9 +13,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= girgen@partitur.se
POSTGRESQL_SUBPORT=YES
-.include <${.CURDIR}/../postgresql7/Makefile>
-
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+.include <${.CURDIR}/../../${POSTGRESQL_PORT}/Makefile>
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
USE_PERL5= yes
diff --git a/databases/phppgadmin/Makefile b/databases/phppgadmin/Makefile
index e96a722fbbd4..8c4718ab0f6b 100644
--- a/databases/phppgadmin/Makefile
+++ b/databases/phppgadmin/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.else
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
.endif
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
WRKSRC= ${WRKDIR}/phpPgAdmin
NO_BUILD= YES
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 12768f05fd94..196f60225eea 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -16,7 +16,9 @@ POSTGRESQL_SUBPORT= YES
BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+POSTGRESQL_PORT?= databases/postgresql7
USE_PYTHON= yes
CONFIGURE_ARGS= --with-python --prefix=${PREFIX}
diff --git a/databases/py-psycopg/Makefile b/databases/py-psycopg/Makefile
index 4f89b3f996a5..d51a9ef4f0f7 100644
--- a/databases/py-psycopg/Makefile
+++ b/databases/py-psycopg/Makefile
@@ -16,8 +16,9 @@ MAINTAINER= simuran@shaw.ca
RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.2:${PORTSDIR}/${POSTGRESQL_PORT}
+POSTGRESQL_PORT?= databases/postgresql7
USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
diff --git a/databases/ruby-postgres/Makefile b/databases/ruby-postgres/Makefile
index 02df47cec0e8..784f467b5dc6 100644
--- a/databases/ruby-postgres/Makefile
+++ b/databases/ruby-postgres/Makefile
@@ -15,7 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+POSTGRESQL_PORT?= databases/postgresql7
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/databases/rubygem-postgres/Makefile b/databases/rubygem-postgres/Makefile
index 02df47cec0e8..784f467b5dc6 100644
--- a/databases/rubygem-postgres/Makefile
+++ b/databases/rubygem-postgres/Makefile
@@ -15,7 +15,9 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+POSTGRESQL_PORT?= databases/postgresql7
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index 88ef9e257cc0..366031b5e2b2 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -31,6 +31,8 @@ CONFIGURE_ARGS= ${SQLRELAY_CONFIGURE_ARGS} \
MAKE_ARGS= VERSION="${PORTVERSION:R}"
INSTALLS_SHLIB= yes
+POSTGRESQL_PORT?= databases/postgresql7
+
.include "${.CURDIR}/Makefile.common"
.if defined(PACKAGE_BUILDING) || defined(BATCH)
@@ -82,7 +84,7 @@ IF_MSQL= "@comment "
.endif
.if defined(WITH_POSTGRESQL) && ${WITH_POSTGRESQL:L} != no
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgresql-prefix="${LOCALBASE}"
IF_POSTGRESQL= ""
.else
diff --git a/databases/zpygresqlda/Makefile b/databases/zpygresqlda/Makefile
index 11f74a7dc557..16bd89930e51 100644
--- a/databases/zpygresqlda/Makefile
+++ b/databases/zpygresqlda/Makefile
@@ -15,8 +15,9 @@ DISTNAME= ZPyGreSQLDA-0.3-rjr2
MAINTAINER= nbm@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+POSTGRESQL_PORT?= databases/postgresql7
PYTHON_VERSION= python1.5
# You can change this in the environment