aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-04 10:55:23 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-04 10:55:23 +0000
commit5aa43c1aba1579d88f80fc6f75f5b1fcb3df4b66 (patch)
tree8252139e7b614c53058f1ef8f9b3f7ef729f31c0 /databases
parent243c0ad4d0252af27fdabdff1c8e04581608e044 (diff)
downloadports-5aa43c1aba1579d88f80fc6f75f5b1fcb3df4b66.tar.gz
ports-5aa43c1aba1579d88f80fc6f75f5b1fcb3df4b66.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/py-sqlalchemy/Makefile8
-rw-r--r--databases/py-sqlalchemy06/Makefile8
-rw-r--r--databases/py-sqlite3dbm/Makefile10
-rw-r--r--databases/py-sqlkit/Makefile8
-rw-r--r--databases/py-sqlobject/Makefile2
5 files changed, 10 insertions, 26 deletions
diff --git a/databases/py-sqlalchemy/Makefile b/databases/py-sqlalchemy/Makefile
index fc6d45e6e7ca..4dfde209811b 100644
--- a/databases/py-sqlalchemy/Makefile
+++ b/databases/py-sqlalchemy/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: py-sqlalchemy
-# Date created: 12 August 2004
-# Whom: Dryice Dong Liu <dryice@dryice.name>
-#
+# Created by: Dryice Dong Liu <dryice@dryice.name>
# $FreeBSD$
-#
PORTNAME= sqlalchemy
PORTVERSION= 0.7.8
@@ -79,7 +75,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:${PORTSDIR}/databases/py-ps
.endif
.if ${PORT_OPTIONS:MSQLITE}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
.endif
.if ${PORT_OPTIONS:MSYBASE}
diff --git a/databases/py-sqlalchemy06/Makefile b/databases/py-sqlalchemy06/Makefile
index 89de549b1195..e42ff3fa839a 100644
--- a/databases/py-sqlalchemy06/Makefile
+++ b/databases/py-sqlalchemy06/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: py-sqlalchemy
-# Date created: 12 August 2004
-# Whom: Dryice Dong Liu <dryice@dryice.name>
-#
+# Created by: Dryice Dong Liu <dryice@dryice.name>
# $FreeBSD$
-#
PORTNAME= sqlalchemy06
PORTVERSION= 0.6.9
@@ -87,7 +83,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:${PORTSDIR}/databases/py-ps
.endif
.if ${PORT_OPTIONS:MSQLITE}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
.endif
.if ${PORT_OPTIONS:MSYBASE}
diff --git a/databases/py-sqlite3dbm/Makefile b/databases/py-sqlite3dbm/Makefile
index 9520e66f09f1..d94b47083724 100644
--- a/databases/py-sqlite3dbm/Makefile
+++ b/databases/py-sqlite3dbm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-sqlite3dbm
-# Date created: Oct 28, 2011
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= sqlite3dbm
PORTVERSION= 0.1.4
@@ -14,8 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Sqlite-backed dictionary
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
diff --git a/databases/py-sqlkit/Makefile b/databases/py-sqlkit/Makefile
index 0215080b53ae..d917f46bdf79 100644
--- a/databases/py-sqlkit/Makefile
+++ b/databases/py-sqlkit/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: databases/py-sqlkit
-# Date created: 2011-05-09
-# Whom: bsam
-#
+# Created by: bsam
# $FreeBSD$
-#
PORTNAME= sqlkit
PORTVERSION= 0.9.5.1
@@ -61,7 +57,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:${PORTSDIR}/databases/py-ps
.endif
.if ${PORT_OPTIONS:MSQLITE}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
.endif
.if ${PORT_OPTIONS:MSYBASE}
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
index 20adc0a8ee5a..bc032307be46 100644
--- a/databases/py-sqlobject/Makefile
+++ b/databases/py-sqlobject/Makefile
@@ -42,7 +42,7 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py
.endif
.if ${PORT_OPTIONS:MSQLITE}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
.endif
.if ${PORT_OPTIONS:MMSSQL}