aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-08 20:23:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-08 20:23:45 +0000
commitef1b3d107105075700da0844ac072acae2de7726 (patch)
tree14d3f35f7d5dc26e8e8feed96c01af49bd9e4d3d /databases
parenta71e0ff08b3f1acf82cd96524c18b3a653ed1954 (diff)
downloadports-ef1b3d107105075700da0844ac072acae2de7726.tar.gz
ports-ef1b3d107105075700da0844ac072acae2de7726.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/akonadi/Makefile15
-rw-r--r--databases/akonadi/distinfo6
-rw-r--r--databases/akonadi/pkg-plist14
3 files changed, 14 insertions, 21 deletions
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index d3fba1472de9..b754f7958b5c 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= akonadi
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.1.1
CATEGORIES= databases kde ipv6
MASTER_SITES= http://akonadi.omat.nl/
DIST_SUBDIR= KDE
@@ -14,16 +13,17 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Storage server for kdepim
+LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python
BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
- ${LOCALBASE}/lib/qt4/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin \
${LOCALBASE}/bin/mysqld_safe:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
RUN_DEPENDS+= update-mime-database:${PORTSDIR}/misc/shared-mime-info \
- ${LOCALBASE}/bin/mysqld_safe:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+ ${LOCALBASE}/bin/mysqld_safe:${PORTSDIR}/databases/mysql${MYSQL_VER}-server \
+ ${QT_PREFIX}/lib/qt4/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin
USE_BZIP2= yes
USE_QT_VER= 4
USE_XORG= x11
-QT_COMPONENTS= corelib network qtestlib dbus \
+QT_COMPONENTS= corelib network qtestlib dbus sql \
qmake_build moc_build rcc_build uic_build
USE_MYSQL= yes
USE_KDE4= kdeprefix kdehier automoc4 sharedmime
@@ -34,9 +34,6 @@ post-extract:
${MKDIR} ${WRKSRC}
post-patch:
-#fix finding automoc when PREFIX is not matched KDE4_PREFIX
- ${REINPLACE_CMD} -e 's|NO_DEFAULT_PATH|${KDE4_PREFIX} NO_DEFAULT_PATH|' \
- ${WRKSRC}/../cmake/modules/FindAutomoc4.cmake
${REINPLACE_CMD} -e '/akonadi.pc/s|pkgconfig|../libdata/pkgconfig|' \
${PATCH_WRKSRC}/CMakeLists.txt
${CP} ${PATCH_WRKSRC}/server/src/storage/entities-header.xsl \
@@ -52,7 +49,7 @@ post-patch:
${REINPLACE_CMD} -e 's|include "entities.h"|include <entitiesKDE4.h>|g' \
-e 's|include <entities.h>|include <entitiesKDE4.h>|g'
.endfor
- ${REINPLACE_CMD} -e 's| MYSQLD_EXECUTABLE mysqld | MYSQLD_EXECUTABLE mysqld_safe /usr/local/bin |g' \
+ ${REINPLACE_CMD} -e '/find_program/s|mysqld|mysqld_safe ${LOCALBASE}/bin|g' \
${PATCH_WRKSRC}/server/CMakeLists.txt
#prevent updating mime during build
${REINPLACE_CMD} -e '/^update_xdg_mimetypes/d; /SharedMimeInfo/d' \
diff --git a/databases/akonadi/distinfo b/databases/akonadi/distinfo
index 24eb5a0e0ac2..1f98707dea7d 100644
--- a/databases/akonadi/distinfo
+++ b/databases/akonadi/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/akonadi-1.0.0.tar.bz2) = 90039928f818a55a7e2a1bf852a32f2d
-SHA256 (KDE/akonadi-1.0.0.tar.bz2) = fab1f59019d277ad461acaa866a520350240927c3c526cbfdebe825cc6be55fd
-SIZE (KDE/akonadi-1.0.0.tar.bz2) = 122815
+MD5 (KDE/akonadi-1.1.1.tar.bz2) = 2e98b42cec9ec4e60a2e3c096f1a3106
+SHA256 (KDE/akonadi-1.1.1.tar.bz2) = 7706b9de686a746c0832cd92bd2567114d6257781f3190a9e63a9f5a53d44913
+SIZE (KDE/akonadi-1.1.1.tar.bz2) = 134761
diff --git a/databases/akonadi/pkg-plist b/databases/akonadi/pkg-plist
index 34540c408bb6..a66711f37f39 100644
--- a/databases/akonadi/pkg-plist
+++ b/databases/akonadi/pkg-plist
@@ -9,16 +9,17 @@ include/akonadi/private/protocol_p.h
include/akonadi/private/xdgbasedirs_p.h
lib/libakonadiprivate.so
lib/libakonadiprivate.so.1
-lib/libakonadiprivate.so.1.0.0
+lib/libakonadiprivate.so.1.1.1
lib/libakonadiprotocolinternals.so
lib/libakonadiprotocolinternals.so.1
-lib/libakonadiprotocolinternals.so.1.0.0
+lib/libakonadiprotocolinternals.so.1.1.1
libdata/pkgconfig/akonadi.pc
share/config/akonadi/mysql-global.conf
share/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Control.xml
share/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Status.xml
share/dbus-1/interfaces/org.freedesktop.Akonadi.AgentManager.xml
share/dbus-1/interfaces/org.freedesktop.Akonadi.ControlManager.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.DebugInterface.xml
share/dbus-1/interfaces/org.freedesktop.Akonadi.NotificationManager.xml
share/dbus-1/interfaces/org.freedesktop.Akonadi.Resource.xml
share/dbus-1/interfaces/org.freedesktop.Akonadi.Search.xml
@@ -29,13 +30,8 @@ share/dbus-1/interfaces/org.freedesktop.Akonadi.Tracer.xml
share/dbus-1/interfaces/org.freedesktop.Akonadi.TracerNotification.xml
share/dbus-1/services/org.freedesktop.Akonadi.Control.service
share/mime/packages/akonadi-mime.xml
-@dirrmtry share/mime/packages
-@dirrmtry share/mime
-@dirrmtry share/dbus-1/services
@dirrm share/config/akonadi
-@dirrmtry share/config
-@dirrmtry share/pixmaps
-@dirrm include/akonadi/private
-@dirrm include/akonadi
+@dirrmtry include/akonadi/private
+@dirrmtry include/akonadi
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true