aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-12-09 01:55:51 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-12-09 01:55:51 +0000
commit05bb847615018d9ac2037056d2e2518956e03966 (patch)
tree956ece6e81664544dec0a29dc708d9f5d794cb8b /databases
parentdef26a01da7ac2847a4dec99511a88c9ee64f819 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/py-pylibmc/Makefile19
-rw-r--r--databases/py-pylibmc/distinfo4
-rw-r--r--databases/py-pylibmc/files/patch-setup.cfg8
-rw-r--r--databases/py-pylibmc/files/patch-setup.py8
-rw-r--r--databases/py-pylibmc/pkg-descr13
5 files changed, 43 insertions, 9 deletions
diff --git a/databases/py-pylibmc/Makefile b/databases/py-pylibmc/Makefile
index ba2784abe0bd..592cd5524db4 100644
--- a/databases/py-pylibmc/Makefile
+++ b/databases/py-pylibmc/Makefile
@@ -2,22 +2,33 @@
# $FreeBSD$
PORTNAME= pylibmc
-PORTVERSION= 1.3.0
-PORTREVISION= 1
+PORTVERSION= 1.4.1
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Python wrapper around the libmemcached interface
+COMMENT= Quick and small memcached client for Python
LICENSE= BSD3CLAUSE
LIB_DEPENDS= libmemcached.so:${PORTSDIR}/databases/libmemcached
+TEST_DEPENDS= memcached:${PORTSDIR}/databases/memcached \
+ nosetests:${PORTSDIR}/devel/py-nose
-USES= python:2
+OPTIONS_DEFINE= TESTS
+TESTS_DESC= Install test suite dependencies
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+
+USES= python
USE_PYTHON= distutils autoplist
MAKE_ENV+= LIBMEMCACHED="${LOCALBASE}"
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_pylibmc.so
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
.include <bsd.port.mk>
diff --git a/databases/py-pylibmc/distinfo b/databases/py-pylibmc/distinfo
index 4386f04fc973..f42d6b1943b1 100644
--- a/databases/py-pylibmc/distinfo
+++ b/databases/py-pylibmc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pylibmc-1.3.0.tar.gz) = a6945a4c77f96d5b744118805247fb24c09f1d353aebbce6dd510a6042689b45
-SIZE (pylibmc-1.3.0.tar.gz) = 49949
+SHA256 (pylibmc-1.4.1.tar.gz) = a00e75f5c76e573e95ac5b29cb8a816728930f29332c49c74dbfd326d598088f
+SIZE (pylibmc-1.4.1.tar.gz) = 53360
diff --git a/databases/py-pylibmc/files/patch-setup.cfg b/databases/py-pylibmc/files/patch-setup.cfg
new file mode 100644
index 000000000000..7c4bc9731649
--- /dev/null
+++ b/databases/py-pylibmc/files/patch-setup.cfg
@@ -0,0 +1,8 @@
+--- setup.cfg.orig 2014-12-09 01:22:54 UTC
++++ setup.cfg
+@@ -1,5 +1,4 @@
+ [nosetests]
+-with-info=1
+ with-doctest=1
+ debug=nose.plugins.pylibmc
+ doctest-extension=txt
diff --git a/databases/py-pylibmc/files/patch-setup.py b/databases/py-pylibmc/files/patch-setup.py
new file mode 100644
index 000000000000..49a1ac2d22e3
--- /dev/null
+++ b/databases/py-pylibmc/files/patch-setup.py
@@ -0,0 +1,8 @@
+--- setup.py.orig 2014-12-09 01:16:30 UTC
++++ setup.py
+@@ -122,4 +122,5 @@ setup(
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ ],
++ test_suite = 'nose.collector'
+ )
diff --git a/databases/py-pylibmc/pkg-descr b/databases/py-pylibmc/pkg-descr
index c363fa4c46e3..55968e713b11 100644
--- a/databases/py-pylibmc/pkg-descr
+++ b/databases/py-pylibmc/pkg-descr
@@ -1,4 +1,11 @@
-pylibmc is a Python wrapper around the accompanying C Python extension
-_pylibmc, which is a wrapper around libmemcached from TangentOrg.
+pylibmc is a client in Python for memcached. It is a wrapper around
+TangentOrg's libmemcached library.
-WWW: https://pypi.python.org/pypi/pylibmc
+The interface is intentionally made as close to python-memcached as possible,
+so that applications can drop-in replace it.
+
+pylibmc leverages among other things configurable behaviors, data pickling,
+data compression, battle-tested GIL retention, consistent distribution, and
+the binary memcached protocol.
+
+WWW: http://sendapatch.se/projects/pylibmc