aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-30 19:20:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-30 19:20:22 +0000
commit4efa9ce4aba677e16625a76f8415226114d2d072 (patch)
tree768a9d49a28e618c67e66b92df38c1d490e817b4 /databases
parente60f196636352a608c09494e14f7820b3215a15d (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/clip/Makefile4
-rw-r--r--databases/freetds-devel/Makefile3
-rw-r--r--databases/freetds/Makefile3
-rw-r--r--databases/grass-i18n/Makefile2
-rw-r--r--databases/grass/Makefile2
-rw-r--r--databases/hk_classes/Makefile3
-rw-r--r--databases/namazu2/Makefile4
-rw-r--r--databases/sqlrelay/Makefile4
8 files changed, 10 insertions, 15 deletions
diff --git a/databases/clip/Makefile b/databases/clip/Makefile
index e1abaeb9a520..fbe35c2d055c 100644
--- a/databases/clip/Makefile
+++ b/databases/clip/Makefile
@@ -34,8 +34,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2 \
gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra \
- gd.4:${PORTSDIR}/graphics/gd \
- iconv.3:${PORTSDIR}/converters/libiconv
+ gd.4:${PORTSDIR}/graphics/gd
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
wget:${PORTSDIR}/ftp/wget
@@ -72,6 +71,7 @@ PLIST_SUB+= IBASE="@comment "
USE_BISON= yes
USE_GMAKE= yes
+USE_ICONV= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
USE_XLIB= yes
diff --git a/databases/freetds-devel/Makefile b/databases/freetds-devel/Makefile
index 694330c23754..6baa6014a5ae 100644
--- a/databases/freetds-devel/Makefile
+++ b/databases/freetds-devel/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= ALPHA/freetds/stable
MAINTAINER?= kiesel@schlund.de
COMMENT= Sybase/Microsoft TDS protocol library
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
+USE_ICONV= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_GONFIGURE= yes
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 694330c23754..6baa6014a5ae 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= ALPHA/freetds/stable
MAINTAINER?= kiesel@schlund.de
COMMENT= Sybase/Microsoft TDS protocol library
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
+USE_ICONV= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_GONFIGURE= yes
diff --git a/databases/grass-i18n/Makefile b/databases/grass-i18n/Makefile
index e09aeaa0b9c2..58c8eba974a7 100644
--- a/databases/grass-i18n/Makefile
+++ b/databases/grass-i18n/Makefile
@@ -23,7 +23,6 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
gd.4:${PORTSDIR}/graphics/gd \
fftw.2:${PORTSDIR}/math/fftw \
- iconv.3:${PORTSDIR}/converters/libiconv \
freetype.9:${PORTSDIR}/print/freetype2 \
gdbm.3:${PORTSDIR}/databases/gdbm \
pq.3:${PORTSDIR}/${POSTGRESQL_PORT} \
@@ -38,6 +37,7 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude *CVS*
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+USE_ICONV= yes
USE_XLIB= yes
USE_MESA= yes
USE_PERL5= yes
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index e09aeaa0b9c2..58c8eba974a7 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -23,7 +23,6 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
gd.4:${PORTSDIR}/graphics/gd \
fftw.2:${PORTSDIR}/math/fftw \
- iconv.3:${PORTSDIR}/converters/libiconv \
freetype.9:${PORTSDIR}/print/freetype2 \
gdbm.3:${PORTSDIR}/databases/gdbm \
pq.3:${PORTSDIR}/${POSTGRESQL_PORT} \
@@ -38,6 +37,7 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude *CVS*
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+USE_ICONV= yes
USE_XLIB= yes
USE_MESA= yes
USE_PERL5= yes
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index 64c9b2dfc44a..6e50d6ec01f7 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -13,8 +13,7 @@ MASTER_SITE_SUBDIR= hk-classes
MAINTAINER= sem@ciam.ru
COMMENT= C++ Library for rapid development of database applications
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
+USE_ICONV= yes
USE_PYTHON= yes
CONFIGURE_ENV+= LIBPYTHON="-l${PYTHON_VERSION} ${PTHREAD_LIBS}"
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/databases/namazu2/Makefile b/databases/namazu2/Makefile
index 5c0825dcec07..00203241ab53 100644
--- a/databases/namazu2/Makefile
+++ b/databases/namazu2/Makefile
@@ -21,12 +21,10 @@ COMMENT= Full-text search system intended for easy use
BUILD_DEPENDS= ${PM_BASE}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic
RUN_DEPENDS= ${PM_BASE}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-# xlHtml:${PORTSDIR}/textproc/xlhtml \
-# wvHtml:${PORTSDIR}/textproc/wv
PM_BASE= ${SITE_PERL}
+USE_ICONV= yes
USE_GETTEXT= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index a4240f207807..4a7c9690ac2c 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -16,9 +16,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A persistent DB connection pooling/proxying/load balancing system
LIB_DEPENDS= rudiments.0:${PORTSDIR}/devel/rudiments \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- iconv.3:${PORTSDIR}/converters/libiconv
+ xml2.5:${PORTSDIR}/textproc/libxml2
+USE_ICONV= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes