aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-26 10:44:28 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-26 10:44:28 +0000
commit83f02b963c2b22c85235bf19b4f10a20bea921b5 (patch)
treee5e83d3ba0442c1c2f0b99c843428b36a8eb003d /databases
parent152f30ef73f9cf1c87d1eb78186693682bed0c43 (diff)
downloadports-83f02b963c2b22c85235bf19b4f10a20bea921b5.tar.gz
ports-83f02b963c2b22c85235bf19b4f10a20bea921b5.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/dbf/Makefile2
-rw-r--r--databases/evolution-data-server/Makefile3
-rw-r--r--databases/gtksql/Makefile2
-rw-r--r--databases/hk_classes/Makefile3
-rw-r--r--databases/libgda4/Makefile3
5 files changed, 5 insertions, 8 deletions
diff --git a/databases/dbf/Makefile b/databases/dbf/Makefile
index cf3cb90d278f..d4a1b8c64cc4 100644
--- a/databases/dbf/Makefile
+++ b/databases/dbf/Makefile
@@ -27,7 +27,7 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
PLIST_SUB+= NLS=""
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index a9df23fba152..574103f87bf6 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup \
USE_BZIP2= yes
USE_GMAKE= yes
-USES= bison pathfix
-USE_GETTEXT= yes
+USES= bison pathfix gettext
USE_GNOME= gnomeprefix intlhack ltverhack ltasneededhack gconf2 \
libxml2
USE_OPENLDAP= yes
diff --git a/databases/gtksql/Makefile b/databases/gtksql/Makefile
index 509dbcc8c51b..18d9d6f61979 100644
--- a/databases/gtksql/Makefile
+++ b/databases/gtksql/Makefile
@@ -36,7 +36,7 @@ CONFIGURE_ARGS+=--without-mysql
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index deec17afe57e..c0e16f4a5def 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -13,11 +13,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
xml2.5:${PORTSDIR}/textproc/libxml2
-USES= pkgconfig
+USES= pkgconfig gettext
USE_BZIP2= yes
USE_ICONV= yes
USE_PYTHON= yes
-USE_GETTEXT= yes
CXXFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -largp -lintl
USE_AUTOTOOLS= libtool
diff --git a/databases/libgda4/Makefile b/databases/libgda4/Makefile
index 2821f115797c..1c2e36fbaa2f 100644
--- a/databases/libgda4/Makefile
+++ b/databases/libgda4/Makefile
@@ -24,9 +24,8 @@ LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
json-glib-1.0:${PORTSDIR}/devel/json-glib
USE_AUTOTOOLS= libtool
-USE_GETTEXT= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix glib20 libxslt intlhack referencehack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes