aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-03-27 08:25:14 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-03-27 08:25:14 +0000
commitd7337730a1c9111a389d0ce8d6fed8330dc73eb4 (patch)
tree65c6bdb7575d20de710173e40580fbf1fd52f5f2 /databases
parent9d70fa99f4fb37a9c20de3738b4cd1645a19e260 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-DBIx-Class/Makefile25
-rw-r--r--databases/p5-DBIx-Class/distinfo6
-rw-r--r--databases/p5-DBIx-Class/pkg-descr31
-rw-r--r--databases/p5-DBIx-Class/pkg-plist32
4 files changed, 72 insertions, 22 deletions
diff --git a/databases/p5-DBIx-Class/Makefile b/databases/p5-DBIx-Class/Makefile
index 6208260e7e56..9abbfa63af31 100644
--- a/databases/p5-DBIx-Class/Makefile
+++ b/databases/p5-DBIx-Class/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DBIx-Class
-PORTVERSION= 0.05007
+PORTVERSION= 0.06000
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBIx
@@ -36,13 +36,15 @@ MAN3= DBIx::Class.3 \
DBIx::Class::AccessorGroup.3 \
DBIx::Class::CDBICompat.3 \
DBIx::Class::Core.3 \
+ DBIx::Class::Cursor.3 \
DBIx::Class::DB.3 \
DBIx::Class::InflateColumn.3 \
DBIx::Class::Manual.3 \
+ DBIx::Class::Manual::Component.3 \
DBIx::Class::Manual::Cookbook.3 \
- DBIx::Class::Manual::FAQ.3 \
+ DBIx::Class::Manual::Example.3 \
+ DBIx::Class::Manual::Glossary.3 \
DBIx::Class::Manual::Intro.3 \
- DBIx::Class::Manual::SchemaIntro.3 \
DBIx::Class::Manual::Troubleshooting.3 \
DBIx::Class::PK.3 \
DBIx::Class::PK::Auto.3 \
@@ -62,10 +64,25 @@ MAN3= DBIx::Class.3 \
DBIx::Class::ResultSourceProxy::Table.3 \
DBIx::Class::Row.3 \
DBIx::Class::Schema.3 \
- DBIx::Class::Serialize.3 \
+ DBIx::Class::Serialize::Storable.3 \
DBIx::Class::Storage::DBI.3 \
+ DBIx::Class::Storage::DBI::Cursor.3 \
+ DBIx::Class::Storage::DBI::DB2.3 \
+ DBIx::Class::Storage::DBI::MSSQL.3 \
+ DBIx::Class::Storage::DBI::Oracle.3 \
+ DBIx::Class::Storage::DBI::Pg.3 \
+ DBIx::Class::Storage::DBI::SQLite.3 \
+ DBIx::Class::Storage::DBI::mysql.3 \
DBIx::Class::Test::SQLite.3 \
+ DBIx::Class::UTF8Columns.3 \
DBIx::Class::UUIDColumns.3 \
+ DBIx::Class::UUIDMaker.3 \
+ DBIx::Class::UUIDMaker::APR::UUID.3 \
+ DBIx::Class::UUIDMaker::Data::UUID.3 \
+ DBIx::Class::UUIDMaker::Data::Uniqid.3 \
+ DBIx::Class::UUIDMaker::UUID.3 \
+ DBIx::Class::UUIDMaker::Win32::Guidgen.3 \
+ DBIx::Class::UUIDMaker::Win32API::GUID.3 \
DBIx::Class::Validation.3 \
SQL::Translator::Producer::DBIx::Class::File.3
diff --git a/databases/p5-DBIx-Class/distinfo b/databases/p5-DBIx-Class/distinfo
index 42388b87dbd2..0e4a56bb801d 100644
--- a/databases/p5-DBIx-Class/distinfo
+++ b/databases/p5-DBIx-Class/distinfo
@@ -1,3 +1,3 @@
-MD5 (DBIx-Class-0.05007.tar.gz) = c20304fac4296e4982ad64a2226de347
-SHA256 (DBIx-Class-0.05007.tar.gz) = a39338205320f6ca84fff2f94641475a8fad10a13e5688bb0e43eb56e9e82d8e
-SIZE (DBIx-Class-0.05007.tar.gz) = 104347
+MD5 (DBIx-Class-0.06000.tar.gz) = 63fec9467b0c7b23d3e9e7e74d89419f
+SHA256 (DBIx-Class-0.06000.tar.gz) = f8f06756ac0d752b02adf0b96559d15f59847b8d48f122344e75dff9621f216d
+SIZE (DBIx-Class-0.06000.tar.gz) = 128808
diff --git a/databases/p5-DBIx-Class/pkg-descr b/databases/p5-DBIx-Class/pkg-descr
index 367dc4fb0f56..727692ee71de 100644
--- a/databases/p5-DBIx-Class/pkg-descr
+++ b/databases/p5-DBIx-Class/pkg-descr
@@ -1,13 +1,24 @@
-This is an SQL to OO mapper, inspired by the Class::DBI framework, and
-meant to support compability with it, while restructuring the internals
-and making it possible to support some new features like self-joins,
-distinct, group bys and more.
+This is an SQL to OO mapper with an object API inspired by Class::DBI (and a
+compatibility layer as a springboard for porting) and a resultset API that
+allows abstract encapsulation of database operations. It aims to make
+representing queries in your code as perl-ish as possible while still providing
+access to as many of the capabilities of the database as possible, including
+retrieving related records from multiple tables in a single query, JOIN, LEFT
+JOIN, COUNT, DISTINCT, GROUP BY and HAVING support.
-This project is still at an early stage, so the maintainers don't make
-any absolute promise that full backwards-compatibility will be
-supported; however, if we can without compromising the improvements
-we're trying to make, we will, and any non-compatible changes will merit
-a full justification on the mailing list and a CPAN developer release
-for people to test against.
+DBIx::Class can handle multi-column primary and foreign keys, complex queries
+and database-level paging, and does its best to only query the database when it
+actually needs to in order to return something you've directly asked for. If a
+resultset is used as an iterator it only fetches rows off the statement handle
+as requested in order to minimise memory usage. It has auto-increment support
+for SQLite, MySQL, PostgreSQL, Oracle, SQL Server and DB2 and is known to be
+used in production on at least the first four, and is fork- and thread-safe
+out of the box (although your DBD may not be).
+
+This project is still under rapid development, so features added in the latest
+major release may not work 100% yet - check the Changes if you run into
+trouble, and beware of anything explicitly marked EXPERIMENTAL. Failing test
+cases are *always* welcome and point releases are put out rapidly as bugs are
+found and fixed.
WWW: http://search.cpan.org/dist/DBIx-Class/
diff --git a/databases/p5-DBIx-Class/pkg-plist b/databases/p5-DBIx-Class/pkg-plist
index 387256fe284b..ff6d1fdcc3f2 100644
--- a/databases/p5-DBIx-Class/pkg-plist
+++ b/databases/p5-DBIx-Class/pkg-plist
@@ -30,11 +30,12 @@
%%SITE_PERL%%/DBIx/Class/DB.pm
%%SITE_PERL%%/DBIx/Class/InflateColumn.pm
%%SITE_PERL%%/DBIx/Class/Manual.pod
-%%SITE_PERL%%/DBIx/Class/Manual/Troubleshooting.pod
-%%SITE_PERL%%/DBIx/Class/Manual/FAQ.pod
-%%SITE_PERL%%/DBIx/Class/Manual/Intro.pod
-%%SITE_PERL%%/DBIx/Class/Manual/SchemaIntro.pod
+%%SITE_PERL%%/DBIx/Class/Manual/Component.pod
%%SITE_PERL%%/DBIx/Class/Manual/Cookbook.pod
+%%SITE_PERL%%/DBIx/Class/Manual/Example.pod
+%%SITE_PERL%%/DBIx/Class/Manual/Glossary.pod
+%%SITE_PERL%%/DBIx/Class/Manual/Intro.pod
+%%SITE_PERL%%/DBIx/Class/Manual/Troubleshooting.pod
%%SITE_PERL%%/DBIx/Class/PK.pm
%%SITE_PERL%%/DBIx/Class/PK/Auto.pm
%%SITE_PERL%%/DBIx/Class/PK/Auto/DB2.pm
@@ -62,11 +63,26 @@
%%SITE_PERL%%/DBIx/Class/ResultSourceProxy/Table.pm
%%SITE_PERL%%/DBIx/Class/Row.pm
%%SITE_PERL%%/DBIx/Class/Schema.pm
-%%SITE_PERL%%/DBIx/Class/Serialize.pm
+%%SITE_PERL%%/DBIx/Class/Serialize/Storable.pm
+%%SITE_PERL%%/DBIx/Class/Storage.pm
%%SITE_PERL%%/DBIx/Class/Storage/DBI.pm
%%SITE_PERL%%/DBIx/Class/Storage/DBI/Cursor.pm
+%%SITE_PERL%%/DBIx/Class/Storage/DBI/DB2.pm
+%%SITE_PERL%%/DBIx/Class/Storage/DBI/MSSQL.pm
+%%SITE_PERL%%/DBIx/Class/Storage/DBI/Oracle.pm
+%%SITE_PERL%%/DBIx/Class/Storage/DBI/Pg.pm
+%%SITE_PERL%%/DBIx/Class/Storage/DBI/SQLite.pm
+%%SITE_PERL%%/DBIx/Class/Storage/DBI/mysql.pm
%%SITE_PERL%%/DBIx/Class/Test/SQLite.pm
+%%SITE_PERL%%/DBIx/Class/UTF8Columns.pm
%%SITE_PERL%%/DBIx/Class/UUIDColumns.pm
+%%SITE_PERL%%/DBIx/Class/UUIDMaker.pm
+%%SITE_PERL%%/DBIx/Class/UUIDMaker/APR/UUID.pm
+%%SITE_PERL%%/DBIx/Class/UUIDMaker/Data/UUID.pm
+%%SITE_PERL%%/DBIx/Class/UUIDMaker/Data/Uniqid.pm
+%%SITE_PERL%%/DBIx/Class/UUIDMaker/UUID.pm
+%%SITE_PERL%%/DBIx/Class/UUIDMaker/Win32/Guidgen.pm
+%%SITE_PERL%%/DBIx/Class/UUIDMaker/Win32API/GUID.pm
%%SITE_PERL%%/DBIx/Class/Validation.pm
%%SITE_PERL%%/SQL/Translator/Parser/DBIx/Class.pm
%%SITE_PERL%%/SQL/Translator/Producer/DBIx/Class/File.pm
@@ -77,9 +93,15 @@
@dirrmtry %%SITE_PERL%%/SQL/Translator/Parser
@dirrmtry %%SITE_PERL%%/SQL/Translator
@dirrmtry %%SITE_PERL%%/SQL
+@dirrmtry %%SITE_PERL%%/DBIx/Class/UUIDMaker/Win32API
+@dirrmtry %%SITE_PERL%%/DBIx/Class/UUIDMaker/Win32
+@dirrmtry %%SITE_PERL%%/DBIx/Class/UUIDMaker/Data
+@dirrmtry %%SITE_PERL%%/DBIx/Class/UUIDMaker/APR
+@dirrmtry %%SITE_PERL%%/DBIx/Class/UUIDMaker
@dirrmtry %%SITE_PERL%%/DBIx/Class/Test
@dirrmtry %%SITE_PERL%%/DBIx/Class/Storage/DBI
@dirrmtry %%SITE_PERL%%/DBIx/Class/Storage
+@dirrmtry %%SITE_PERL%%/DBIx/Class/Serialize
@dirrmtry %%SITE_PERL%%/DBIx/Class/ResultSourceProxy
@dirrmtry %%SITE_PERL%%/DBIx/Class/ResultSource
@dirrmtry %%SITE_PERL%%/DBIx/Class/Relationship