aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-01 02:36:38 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-01 02:36:38 +0000
commit01f686aad2e21fcc44d04a3d07b74975e56c2aa3 (patch)
tree251f4cec7efc76d4618a03dfa57f0af4eac693f4 /databases
parent168b1e2955088e739a6a5dfc0d6ee1d52c7b4181 (diff)
downloadports-01f686aad2e21fcc44d04a3d07b74975e56c2aa3.tar.gz
ports-01f686aad2e21fcc44d04a3d07b74975e56c2aa3.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/puredb/Makefile28
-rw-r--r--databases/puredb/distinfo1
-rw-r--r--databases/puredb/files/patch-example_read.c12
-rw-r--r--databases/puredb/pkg-descr10
-rw-r--r--databases/puredb/pkg-plist17
6 files changed, 69 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 1e2cc75e79b5..ca76cf9f129b 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -137,6 +137,7 @@
SUBDIR += postgresql7
SUBDIR += postgresql72
SUBDIR += postgresql_autodoc
+ SUBDIR += puredb
SUBDIR += pxtools
SUBDIR += py-MySQL
SUBDIR += py-MySQLdb
diff --git a/databases/puredb/Makefile b/databases/puredb/Makefile
new file mode 100644
index 000000000000..557e320cd471
--- /dev/null
+++ b/databases/puredb/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: puredb
+# Date created: 01 Nov 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= puredb
+PORTVERSION= 2.1
+CATEGORIES= databases
+MASTER_SITES= http://www.pureftpd.org/puredb/
+DISTNAME= pure-db-${PORTVERSION}
+
+MAINTAINER= sergei@kolobov.com
+COMMENT= Set of libraries for creating and reading constant databases
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+DOCS= AUTHORS FORMAT_DESCR NEWS README
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/puredb/distinfo b/databases/puredb/distinfo
new file mode 100644
index 000000000000..da85a2c054e8
--- /dev/null
+++ b/databases/puredb/distinfo
@@ -0,0 +1 @@
+MD5 (pure-db-2.1.tar.gz) = 2fdf5771c169877218b1f83852f8cad4
diff --git a/databases/puredb/files/patch-example_read.c b/databases/puredb/files/patch-example_read.c
new file mode 100644
index 000000000000..ba6d4fe304a8
--- /dev/null
+++ b/databases/puredb/files/patch-example_read.c
@@ -0,0 +1,12 @@
+--- src/example_read.c.orig Fri Nov 1 23:21:19 2002
++++ src/example_read.c Fri Nov 1 23:21:47 2002
+@@ -3,6 +3,9 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#endif
+ #include <puredb_read.h>
+
+ int main(void)
diff --git a/databases/puredb/pkg-descr b/databases/puredb/pkg-descr
new file mode 100644
index 000000000000..b97a306910e3
--- /dev/null
+++ b/databases/puredb/pkg-descr
@@ -0,0 +1,10 @@
+PureDB is a portable and tiny set of libraries for creating and reading
+constant databases. It manages data files that contains text or binary
+key/data pairs of arbitrary sizes. Lookups are very fast (normally only one
+disk access to match a hash value), overhead is low (a database is 1028
+bytes plus only 16 extra bytes per record), multiple concurrent read access
+are supported, and databases can be up to 4 Gb long, and they are portable
+across architectures.
+
+Author: Frank DENIS <j@4u.net>.
+WWW: http://www.pureftpd.org/puredb/
diff --git a/databases/puredb/pkg-plist b/databases/puredb/pkg-plist
new file mode 100644
index 000000000000..51e549d18c39
--- /dev/null
+++ b/databases/puredb/pkg-plist
@@ -0,0 +1,17 @@
+bin/example_read
+bin/example_write
+include/puredb_read.h
+include/puredb_write.h
+lib/libpuredb_read.so.0
+lib/libpuredb_read.so
+lib/libpuredb_read.la
+lib/libpuredb_read.a
+lib/libpuredb_write.so.0
+lib/libpuredb_write.so
+lib/libpuredb_write.la
+lib/libpuredb_write.a
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/FORMAT_DESCR
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%