aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-07 18:42:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-07 18:42:25 +0000
commit336b31c3940aea29270fc9fd9b51d3ba1633729e (patch)
treeab986f61fb6fef3625ba83cee9ea5d304243bfe8 /databases
parentd02465ee5bd1e47c51b942f66a4c99d7dc742601 (diff)
downloadports-336b31c3940aea29270fc9fd9b51d3ba1633729e.tar.gz
ports-336b31c3940aea29270fc9fd9b51d3ba1633729e.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/libgda2/Makefile23
-rw-r--r--databases/libgda2/distinfo2
-rw-r--r--databases/libgda2/files/patch-aa12
-rw-r--r--databases/libgda2/files/patch-configure10
-rw-r--r--databases/libgda2/files/patch-ltmain.sh42
-rw-r--r--databases/libgda2/pkg-plist30
-rw-r--r--databases/libgda3/Makefile23
-rw-r--r--databases/libgda3/distinfo2
-rw-r--r--databases/libgda3/files/patch-aa12
-rw-r--r--databases/libgda3/files/patch-configure10
-rw-r--r--databases/libgda3/files/patch-ltmain.sh42
-rw-r--r--databases/libgda3/pkg-plist30
-rw-r--r--databases/libgnomedb/Makefile6
-rw-r--r--databases/libgnomedb/distinfo2
-rw-r--r--databases/libgnomedb/pkg-plist15
-rw-r--r--databases/mergeant/Makefile6
-rw-r--r--databases/mergeant/distinfo2
-rw-r--r--databases/mergeant/files/patch-configure12
-rw-r--r--databases/mergeant/pkg-plist19
19 files changed, 226 insertions, 74 deletions
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index 3164c06d05b4..a0144e7dacd1 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= libgda2
-PORTVERSION= 0.9.0
+PORTVERSION= 0.10.0
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/0.9
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/0.10
DISTNAME= libgda-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -17,7 +17,7 @@ MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
- glib-2.0.0:${PORTSDIR}/devel/glib20 \
+ glib-2.0.200:${PORTSDIR}/devel/glib20 \
xslt.1:${PORTSDIR}/textproc/libxslt \
popt.0:${PORTSDIR}/devel/popt
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
@@ -29,18 +29,20 @@ USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack gnomehier
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -lgdbm"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gda-config-tool.1
+MAN5= gda-config.5
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
PLIST_SUB= MYSQL=""
.else
+CONFIGURE_ARGS+= --without-mysql
PLIST_SUB= MYSQL="@comment "
.endif
@@ -50,9 +52,19 @@ LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= POSTGRES=""
.else
+CONFIGURE_ARGS+= --without-postgres
PLIST_SUB+= POSTGRES="@comment "
.endif
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}
+PLIST_SUB+= LDAP=""
+.else
+CONFIGURE_ARGS+= --without-ldap
+PLIST_SUB+= LDAP="@comment "
+.endif
+
pre-extract:
.if !defined(WITH_MYSQL)
@${ECHO_MSG} "You can enable support for MySQL databases by defining WITH_MYSQL."
@@ -60,6 +72,9 @@ pre-extract:
.if !defined(WITH_POSTGRES)
@${ECHO_MSG} "You can enable support for Postgres databases by defining WITH_POSTGRES."
.endif
+.if !defined(WITH_LDAP)
+ @${ECHO_MSG} "You can enable support for LDAP databases by defining WITH_LDAP."
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/databases/libgda2/distinfo b/databases/libgda2/distinfo
index 333320e20848..94e335653dde 100644
--- a/databases/libgda2/distinfo
+++ b/databases/libgda2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libgda-0.9.0.tar.bz2) = 2d6599ba594b359a286f8f05c791b702
+MD5 (gnome2/libgda-0.10.0.tar.bz2) = 7d8ab6091d7a90e4b92fe6d123e6ae88
diff --git a/databases/libgda2/files/patch-aa b/databases/libgda2/files/patch-aa
index 94f70db4275c..a090fe088157 100644
--- a/databases/libgda2/files/patch-aa
+++ b/databases/libgda2/files/patch-aa
@@ -1,11 +1,11 @@
---- Makefile.in.orig Fri Jul 26 16:09:57 2002
-+++ Makefile.in Fri Jul 26 16:10:46 2002
-@@ -155,7 +155,7 @@
+--- Makefile.in.orig Thu Feb 6 23:01:24 2003
++++ Makefile.in Thu Feb 6 23:01:54 2003
+@@ -164,7 +164,7 @@
YACC = @YACC@
cxxflags_set = @cxxflags_set@
--SUBDIRS = po idl libsql libgda providers report tools testing data doc
-+SUBDIRS = po idl libsql libgda providers report tools data doc
+-SUBDIRS = po libsql libgda providers report tools testing data doc
++SUBDIRS = po libsql libgda providers report tools data doc
- EXTRA_DIST = COPYING libgda.spec.in libgda.pc.in intltool-extract.in intltool-merge.in intltool-update.in
+ EXTRA_DIST = COPYING libgda.spec intltool-extract.in intltool-merge.in intltool-update.in
diff --git a/databases/libgda2/files/patch-configure b/databases/libgda2/files/patch-configure
deleted file mode 100644
index d744b24f81e8..000000000000
--- a/databases/libgda2/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sun Jun 2 22:12:29 2002
-+++ configure Sun Jun 2 22:13:06 2002
-@@ -8429,6 +8429,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/databases/libgda2/files/patch-ltmain.sh b/databases/libgda2/files/patch-ltmain.sh
new file mode 100644
index 000000000000..1c2fba5d533f
--- /dev/null
+++ b/databases/libgda2/files/patch-ltmain.sh
@@ -0,0 +1,42 @@
+--- ltmain.sh.orig Fri Sep 13 15:38:11 2002
++++ ltmain.sh Fri Oct 11 01:44:24 2002
+@@ -1073,8 +1073,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2502,6 +2510,9 @@
+ *-*-openbsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4286,10 +4297,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/databases/libgda2/pkg-plist b/databases/libgda2/pkg-plist
index 863d4591116f..8882e5c2312a 100644
--- a/databases/libgda2/pkg-plist
+++ b/databases/libgda2/pkg-plist
@@ -1,8 +1,20 @@
bin/gda-config-tool
+bin/gda-report-test
bin/gda-run
etc/libgda/config
include/libgda-report/gda-report-document.h
+include/libgda-report/gda-report-item-detail.h
+include/libgda-report/gda-report-item-label.h
+include/libgda-report/gda-report-item-pagefooter.h
+include/libgda-report/gda-report-item-pageheader.h
+include/libgda-report/gda-report-item-repfield.h
+include/libgda-report/gda-report-item-report.h
+include/libgda-report/gda-report-item-reportfooter.h
+include/libgda-report/gda-report-item-reportheader.h
+include/libgda-report/gda-report-item-sqlquery.h
+include/libgda-report/gda-report-item.h
include/libgda-report/gda-report-types.h
+include/libgda-report/gda-report-valid.h
include/libgda-report/gda-report.h
include/libgda/gda-client.h
include/libgda/gda-command.h
@@ -61,10 +73,14 @@ lib/libgdasql.a
lib/libgdasql.so
lib/libgdasql.so.0
lib/libgda/providers/libgda-default.so
+%%LDAP%%lib/libgda/providers/libgda-ldap.so
%%MYSQL%%lib/libgda/providers/libgda-mysql.so
%%POSTGRES%%lib/libgda/providers/libgda-postgres.so
libdata/pkgconfig/libgda.pc
share/doc/libgda/architecture.html
+share/doc/libgda/c680.html
+share/doc/libgda/c685.html
+share/doc/libgda/c687.html
share/doc/libgda/c689.html
share/doc/libgda/compiling.html
share/doc/libgda/connecting.html
@@ -150,11 +166,18 @@ share/doc/libgda/migration-configuration.html
share/doc/libgda/migration-executing-commands.html
share/doc/libgda/migration.html
share/doc/libgda/processing-queries.html
+share/doc/libgda/x849.html
+share/doc/libgda/x851.html
share/doc/libgda/x853.html
+share/doc/libgda/x878.html
+share/doc/libgda/x880.html
share/doc/libgda/x882.html
+share/doc/libgda/x883.html
+share/doc/libgda/x885.html
share/doc/libgda/x887.html
-share/gnome/idl/libgda/GNOME_Database.idl
-share/gnome/libgda/dtd/gda-report.dtd
+share/gnome/libgda/xml/gda-report.dtd
+share/gnome/libgda/xml/gda-xml-query.dtd
+share/gnome/libgda/xml/gda-xml-query.xsl
share/gnome/omf/libgda/libgda-C.omf
share/locale/az/LC_MESSAGES/libgda-2.mo
share/locale/ca/LC_MESSAGES/libgda-2.mo
@@ -186,9 +209,8 @@ share/locale/uk/LC_MESSAGES/libgda-2.mo
share/locale/vi/LC_MESSAGES/libgda-2.mo
share/locale/zh_CN/LC_MESSAGES/libgda-2.mo
@dirrm share/gnome/omf/libgda
-@dirrm share/gnome/libgda/dtd
+@dirrm share/gnome/libgda/xml
@dirrm share/gnome/libgda
-@dirrm share/gnome/idl/libgda
@dirrm lib/libgda/providers
@dirrm lib/libgda
@dirrm include/libgda/sql
diff --git a/databases/libgda3/Makefile b/databases/libgda3/Makefile
index 3164c06d05b4..a0144e7dacd1 100644
--- a/databases/libgda3/Makefile
+++ b/databases/libgda3/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= libgda2
-PORTVERSION= 0.9.0
+PORTVERSION= 0.10.0
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/0.9
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/0.10
DISTNAME= libgda-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -17,7 +17,7 @@ MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
- glib-2.0.0:${PORTSDIR}/devel/glib20 \
+ glib-2.0.200:${PORTSDIR}/devel/glib20 \
xslt.1:${PORTSDIR}/textproc/libxslt \
popt.0:${PORTSDIR}/devel/popt
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
@@ -29,18 +29,20 @@ USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack gnomehier
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -lgdbm"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gda-config-tool.1
+MAN5= gda-config.5
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
PLIST_SUB= MYSQL=""
.else
+CONFIGURE_ARGS+= --without-mysql
PLIST_SUB= MYSQL="@comment "
.endif
@@ -50,9 +52,19 @@ LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= POSTGRES=""
.else
+CONFIGURE_ARGS+= --without-postgres
PLIST_SUB+= POSTGRES="@comment "
.endif
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}
+PLIST_SUB+= LDAP=""
+.else
+CONFIGURE_ARGS+= --without-ldap
+PLIST_SUB+= LDAP="@comment "
+.endif
+
pre-extract:
.if !defined(WITH_MYSQL)
@${ECHO_MSG} "You can enable support for MySQL databases by defining WITH_MYSQL."
@@ -60,6 +72,9 @@ pre-extract:
.if !defined(WITH_POSTGRES)
@${ECHO_MSG} "You can enable support for Postgres databases by defining WITH_POSTGRES."
.endif
+.if !defined(WITH_LDAP)
+ @${ECHO_MSG} "You can enable support for LDAP databases by defining WITH_LDAP."
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/databases/libgda3/distinfo b/databases/libgda3/distinfo
index 333320e20848..94e335653dde 100644
--- a/databases/libgda3/distinfo
+++ b/databases/libgda3/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libgda-0.9.0.tar.bz2) = 2d6599ba594b359a286f8f05c791b702
+MD5 (gnome2/libgda-0.10.0.tar.bz2) = 7d8ab6091d7a90e4b92fe6d123e6ae88
diff --git a/databases/libgda3/files/patch-aa b/databases/libgda3/files/patch-aa
index 94f70db4275c..a090fe088157 100644
--- a/databases/libgda3/files/patch-aa
+++ b/databases/libgda3/files/patch-aa
@@ -1,11 +1,11 @@
---- Makefile.in.orig Fri Jul 26 16:09:57 2002
-+++ Makefile.in Fri Jul 26 16:10:46 2002
-@@ -155,7 +155,7 @@
+--- Makefile.in.orig Thu Feb 6 23:01:24 2003
++++ Makefile.in Thu Feb 6 23:01:54 2003
+@@ -164,7 +164,7 @@
YACC = @YACC@
cxxflags_set = @cxxflags_set@
--SUBDIRS = po idl libsql libgda providers report tools testing data doc
-+SUBDIRS = po idl libsql libgda providers report tools data doc
+-SUBDIRS = po libsql libgda providers report tools testing data doc
++SUBDIRS = po libsql libgda providers report tools data doc
- EXTRA_DIST = COPYING libgda.spec.in libgda.pc.in intltool-extract.in intltool-merge.in intltool-update.in
+ EXTRA_DIST = COPYING libgda.spec intltool-extract.in intltool-merge.in intltool-update.in
diff --git a/databases/libgda3/files/patch-configure b/databases/libgda3/files/patch-configure
deleted file mode 100644
index d744b24f81e8..000000000000
--- a/databases/libgda3/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sun Jun 2 22:12:29 2002
-+++ configure Sun Jun 2 22:13:06 2002
-@@ -8429,6 +8429,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/databases/libgda3/files/patch-ltmain.sh b/databases/libgda3/files/patch-ltmain.sh
new file mode 100644
index 000000000000..1c2fba5d533f
--- /dev/null
+++ b/databases/libgda3/files/patch-ltmain.sh
@@ -0,0 +1,42 @@
+--- ltmain.sh.orig Fri Sep 13 15:38:11 2002
++++ ltmain.sh Fri Oct 11 01:44:24 2002
+@@ -1073,8 +1073,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2502,6 +2510,9 @@
+ *-*-openbsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4286,10 +4297,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/databases/libgda3/pkg-plist b/databases/libgda3/pkg-plist
index 863d4591116f..8882e5c2312a 100644
--- a/databases/libgda3/pkg-plist
+++ b/databases/libgda3/pkg-plist
@@ -1,8 +1,20 @@
bin/gda-config-tool
+bin/gda-report-test
bin/gda-run
etc/libgda/config
include/libgda-report/gda-report-document.h
+include/libgda-report/gda-report-item-detail.h
+include/libgda-report/gda-report-item-label.h
+include/libgda-report/gda-report-item-pagefooter.h
+include/libgda-report/gda-report-item-pageheader.h
+include/libgda-report/gda-report-item-repfield.h
+include/libgda-report/gda-report-item-report.h
+include/libgda-report/gda-report-item-reportfooter.h
+include/libgda-report/gda-report-item-reportheader.h
+include/libgda-report/gda-report-item-sqlquery.h
+include/libgda-report/gda-report-item.h
include/libgda-report/gda-report-types.h
+include/libgda-report/gda-report-valid.h
include/libgda-report/gda-report.h
include/libgda/gda-client.h
include/libgda/gda-command.h
@@ -61,10 +73,14 @@ lib/libgdasql.a
lib/libgdasql.so
lib/libgdasql.so.0
lib/libgda/providers/libgda-default.so
+%%LDAP%%lib/libgda/providers/libgda-ldap.so
%%MYSQL%%lib/libgda/providers/libgda-mysql.so
%%POSTGRES%%lib/libgda/providers/libgda-postgres.so
libdata/pkgconfig/libgda.pc
share/doc/libgda/architecture.html
+share/doc/libgda/c680.html
+share/doc/libgda/c685.html
+share/doc/libgda/c687.html
share/doc/libgda/c689.html
share/doc/libgda/compiling.html
share/doc/libgda/connecting.html
@@ -150,11 +166,18 @@ share/doc/libgda/migration-configuration.html
share/doc/libgda/migration-executing-commands.html
share/doc/libgda/migration.html
share/doc/libgda/processing-queries.html
+share/doc/libgda/x849.html
+share/doc/libgda/x851.html
share/doc/libgda/x853.html
+share/doc/libgda/x878.html
+share/doc/libgda/x880.html
share/doc/libgda/x882.html
+share/doc/libgda/x883.html
+share/doc/libgda/x885.html
share/doc/libgda/x887.html
-share/gnome/idl/libgda/GNOME_Database.idl
-share/gnome/libgda/dtd/gda-report.dtd
+share/gnome/libgda/xml/gda-report.dtd
+share/gnome/libgda/xml/gda-xml-query.dtd
+share/gnome/libgda/xml/gda-xml-query.xsl
share/gnome/omf/libgda/libgda-C.omf
share/locale/az/LC_MESSAGES/libgda-2.mo
share/locale/ca/LC_MESSAGES/libgda-2.mo
@@ -186,9 +209,8 @@ share/locale/uk/LC_MESSAGES/libgda-2.mo
share/locale/vi/LC_MESSAGES/libgda-2.mo
share/locale/zh_CN/LC_MESSAGES/libgda-2.mo
@dirrm share/gnome/omf/libgda
-@dirrm share/gnome/libgda/dtd
+@dirrm share/gnome/libgda/xml
@dirrm share/gnome/libgda
-@dirrm share/gnome/idl/libgda
@dirrm lib/libgda/providers
@dirrm lib/libgda
@dirrm include/libgda/sql
diff --git a/databases/libgnomedb/Makefile b/databases/libgnomedb/Makefile
index 4f1988b55c97..e3fab7b08545 100644
--- a/databases/libgnomedb/Makefile
+++ b/databases/libgnomedb/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= libgnomedb
-PORTVERSION= 0.9.0
+PORTVERSION= 0.10.0
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/libgnomedb/0.9
+MASTER_SITE_SUBDIR= sources/libgnomedb/0.10
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui \
+LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui \
gda-2.1:${PORTSDIR}/databases/libgda2
USE_BZIP2= yes
diff --git a/databases/libgnomedb/distinfo b/databases/libgnomedb/distinfo
index 3f2c29df78cc..25a2e6ac8202 100644
--- a/databases/libgnomedb/distinfo
+++ b/databases/libgnomedb/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libgnomedb-0.9.0.tar.bz2) = 1bd321a1c15a0922c9efc87742e9c081
+MD5 (gnome2/libgnomedb-0.10.0.tar.bz2) = edbc2fdc604694f8bd43b479f8805b91
diff --git a/databases/libgnomedb/pkg-plist b/databases/libgnomedb/pkg-plist
index fb7467eb6bc5..2885fd5a4a79 100644
--- a/databases/libgnomedb/pkg-plist
+++ b/databases/libgnomedb/pkg-plist
@@ -1,9 +1,9 @@
bin/gnome-database-properties
etc/gconf/gconf.xml.defaults/apps/gnome-db/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/gnome-db/Shell/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnome-db/Editor/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/gnome-db/UI/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gnome-db/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/gnome-db/Shell/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnome-db/Editor/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gnome-db/UI/%gconf.xml
etc/gconf/schemas/libgnomedb.schemas
etc/gnome-vfs-2.0/modules/database-module.conf
@@ -17,18 +17,19 @@ include/libgnomedb/gnome-db-control.h
include/libgnomedb/gnome-db-data-source-selector.h
include/libgnomedb/gnome-db-dsn-config-druid.h
include/libgnomedb/gnome-db-dsn-config.h
+include/libgnomedb/gnome-db-editor.h
include/libgnomedb/gnome-db-error-dialog.h
include/libgnomedb/gnome-db-error.h
include/libgnomedb/gnome-db-form.h
include/libgnomedb/gnome-db-gray-bar.h
include/libgnomedb/gnome-db-grid.h
+include/libgnomedb/gnome-db-icon-list.h
include/libgnomedb/gnome-db-list.h
include/libgnomedb/gnome-db-login-dialog.h
include/libgnomedb/gnome-db-login.h
include/libgnomedb/gnome-db-model.h
include/libgnomedb/gnome-db-provider-selector.h
include/libgnomedb/gnome-db-report-editor.h
-include/libgnomedb/gnome-db-sql-editor.h
include/libgnomedb/gnome-db-stock.h
include/libgnomedb/gnome-db-table-editor.h
include/libgnomedb/gnome-db-util.h
@@ -73,11 +74,13 @@ share/doc/libgnomedb/libgnomedb-gnomedbcontrolwidget.html
share/doc/libgnomedb/libgnomedb-gnomedbdatasourceselector.html
share/doc/libgnomedb/libgnomedb-gnomedbdsnconfig.html
share/doc/libgnomedb/libgnomedb-gnomedbdsnconfigdruid.html
+share/doc/libgnomedb/libgnomedb-gnomedbeditor.html
share/doc/libgnomedb/libgnomedb-gnomedberror.html
share/doc/libgnomedb/libgnomedb-gnomedberrordialog.html
share/doc/libgnomedb/libgnomedb-gnomedbform.html
share/doc/libgnomedb/libgnomedb-gnomedbgraybar.html
share/doc/libgnomedb/libgnomedb-gnomedbgrid.html
+share/doc/libgnomedb/libgnomedb-gnomedbiconlist.html
share/doc/libgnomedb/libgnomedb-gnomedblist.html
share/doc/libgnomedb/libgnomedb-gnomedblogin.html
share/doc/libgnomedb/libgnomedb-gnomedblogindialog.html
@@ -101,6 +104,7 @@ share/gnome/pixmaps/libgnomedb/gnome-db-database_24x24.png
share/gnome/pixmaps/libgnomedb/gnome-db-designer_24x24.png
share/gnome/pixmaps/libgnomedb/gnome-db-disconnect_24x24.png
share/gnome/pixmaps/libgnomedb/gnome-db-indexes_16x16.png
+share/gnome/pixmaps/libgnomedb/gnome-db-no-transaction_24x24.png
share/gnome/pixmaps/libgnomedb/gnome-db-procedures_16x16.png
share/gnome/pixmaps/libgnomedb/gnome-db-procedures_24x24.png
share/gnome/pixmaps/libgnomedb/gnome-db-query_16x16.png
@@ -116,6 +120,7 @@ share/gnome/pixmaps/libgnomedb/gnome-db-triggers_16x16.png
share/gnome/pixmaps/libgnomedb/gnome-db-types_16x16.png
share/gnome/pixmaps/libgnomedb/gnome-db-types_24x24.png
share/gnome/pixmaps/libgnomedb/gnome-db-views_16x16.png
+share/gnome/pixmaps/libgnomedb/gnome-db-within-transaction_24x24.png
share/gnome/pixmaps/libgnomedb/gnome-db.png
share/locale/az/LC_MESSAGES/libgnomedb-2.mo
share/locale/be/LC_MESSAGES/libgnomedb-2.mo
@@ -154,8 +159,8 @@ share/locale/zh_TW/LC_MESSAGES/libgnomedb-2.mo
@dirrm share/doc/libgnomedb
@dirrm include/libgnomedb
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-db/UI
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-db/Shell
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-db/Editor
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnome-db
@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-db/UI
-@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-db/Shell
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-db/Editor
@dirrm etc/gconf/gconf.xml.defaults/apps/gnome-db
diff --git a/databases/mergeant/Makefile b/databases/mergeant/Makefile
index eb188df43d13..ac31ed4041af 100644
--- a/databases/mergeant/Makefile
+++ b/databases/mergeant/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= mergeant
-PORTVERSION= 0.9.0
+PORTVERSION= 0.10.0
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.9
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.10
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= gnomedb-2.1:${PORTSDIR}/databases/libgnomedb \
- gnomeprintui-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui
+ gnomeprintui-2-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui
USE_BZIP2= yes
USE_X_PREFIX= yes
diff --git a/databases/mergeant/distinfo b/databases/mergeant/distinfo
index dd339327b3d9..f65e8c1f64af 100644
--- a/databases/mergeant/distinfo
+++ b/databases/mergeant/distinfo
@@ -1 +1 @@
-MD5 (gnome2/mergeant-0.9.0.tar.bz2) = 4f821d296ac4d53ca7111242b70455ab
+MD5 (gnome2/mergeant-0.10.0.tar.bz2) = 2e8b98332288d07a5e1cbdfd0a828f2f
diff --git a/databases/mergeant/files/patch-configure b/databases/mergeant/files/patch-configure
index d718517b75ab..522cb695567f 100644
--- a/databases/mergeant/files/patch-configure
+++ b/databases/mergeant/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Sep 9 17:46:33 2002
-+++ configure Sun Sep 15 02:43:36 2002
-@@ -7596,6 +7596,7 @@
+--- configure.orig Mon Jan 27 20:50:17 2003
++++ configure Fri Feb 7 01:02:04 2003
+@@ -7948,6 +7948,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,7 +8,7 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -10065,13 +10066,13 @@
+@@ -9405,13 +9406,13 @@
MERGEANT_Pixmapdir=${datadir}/pixmaps/${PACKAGE}
@@ -19,8 +19,8 @@
MERGEANT_Plugdir=${datadir}/${PACKAGE}/plugins
--MERGEANT_Helpdir=${datadir}/doc/${PACKAGE}
-+MERGEANT_Helpdir=${prefix}/share/doc/${PACKAGE}
+-MERGEANT_Helpdir=${datadir}/gnome/help/${PACKAGE}
++MERGEANT_Helpdir=${datadir}/help/${PACKAGE}
diff --git a/databases/mergeant/pkg-plist b/databases/mergeant/pkg-plist
index ac52b84072cd..dea19a0e9515 100644
--- a/databases/mergeant/pkg-plist
+++ b/databases/mergeant/pkg-plist
@@ -1,12 +1,16 @@
bin/mergeant
-share/doc/mergeant/C/topic.dat
+share/gnome/application-registry/mergeant.applications
share/gnome/applications/mergeant.desktop
+share/gnome/help/mergeant/C/topic.dat
share/gnome/mergeant/dtd/mergeant.dtd
share/gnome/mergeant/plugins/libPnetaddr.so
share/gnome/mergeant/plugins/libPpicts.so
share/gnome/mergeant/plugins/libPsample.so
+share/gnome/mime-info/mergeant.keys
+share/gnome/mime-info/mergeant.mime
share/gnome/omf/mergeant/mergeant-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/mergeant/mergeant-C.omf 2>/dev/null || /usr/bin/true
+share/gnome/pixmaps/document-icons/gnome-application-x-mergeant.png
share/gnome/pixmaps/mergeant/mergeant.png
share/gnome/pixmaps/mergeant/mergeant_connect.png
share/gnome/pixmaps/mergeant/mergeant_connect_small.png
@@ -19,6 +23,9 @@ share/gnome/pixmaps/mergeant/mergeant_rels.png
share/gnome/pixmaps/mergeant/mergeant_rels_small.png
share/gnome/pixmaps/mergeant/mergeant_sequences.png
share/gnome/pixmaps/mergeant/mergeant_tables.png
+share/gnome/pixmaps/mergeant/query-view-query_16x16.png
+share/gnome/pixmaps/mergeant/query-view-table_16x16.png
+share/gnome/pixmaps/mergeant/query-view-view_16x16.png
share/locale/cs/LC_MESSAGES/mergeant.mo
share/locale/da/LC_MESSAGES/mergeant.mo
share/locale/de/LC_MESSAGES/mergeant.mo
@@ -26,6 +33,8 @@ share/locale/es/LC_MESSAGES/mergeant.mo
share/locale/fr/LC_MESSAGES/mergeant.mo
share/locale/it/LC_MESSAGES/mergeant.mo
share/locale/ms/LC_MESSAGES/mergeant.mo
+share/locale/nl/LC_MESSAGES/mergeant.mo
+share/locale/no/LC_MESSAGES/mergeant.mo
share/locale/pl/LC_MESSAGES/mergeant.mo
share/locale/pt_BR/LC_MESSAGES/mergeant.mo
share/locale/ru/LC_MESSAGES/mergeant.mo
@@ -38,8 +47,8 @@ share/locale/vi/LC_MESSAGES/mergeant.mo
@dirrm share/gnome/mergeant/plugins
@dirrm share/gnome/mergeant/dtd
@dirrm share/gnome/mergeant
-@dirrm share/doc/mergeant/C/stylesheet-images
-@dirrm share/doc/mergeant/C/images
-@dirrm share/doc/mergeant/C
-@dirrm share/doc/mergeant
+@dirrm share/gnome/help/mergeant/C/stylesheet-images
+@dirrm share/gnome/help/mergeant/C/images
+@dirrm share/gnome/help/mergeant/C
+@dirrm share/gnome/help/mergeant
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/mergeant/mergeant-C.omf 2>/dev/null || /usr/bin/true