aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-29 04:42:14 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-29 04:42:14 +0000
commit33fee01efa87a74858fd46a623136f1400cdef21 (patch)
tree0156222f9fc6839586790e11b6ce8ef53f6dba55 /databases
parent1a2fa5b4c2d60ff5bdf4f2853fa190d8ef6fe6d7 (diff)
downloadports-33fee01efa87a74858fd46a623136f1400cdef21.tar.gz
ports-33fee01efa87a74858fd46a623136f1400cdef21.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/sqsh/Makefile24
-rw-r--r--databases/sqsh/distinfo1
-rw-r--r--databases/sqsh/files/patch-aa20
-rw-r--r--databases/sqsh/files/patch-ab32
-rw-r--r--databases/sqsh/files/patch-ac8
-rw-r--r--databases/sqsh/pkg-comment1
-rw-r--r--databases/sqsh/pkg-descr2
-rw-r--r--databases/sqsh/pkg-plist1
9 files changed, 90 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index fcf7ad3bb78d..f76757b883eb 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -31,6 +31,7 @@
SUBDIR += py-MySQL
SUBDIR += py-PyGreSQL
SUBDIR += ruby-postgres
+ SUBDIR += sqsh
SUBDIR += tcl-Mysql
SUBDIR += tkgnats
SUBDIR += typhoon
diff --git a/databases/sqsh/Makefile b/databases/sqsh/Makefile
new file mode 100644
index 000000000000..0aecd6af1df1
--- /dev/null
+++ b/databases/sqsh/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sqsh
+# Version required: 1.7
+# Date created: 14 Jan 2000
+# Whom: Domas Mituzas <midom@dammit.lt>
+#
+# $FreeBSD$
+
+DISTNAME= sqsh-1.7
+CATEGORIES= databases
+MASTER_SITES= http://www.voicenet.com/~gray/
+EXTRACT_SUFX= -src.tar.gz
+
+MAINTAINER= midom@dammit.lt
+
+LIB_DEPENDS= tds.0:${PORTSDIR}/databases/freetds
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash1
+
+FETCH_BEFORE_ARGS= -b
+
+GNU_CONFIGURE= yes
+
+MAN1= sqsh.1
+
+.include <bsd.port.mk>
diff --git a/databases/sqsh/distinfo b/databases/sqsh/distinfo
new file mode 100644
index 000000000000..8ea134232674
--- /dev/null
+++ b/databases/sqsh/distinfo
@@ -0,0 +1 @@
+MD5 (sqsh-1.7-src.tar.gz) = dfdb8eda026ff1fedbbf64d8c173705a
diff --git a/databases/sqsh/files/patch-aa b/databases/sqsh/files/patch-aa
new file mode 100644
index 000000000000..dbb4835a32ee
--- /dev/null
+++ b/databases/sqsh/files/patch-aa
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Wed Jan 6 04:38:41 1999
++++ Makefile.in Fri Jan 14 14:44:07 2000
+@@ -190,6 +190,8 @@
+ $(TARGET) : $(OBJS) sqsh_main.o
+ $(CC) $(LDFLAGS) $(OBJS) sqsh_main.o $(LIBS) -o $@
+
++all : $(TARGET)
++
+ sqsh_test : $(OBJS) sqsh_test.o
+ $(CC) $(LDFLAGS) $(OBJS) sqsh_test.o $(LIBS) -o $@
+
+@@ -206,7 +208,7 @@
+ distclean : realclean
+ rm -f configure Makefile config.h
+
+-install : $(TARGET)
++install : $(TARGET) install.man
+ $(INSTALL_DIR) $(bin_dir)
+ $(INSTALL_PROG) $(TARGET) $(bin_dir)/$(TARGET)
+
diff --git a/databases/sqsh/files/patch-ab b/databases/sqsh/files/patch-ab
new file mode 100644
index 000000000000..9ba0af2d057f
--- /dev/null
+++ b/databases/sqsh/files/patch-ab
@@ -0,0 +1,32 @@
+--- configure.orig Fri Jan 14 14:09:13 2000
++++ configure Fri Jan 14 14:13:12 2000
+@@ -1047,7 +1047,10 @@
+
+ #
+ # Is $SYBASE defined?
+-#
++# -- it should have some defaults...
++
++SYBASE=/usr/local/
++
+ echo $ac_n "checking Open Client installation""... $ac_c" 1>&6
+ echo "configure:1053: checking Open Client installation" >&5
+
+@@ -1095,7 +1098,7 @@
+ # The basic client libraries that are always needed
+ # on all platforms.
+ #
+- SYBASE_LIBS="-lblk -lcs -lct -lcomn -ltcl -lintl"
++ SYBASE_LIBS="-lct -lintl"
+
+ MAJOR_VERSION=`echo $SYBASE_VERSION | cut -d '.' -f 1`
+
+@@ -1128,6 +1131,8 @@
+ case "${host_os}" in
+ linux*)
+ SYBASE_OS="-ldl -lm";;
++ freebsd*)
++ SYBASE_OS="-lm";;
+ irix*)
+ SYBASE_OS="-lnsl -lm";;
+ ncr*)
diff --git a/databases/sqsh/files/patch-ac b/databases/sqsh/files/patch-ac
new file mode 100644
index 000000000000..69c63e24d31d
--- /dev/null
+++ b/databases/sqsh/files/patch-ac
@@ -0,0 +1,8 @@
+--- autoconf/install-man.orig Fri Jan 14 21:19:45 2000
++++ autoconf/install-man Fri Jan 14 21:20:00 2000
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/usr/local/bin/bash
+ #
+ # install-man -- install or uninstall compressed or uncompressed man pages.
+ #
diff --git a/databases/sqsh/pkg-comment b/databases/sqsh/pkg-comment
new file mode 100644
index 000000000000..2bda6aff4a54
--- /dev/null
+++ b/databases/sqsh/pkg-comment
@@ -0,0 +1 @@
+Interactive tool for querying Sybase database servers
diff --git a/databases/sqsh/pkg-descr b/databases/sqsh/pkg-descr
new file mode 100644
index 000000000000..a44891d9315f
--- /dev/null
+++ b/databases/sqsh/pkg-descr
@@ -0,0 +1,2 @@
+This is alternative to ancient isql - interactive
+and comfortable database query tool for Sybase.
diff --git a/databases/sqsh/pkg-plist b/databases/sqsh/pkg-plist
new file mode 100644
index 000000000000..1899f9428f2d
--- /dev/null
+++ b/databases/sqsh/pkg-plist
@@ -0,0 +1 @@
+bin/sqsh