aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /databases
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/evolution-data-server/Makefile14
-rw-r--r--databases/evolution-data-server/distinfo6
-rw-r--r--databases/evolution-data-server/files/patch-configure43
-rw-r--r--databases/evolution-data-server/files/patch-docs_reference_camel_Makefile.in21
-rw-r--r--databases/evolution-data-server/pkg-plist19
-rw-r--r--databases/glom/Makefile9
-rw-r--r--databases/glom/distinfo6
-rw-r--r--databases/glom/pkg-plist132
-rw-r--r--databases/libgdamm/Makefile11
-rw-r--r--databases/libgdamm/distinfo6
-rw-r--r--databases/libgdamm/pkg-plist7
-rw-r--r--databases/mysql-gui-tools/Makefile8
-rw-r--r--databases/mysql-gui-tools/files/patch-query-browser-configure.in21
13 files changed, 151 insertions, 152 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 58a2d25f99c9..2adf3caedf0d 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/databases/evolution-data-server/Makefile,v 1.5 2009/04/15 23:04:33 kwm Exp $
+# $MCom: ports/databases/evolution-data-server/Makefile,v 1.181 2009/10/18 04:17:46 marcus Exp $
#
PORTNAME= evolution-data-server
-PORTVERSION= 2.26.3
-PORTREVISION= 1
+PORTVERSION= 2.28.1
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -27,8 +26,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= build
USE_GETTEXT= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui ltverhack \
- ltasneededhack
+USE_GNOME= gnomeprefix gnomehack intlhack ltverhack ltasneededhack \
+ libglade2 libbonobo
USE_OPENLDAP= yes
USE_AUTOTOOLS= libtool:22
USE_BDB= 41+
@@ -41,7 +40,7 @@ CONFIGURE_ARGS= --enable-static \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${BDB_INCLUDE_DIR} ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-PLIST_SUB= VERSION="2.26" EVO_VERSION="1.2"
+PLIST_SUB= VERSION="2.28" EVO_VERSION="1.2"
#OPTIONS= IMAP4 "Enable experimental IMAP4 backend" off
OPTIONS= WEATHER "Enable weather calendar backend" on
@@ -82,7 +81,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g ; \
- s|heimlibs=".*"|heimlibs="${KRB5_LIB}"|g' \
+ s|heimlibs=".*"|heimlibs="${KRB5_LIB}"|g ; \
+ s|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/databases/evolution-data-server/distinfo b/databases/evolution-data-server/distinfo
index a5f1370abf2e..0d7cab157173 100644
--- a/databases/evolution-data-server/distinfo
+++ b/databases/evolution-data-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/evolution-data-server-2.26.3.tar.bz2) = 01205605a598253bc227ff360c7c3dad
-SHA256 (gnome2/evolution-data-server-2.26.3.tar.bz2) = ed2698d64dc663900b50f7a461d79c25e310462b7d41b1073257cbf950e75071
-SIZE (gnome2/evolution-data-server-2.26.3.tar.bz2) = 7167764
+MD5 (gnome2/evolution-data-server-2.28.1.tar.bz2) = ea516bef48900020c4f137514123e34d
+SHA256 (gnome2/evolution-data-server-2.28.1.tar.bz2) = 651de21c10765d4b6503ff59aa50c8b9e1bc704d94341d9a275e3b50d68dae8a
+SIZE (gnome2/evolution-data-server-2.28.1.tar.bz2) = 22309681
diff --git a/databases/evolution-data-server/files/patch-configure b/databases/evolution-data-server/files/patch-configure
index 3fac0e9046c9..65af28acc7b9 100644
--- a/databases/evolution-data-server/files/patch-configure
+++ b/databases/evolution-data-server/files/patch-configure
@@ -1,30 +1,21 @@
---- configure.orig Mon Jun 18 23:55:48 2007
-+++ configure Mon Jun 18 23:56:20 2007
-@@ -24562,6 +24562,14 @@ case "$host" in
- # AC_CACHE_VAL(have_addrinfo, [have_addrinfo=yes])
- # AC_DEFINE(_WIN32_WINNT, 0x501, [To get getaddrinfo etc declarations])
- ;;
-+*freebsd*)
-+ os_win32=no
-+ NO_UNDEFINED=''
-+ SOCKET_LIBS=''
-+ DL_LIB=''
-+ SOFTOKN3_LIB='-lsoftokn3'
-+ LIBEXECDIR_IN_SERVER_FILE="$libexecdir"
-+ ;;
- *) os_win32=no
- NO_UNDEFINED=''
- SOCKET_LIBS=''
-@@ -28651,7 +28659,7 @@ cat >>conftest.$ac_ext <<_ACEOF
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <netdb.h>
--
-+ #include <stdio.h>
+--- configure.orig 2009-08-24 10:39:07.000000000 +0200
++++ configure 2009-08-24 10:44:47.000000000 +0200
+@@ -15988,6 +15988,14 @@ cat >>confdefs.h <<\_ACEOF
+ _ACEOF
- int
- main ()
-@@ -33825,7 +33833,7 @@ idldir='${datadir}'/idl/evolution-data-s
+ ;;
++*freebsd*)
++ os_win32=no
++ NO_UNDEFINED=''
++ SOCKET_LIBS=''
++ DL_LIB=''
++ SOFTOKN3_LIB='-lsoftokn3'
++ LIBEXECDIR_IN_SERVER_FILE="$libexecdir"
++ ;;
+ *)
+ os_win32=no
+ NO_UNDEFINED=''
+@@ -24777,7 +24785,7 @@ idldir='${datadir}'/idl/evolution-data-s
imagesdir='${datadir}'/pixmaps/evolution-data-server
diff --git a/databases/evolution-data-server/files/patch-docs_reference_camel_Makefile.in b/databases/evolution-data-server/files/patch-docs_reference_camel_Makefile.in
index d536fff6de55..69da393ce0cd 100644
--- a/databases/evolution-data-server/files/patch-docs_reference_camel_Makefile.in
+++ b/databases/evolution-data-server/files/patch-docs_reference_camel_Makefile.in
@@ -1,22 +1,11 @@
---- docs/reference/camel/Makefile.in.orig 2009-07-04 12:06:59.000000000 +0200
-+++ docs/reference/camel/Makefile.in 2009-07-04 12:23:53.000000000 +0200
-@@ -127,7 +127,7 @@
+--- docs/reference/camel/Makefile.in.orig 2009-07-27 22:42:25.000000000 +0200
++++ docs/reference/camel/Makefile.in 2009-07-27 22:42:50.000000000 +0200
+@@ -137,7 +137,7 @@ GNOME_PLATFORM_LIBS = @GNOME_PLATFORM_LI
GOBJECT_QUERY = @GOBJECT_QUERY@
GREP = @GREP@
HAVE_JW = @HAVE_JW@
-HTML_DIR = $(datadir)/gtk-doc/html
-+HTML_DIR = $(prefix)/share/doc
- ICONV_CFLAGS = @ICONV_CFLAGS@
++HTML_DIR = $(datadir)/doc
ICONV_LIBS = @ICONV_LIBS@
IDL_INCLUDES = @IDL_INCLUDES@
-@@ -731,8 +731,9 @@
- mv -f $${installdir}/$(DOC_MODULE).devhelp \
- $${installdir}/$(DOC_MODULE)-$(DOC_MODULE_VERSION).devhelp; \
- fi; \
-- $(GTKDOC_REBASE) --relative --dest-dir=$(DESTDIR) --html-dir=$${installdir}; \
-+ cp -R html/* $(HTML_DIR)/camel; \
- fi
-+# $(GTKDOC_REBASE) --relative --dest-dir=$(DESTDIR) --html-dir=$${installdir}; \
-
- uninstall-local:
- @if test -n "$(DOC_MODULE_VERSION)"; then \
+ INSTALL = @INSTALL@
diff --git a/databases/evolution-data-server/pkg-plist b/databases/evolution-data-server/pkg-plist
index c76030056e2f..3845563c6623 100644
--- a/databases/evolution-data-server/pkg-plist
+++ b/databases/evolution-data-server/pkg-plist
@@ -183,6 +183,7 @@ include/evolution-data-server-%%VERSION%%/libebook/e-vcard.h
include/evolution-data-server-%%VERSION%%/libecal/e-cal-check-timezones.h
include/evolution-data-server-%%VERSION%%/libecal/e-cal-component.h
include/evolution-data-server-%%VERSION%%/libecal/e-cal-recur.h
+include/evolution-data-server-%%VERSION%%/libecal/e-cal-system-timezone.h
include/evolution-data-server-%%VERSION%%/libecal/e-cal-time-util.h
include/evolution-data-server-%%VERSION%%/libecal/e-cal-types.h
include/evolution-data-server-%%VERSION%%/libecal/e-cal-util.h
@@ -203,8 +204,10 @@ include/evolution-data-server-%%VERSION%%/libedata-book/e-data-book.h
include/evolution-data-server-%%VERSION%%/libedata-cal/Evolution-DataServer-Calendar.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-cache.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-factory.h
+include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-file-store.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-loader-factory.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-sexp.h
+include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-store.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-sync.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-util.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend.h
@@ -579,6 +582,7 @@ share/doc/libecal/ix01.html
share/doc/libecal/left.png
share/doc/libecal/libecal-e-cal-check-timezones.html
share/doc/libecal/libecal-e-cal-recur.html
+share/doc/libecal/libecal-e-cal-system-timezone.html
share/doc/libecal/libecal-e-cal-time-util.html
share/doc/libecal/libecal-e-cal-types.html
share/doc/libecal/libecal-e-cal-util.html
@@ -601,9 +605,6 @@ share/doc/libedata-book/index.html
share/doc/libedata-book/index.sgml
share/doc/libedata-book/ix01.html
share/doc/libedata-book/left.png
-share/doc/libedata-book/libedata-book-EDataBookFactory.html
-share/doc/libedata-book/libedata-book-e-book-backend-db-cache.html
-share/doc/libedata-book/libedata-book-ximian-vcard.html
share/doc/libedata-book/libedata-book.devhelp
share/doc/libedata-book/libedata-book.devhelp2
share/doc/libedata-book/right.png
@@ -623,7 +624,6 @@ share/doc/libedata-cal/index.html
share/doc/libedata-cal/index.sgml
share/doc/libedata-cal/ix01.html
share/doc/libedata-cal/left.png
-share/doc/libedata-cal/libedata-cal-e-cal-backend-util.html
share/doc/libedata-cal/libedata-cal.devhelp
share/doc/libedata-cal/libedata-cal.devhelp2
share/doc/libedata-cal/right.png
@@ -647,7 +647,6 @@ share/doc/libedataserver/left.png
share/doc/libedataserver/libedataserver-EFlag.html
share/doc/libedataserver/libedataserver-EProxy.html
share/doc/libedataserver/libedataserver-ESExp.html
-share/doc/libedataserver/libedataserver-Version-Information.html
share/doc/libedataserver/libedataserver-e-categories.html
share/doc/libedataserver/libedataserver-e-iconv.html
share/doc/libedataserver/libedataserver-e-memory.html
@@ -683,10 +682,6 @@ share/doc/libedataserverui/index.html
share/doc/libedataserverui/index.sgml
share/doc/libedataserverui/ix01.html
share/doc/libedataserverui/left.png
-share/doc/libedataserverui/libedataserverui-ECategoryCompletion.html
-share/doc/libedataserverui/libedataserverui-ECellRendererColor.html
-share/doc/libedataserverui/libedataserverui-e-book-auth-util.html
-share/doc/libedataserverui/libedataserverui-e-data-server-ui-marshal.html
share/doc/libedataserverui/libedataserverui-e-passwords.html
share/doc/libedataserverui/libedataserverui.devhelp
share/doc/libedataserverui/libedataserverui.devhelp2
@@ -703,6 +698,7 @@ share/idl/evolution-data-server-%%EVO_VERSION%%/Evolution-DataServer.idl
share/locale/am/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/ar/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/as/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
+share/locale/ast/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/az/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/be/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/bg/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
@@ -710,6 +706,7 @@ share/locale/bn/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/bn_IN/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/bs/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/ca/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
+share/locale/ca@valencia/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/cs/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/cy/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
share/locale/da/LC_MESSAGES/evolution-data-server-%%VERSION%%.mo
@@ -849,7 +846,11 @@ share/pixmaps/evolution-data-server/category_time-and-expenses_16.png
@dirrmtry share/locale/ku
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
diff --git a/databases/glom/Makefile b/databases/glom/Makefile
index d17c97aee9ab..1aee75e0e9ef 100644
--- a/databases/glom/Makefile
+++ b/databases/glom/Makefile
@@ -3,12 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/databases/glom/Makefile,v 1.24 2009/03/17 16:33:41 kwm Exp $
+# $MCom: ports/databases/glom/Makefile,v 1.28 2009/10/11 10:43:05 kwm Exp $
#
PORTNAME= glom
-PORTVERSION= 1.10.1
-PORTREVISION= 1
+PORTVERSION= 1.12.2
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,8 +15,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= kwm@FreeBSD.org
COMMENT= GNOME database designer and user interface
-LIB_DEPENDS= bakery-2.6:${PORTSDIR}/x11-toolkits/bakery \
- gdamm-4.0.11:${PORTSDIR}/databases/libgdamm \
+LIB_DEPENDS= gdamm-4.0.12:${PORTSDIR}/databases/libgdamm \
+ gconfmm-2.0.1:${PORTSDIR}/devel/gconfmm \
gtksourceviewmm-2.0.2:${PORTSDIR}/x11-toolkits/libgtksourceviewmm \
avahi-ui.0:${PORTSDIR}/net/avahi-gtk \
epc-1.0.2:${PORTSDIR}/www/libepc \
diff --git a/databases/glom/distinfo b/databases/glom/distinfo
index 4a78945d7f56..2672d73d664e 100644
--- a/databases/glom/distinfo
+++ b/databases/glom/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/glom-1.10.1.tar.bz2) = 611a9cc73aadd1ff5fdc4dd81e240822
-SHA256 (gnome2/glom-1.10.1.tar.bz2) = 76018d2e942ee7581b58c45bb045d35ff465ab3efd86d4bfecd6c8f543b96ce6
-SIZE (gnome2/glom-1.10.1.tar.bz2) = 3308723
+MD5 (gnome2/glom-1.12.2.tar.bz2) = 8f4de116f28501decc0df956ee003809
+SHA256 (gnome2/glom-1.12.2.tar.bz2) = 5ce8bc49d9d6402db540d14c8c16a2407cbf7a588139a4e2942442ead1952992
+SIZE (gnome2/glom-1.12.2.tar.bz2) = 3239342
diff --git a/databases/glom/pkg-plist b/databases/glom/pkg-plist
index 682717c2ee83..b916528825c9 100644
--- a/databases/glom/pkg-plist
+++ b/databases/glom/pkg-plist
@@ -1,59 +1,57 @@
bin/glom
-include/glom-1.0/libglom/appstate.h
-include/glom-1.0/libglom/data_structure/field.h
-include/glom-1.0/libglom/data_structure/fieldtypes.h
-include/glom-1.0/libglom/data_structure/foundset.h
-include/glom-1.0/libglom/data_structure/glomconversions.h
-include/glom-1.0/libglom/data_structure/groupinfo.h
-include/glom-1.0/libglom/data_structure/iso_codes.h
-include/glom-1.0/libglom/data_structure/layout/custom_title.h
-include/glom-1.0/libglom/data_structure/layout/fieldformatting.h
-include/glom-1.0/libglom/data_structure/layout/layoutgroup.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_button.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_calendarportal.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_field.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_image.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_line.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_notebook.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_placeholder.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_portal.h
-include/glom-1.0/libglom/data_structure/layout/layoutitem_text.h
-include/glom-1.0/libglom/data_structure/layout/report_parts/layoutitem_fieldsummary.h
-include/glom-1.0/libglom/data_structure/layout/report_parts/layoutitem_footer.h
-include/glom-1.0/libglom/data_structure/layout/report_parts/layoutitem_groupby.h
-include/glom-1.0/libglom/data_structure/layout/report_parts/layoutitem_header.h
-include/glom-1.0/libglom/data_structure/layout/report_parts/layoutitem_summary.h
-include/glom-1.0/libglom/data_structure/layout/report_parts/layoutitem_verticalgroup.h
-include/glom-1.0/libglom/data_structure/layout/usesrelationship.h
-include/glom-1.0/libglom/data_structure/numeric_format.h
-include/glom-1.0/libglom/data_structure/parameternamegenerator.h
-include/glom-1.0/libglom/data_structure/print_layout.h
-include/glom-1.0/libglom/data_structure/privileges.h
-include/glom-1.0/libglom/data_structure/relationship.h
-include/glom-1.0/libglom/data_structure/report.h
-include/glom-1.0/libglom/data_structure/system_prefs.h
-include/glom-1.0/libglom/data_structure/tableinfo.h
-include/glom-1.0/libglom/data_structure/translatable_item.h
-include/glom-1.0/libglom/document/document_glom.h
-include/glom-1.0/libglom/document/view.h
-include/glom-1.0/libglom/libglom_config.h
-include/glom-1.0/libglom/sharedptr.h
-include/glom-1.0/libglom/standard_table_prefs_fields.h
-lib/libglom-1.0.a
-lib/libglom-1.0.la
-lib/libglom-1.0.so
-lib/libglom-1.0.so.0
-%%PYTHON_SITELIBDIR%%/glom.a
-%%PYTHON_SITELIBDIR%%/glom.la
-%%PYTHON_SITELIBDIR%%/glom.so
-libdata/pkgconfig/glom-1.0.pc
+include/glom-1.12/libglom/appstate.h
+include/glom-1.12/libglom/data_structure/field.h
+include/glom-1.12/libglom/data_structure/fieldtypes.h
+include/glom-1.12/libglom/data_structure/foundset.h
+include/glom-1.12/libglom/data_structure/glomconversions.h
+include/glom-1.12/libglom/data_structure/groupinfo.h
+include/glom-1.12/libglom/data_structure/layout/custom_title.h
+include/glom-1.12/libglom/data_structure/layout/fieldformatting.h
+include/glom-1.12/libglom/data_structure/layout/layoutgroup.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_button.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_calendarportal.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_field.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_image.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_line.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_notebook.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_placeholder.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_portal.h
+include/glom-1.12/libglom/data_structure/layout/layoutitem_text.h
+include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_fieldsummary.h
+include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_footer.h
+include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_groupby.h
+include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_header.h
+include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_summary.h
+include/glom-1.12/libglom/data_structure/layout/report_parts/layoutitem_verticalgroup.h
+include/glom-1.12/libglom/data_structure/layout/usesrelationship.h
+include/glom-1.12/libglom/data_structure/numeric_format.h
+include/glom-1.12/libglom/data_structure/parameternamegenerator.h
+include/glom-1.12/libglom/data_structure/print_layout.h
+include/glom-1.12/libglom/data_structure/privileges.h
+include/glom-1.12/libglom/data_structure/relationship.h
+include/glom-1.12/libglom/data_structure/report.h
+include/glom-1.12/libglom/data_structure/system_prefs.h
+include/glom-1.12/libglom/data_structure/tableinfo.h
+include/glom-1.12/libglom/data_structure/translatable_item.h
+include/glom-1.12/libglom/document/bakery/document.h
+include/glom-1.12/libglom/document/bakery/document_xml.h
+include/glom-1.12/libglom/document/bakery/view/view.h
+include/glom-1.12/libglom/document/bakery/view/view_composite.h
+include/glom-1.12/libglom/document/bakery/view/viewbase.h
+include/glom-1.12/libglom/document/document.h
+include/glom-1.12/libglom/document/view.h
+include/glom-1.12/libglom/init.h
+include/glom-1.12/libglom/libglom_config.h
+include/glom-1.12/libglom/sharedptr.h
+include/glom-1.12/libglom/standard_table_prefs_fields.h
+lib/libglom-1.12.la
+lib/libglom-1.12.so
+lib/libglom-1.12.so.0
+%%PYTHON_SITELIBDIR%%/glom_1_12.la
+%%PYTHON_SITELIBDIR%%/glom_1_12.so
+libdata/pkgconfig/glom-1.12.pc
share/applications/glom.desktop
-%%DATADIR%%/doc/examples/example_film_manager.glom
-%%DATADIR%%/doc/examples/example_lesson_planner.glom
-%%DATADIR%%/doc/examples/example_music_collection.glom
-%%DATADIR%%/doc/examples/example_project_manager.glom
-%%DATADIR%%/doc/examples/example_smallbusiness.glom
%%DATADIR%%/glade/glom_developer.glade
%%DATADIR%%/glade/glom.glade
%%DATADIR%%/glom_document.dtd
@@ -68,6 +66,12 @@ share/applications/glom.desktop
%%DATADIR%%/pixmaps/glom-text.png
%%DATADIR%%/xslt/print_details_to_html.xsl
%%DATADIR%%/xslt/print_report_to_html.xsl
+%%DOCSDIR%%/examples/README
+%%DOCSDIR%%/examples/example_film_manager.glom
+%%DOCSDIR%%/examples/example_lesson_planner.glom
+%%DOCSDIR%%/examples/example_music_collection.glom
+%%DOCSDIR%%/examples/example_project_manager.glom
+%%DOCSDIR%%/examples/example_smallbusiness.glom
share/gnome/help/glom/C/figures/glom_data_details.png
share/gnome/help/glom/C/figures/glom_data_list.png
share/gnome/help/glom/C/figures/glom_design_fields.png
@@ -176,8 +180,6 @@ share/gnome/help/glom/sv/figures/glom_tables.png
share/gnome/help/glom/sv/figures/start.png
share/gnome/help/glom/sv/glom.xml
share/gnome/help/glom/sv/legal.xml
-share/mime-info/glom.keys
-share/mime-info/glom.mime
share/icons/hicolor/16x16/apps/glom.png
share/icons/hicolor/22x22/apps/glom.png
share/icons/hicolor/24x24/apps/glom.png
@@ -211,6 +213,7 @@ share/locale/sv/LC_MESSAGES/glom.mo
share/locale/tr/LC_MESSAGES/glom.mo
share/locale/vi/LC_MESSAGES/glom.mo
share/locale/zh_CN/LC_MESSAGES/glom.mo
+share/mime/application/x-glom.xml
share/mime/packages/glom.xml
share/omf/glom/glom-C.omf
share/omf/glom/glom-de.omf
@@ -232,11 +235,10 @@ share/omf/glom/glom-sv.omf
@dirrm share/gnome/help/glom/C/figures
@dirrm share/gnome/help/glom/C
@dirrm share/gnome/help/glom
+@dirrm %%DOCSDIR%%/examples
@dirrm %%DATADIR%%/xslt
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/glade
-@dirrm %%DATADIR%%/doc/examples
-@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@@ -245,9 +247,11 @@ share/omf/glom/glom-sv.omf
@dirrmtry share/locale/rw
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
-@dirrm include/glom-1.0/libglom/document
-@dirrm include/glom-1.0/libglom/data_structure/layout/report_parts
-@dirrm include/glom-1.0/libglom/data_structure/layout
-@dirrm include/glom-1.0/libglom/data_structure
-@dirrm include/glom-1.0/libglom
-@dirrm include/glom-1.0
+@dirrm include/glom-1.12/libglom/document/bakery/view
+@dirrm include/glom-1.12/libglom/document/bakery
+@dirrm include/glom-1.12/libglom/document
+@dirrm include/glom-1.12/libglom/data_structure/layout/report_parts
+@dirrm include/glom-1.12/libglom/data_structure/layout
+@dirrm include/glom-1.12/libglom/data_structure
+@dirrm include/glom-1.12/libglom
+@dirrm include/glom-1.12
diff --git a/databases/libgdamm/Makefile b/databases/libgdamm/Makefile
index 04ec0e84c7d0..b13efa3b6b81 100644
--- a/databases/libgdamm/Makefile
+++ b/databases/libgdamm/Makefile
@@ -3,12 +3,11 @@
# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/databases/libgdamm/Makefile,v 1.15 2009/04/09 03:24:07 mezz Exp $
+# $MCom: ports/databases/libgdamm/Makefile,v 1.18 2009/11/28 05:58:58 mezz Exp $
#
PORTNAME= libgdamm
-PORTVERSION= 3.99.16
-PORTREVISION= 1
+PORTVERSION= 3.99.17.1
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -25,10 +24,6 @@ USE_GMAKE= yes
USE_GNOME= gnomehack libgda4
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-static
-
-post-patch:
- @${REINPLACE_CMD} -e "s|\(-lglibmm\)|-L\$$(GMM_PROCDIR)/../.. \1|" \
- ${WRKSRC}/tools/extra_defs_gen/Makefile.in
+CONFIGURE_ARGS= --enable-static --disable-documentation
.include <bsd.port.mk>
diff --git a/databases/libgdamm/distinfo b/databases/libgdamm/distinfo
index ca5bd9a3096f..52ebba84dced 100644
--- a/databases/libgdamm/distinfo
+++ b/databases/libgdamm/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/libgdamm-3.99.16.tar.bz2) = 975e90bfaa21491c71cbe12741b24ba2
-SHA256 (gnome2/libgdamm-3.99.16.tar.bz2) = 37189b5ebbfb05f9b2916bc6f36bf770139dcf9c983b65d2c47eb6d337e38a3d
-SIZE (gnome2/libgdamm-3.99.16.tar.bz2) = 836649
+MD5 (gnome2/libgdamm-3.99.17.1.tar.bz2) = 227d838905b45e8ccd6440cf661630fc
+SHA256 (gnome2/libgdamm-3.99.17.1.tar.bz2) = d3078223d4589ee69af94a649a156a933cc8b058fc24064fd440724f234a50db
+SIZE (gnome2/libgdamm-3.99.17.1.tar.bz2) = 924028
diff --git a/databases/libgdamm/pkg-plist b/databases/libgdamm/pkg-plist
index 8a308210e842..8458fdd6eaab 100644
--- a/databases/libgdamm/pkg-plist
+++ b/databases/libgdamm/pkg-plist
@@ -67,19 +67,16 @@ include/libgdamm-4.0/libgdamm/set.h
include/libgdamm-4.0/libgdamm/sqlparser.h
include/libgdamm-4.0/libgdamm/statement.h
include/libgdamm-4.0/libgdamm/transactionstatus.h
+include/libgdamm-4.0/libgdamm/throw_exception.h
include/libgdamm-4.0/libgdamm/value.h
include/libgdamm-4.0/libgdamm/wrap_init.h
include/libgdamm-4.0/libgdamm/xatransaction.h
lib/libgdamm-4.0.a
lib/libgdamm-4.0.la
lib/libgdamm-4.0.so
-lib/libgdamm-4.0.so.11
+lib/libgdamm-4.0.so.12
lib/libgdamm-4.0/include/libgdammconfig.h
-lib/libgdamm-4.0/proc/m4/convert.m4
-lib/libgdamm-4.0/proc/m4/convert_libgdamm.m4
libdata/pkgconfig/libgdamm-4.0.pc
-@dirrm lib/libgdamm-4.0/proc/m4
-@dirrm lib/libgdamm-4.0/proc
@dirrm lib/libgdamm-4.0/include
@dirrm lib/libgdamm-4.0
@dirrm include/libgdamm-4.0/libgdamm/private
diff --git a/databases/mysql-gui-tools/Makefile b/databases/mysql-gui-tools/Makefile
index 174cf5e1f63f..3c3e695883f0 100644
--- a/databases/mysql-gui-tools/Makefile
+++ b/databases/mysql-gui-tools/Makefile
@@ -8,6 +8,7 @@
PORTNAME= mysql-gui-tools
PORTVERSION= 5.0r14
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
MASTER_SITE_SUBDIR= MySQLGUITools
@@ -24,15 +25,16 @@ OPTIONS= QUERY_BROWSER "Build the MySQL Query Browser" on \
ADMINISTRATOR "Build the MySQL Administrator" on
USE_AUTOTOOLS= autoconf:262 libtool:22 automake:110
-USE_GNOME= gnomelibs libglade2 gtkhtml3 libgnomeprint intlhack gtksourceview
+USE_GNOME= libgnome libglade2 gtkhtml3 libgnomeprint intlhack gtksourceview
USE_GL= gl glut
USE_GMAKE= yes
DATADIR= ${PREFIX}/share/mysql-gui
-CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib
HAS_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
CONFIGURE_ARGS+= --with-gtkhtml=libgtkhtml-3.14
.include <bsd.port.pre.mk>
diff --git a/databases/mysql-gui-tools/files/patch-query-browser-configure.in b/databases/mysql-gui-tools/files/patch-query-browser-configure.in
new file mode 100644
index 000000000000..0d86b9fd38c3
--- /dev/null
+++ b/databases/mysql-gui-tools/files/patch-query-browser-configure.in
@@ -0,0 +1,21 @@
+--- query-browser/configure.in.orig 2009-09-27 23:40:34.000000000 +0200
++++ query-browser/configure.in 2009-09-27 23:41:02.000000000 +0200
+@@ -66,7 +66,7 @@
+ gtkhtml=$withval, gtkhtml=libgtkhtml-3.0)
+
+
+-PKG_CHECK_MODULES(GLIB, [glib-2.0 libxml-2.0 >= 2.6.2])
++PKG_CHECK_MODULES(GLIB, [glib-2.0 libxml-2.0 >= 2.6.2 libgnome-2.0])
+ AC_SUBST(GLIB_CFLAGS)
+ AC_SUBST(GLIB_LIBS)
+
+@@ -74,7 +74,8 @@
+ gthread-2.0
+ libxml-2.0 >= 2.6.2
+ $gtkhtml
+- gtkmm-2.4])
++ gtkmm-2.4
++ libgnome-2.0])
+ AC_SUBST(GNOME_CFLAGS)
+ AC_SUBST(GNOME_LIBS)
+