aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-09-23 15:59:11 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-09-23 15:59:11 +0000
commit4391611f293e1d6ce497285de1dc74cb8ebfb03a (patch)
tree7979c235bd6459377983e040e70b17d15b4c040a /databases
parent4168feee0e28829b9f06e13adaba8e7416601703 (diff)
downloadports-4391611f293e1d6ce497285de1dc74cb8ebfb03a.tar.gz
ports-4391611f293e1d6ce497285de1dc74cb8ebfb03a.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/c3p0/Makefile31
-rw-r--r--databases/c3p0/distinfo3
-rw-r--r--databases/c3p0/pkg-descr6
-rw-r--r--databases/c3p0/pkg-plist46
5 files changed, 87 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7a73121560c1..6ffeb8bb99df 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -18,6 +18,7 @@
SUBDIR += bbdb
SUBDIR += beansdb
SUBDIR += buzhug
+ SUBDIR += c3p0
SUBDIR += cassandra
SUBDIR += cdb
SUBDIR += cego
diff --git a/databases/c3p0/Makefile b/databases/c3p0/Makefile
new file mode 100644
index 000000000000..fe0540bb279d
--- /dev/null
+++ b/databases/c3p0/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: c3p0
+# Date created: Sep 23 2010
+# Whom: olgeni
+#
+# $FreeBSD$
+#
+
+PORTNAME= c3p0
+PORTVERSION= 0.9.1.2
+CATEGORIES= databases java
+MASTER_SITES= SF/c3p0/c3p0-bin/c3p0-${PORTVERSION}/
+DISTNAME= c3p0-${PORTVERSION}.bin
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= A library for augmenting JDBC drivers with JNDI-bindable DataSources
+
+USE_JAVA= yes
+NO_BUILD= yes
+JAVA_VERSION= 1.5+
+WRKSRC= ${WRKDIR}/c3p0-${PORTVERSION}
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/lib/c3p0-0.9.1.2.jar ${JAVAJARDIR}/c3p0.jar
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${COPYTREE_SHARE} apidocs ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/arrow_sm.png ${WRKSRC}/doc/index.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/c3p0/distinfo b/databases/c3p0/distinfo
new file mode 100644
index 000000000000..e86ab7fe32e9
--- /dev/null
+++ b/databases/c3p0/distinfo
@@ -0,0 +1,3 @@
+MD5 (c3p0-0.9.1.2.bin.tgz) = 4fc5c090b2e88b21010992e1f85d67bc
+SHA256 (c3p0-0.9.1.2.bin.tgz) = 22da2faf98f54bc238672598edc9941c5280f03e35c7fb9906ada7839ac0e827
+SIZE (c3p0-0.9.1.2.bin.tgz) = 1259670
diff --git a/databases/c3p0/pkg-descr b/databases/c3p0/pkg-descr
new file mode 100644
index 000000000000..508c3c4e9d88
--- /dev/null
+++ b/databases/c3p0/pkg-descr
@@ -0,0 +1,6 @@
+c3p0 is an easy-to-use Java library for augmenting traditional
+(DriverManager-based) JDBC drivers with JNDI-bindable DataSources,
+including DataSources that implement Connection and Statement
+Pooling, as described by the jdbc3 spec and jdbc2 std extension.
+
+WWW: http://sourceforge.net/projects/c3p0/
diff --git a/databases/c3p0/pkg-plist b/databases/c3p0/pkg-plist
new file mode 100644
index 000000000000..36b29496d417
--- /dev/null
+++ b/databases/c3p0/pkg-plist
@@ -0,0 +1,46 @@
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/allclasses-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/allclasses-noframe.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/AbstractConnectionCustomizer.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/AbstractConnectionTester.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/C3P0ProxyConnection.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/C3P0ProxyStatement.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/C3P0Registry.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/ComboPooledDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/ConnectionCustomizer.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/ConnectionTester.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/DataSources.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/DriverManagerDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/DriverManagerDataSourceFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/FullQueryConnectionTester.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/JndiRefConnectionPoolDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/PoolBackedDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/PoolBackedDataSourceFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/PoolConfig.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/PooledDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/QueryConnectionTester.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/SQLWarnings.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/UnifiedConnectionTester.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/WrapperConnectionPoolDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/constant-values.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/deprecated-list.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/help-doc.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/index-all.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/index.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/overview-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/package-list
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/resources/inherit.gif
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/serialized-form.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/stylesheet.css
+%%PORTDOCS%%%%DOCSDIR%%/arrow_sm.png
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%JAVAJARDIR%%/c3p0.jar
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/resources
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%