aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-04-11 19:25:44 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-04-11 19:25:44 +0000
commit494ceff9706c8662d7b04f06e383de09b3004195 (patch)
treed2b95734ea806ca421d523eeda50a253812d78a5 /databases
parent5d8242cb07e7a065c5f90cd3808647b761ca0528 (diff)
downloadports-494ceff9706c8662d7b04f06e383de09b3004195.tar.gz
ports-494ceff9706c8662d7b04f06e383de09b3004195.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/firebird-devel/Makefile50
-rw-r--r--databases/firebird-devel/distinfo4
-rw-r--r--databases/firebird-devel/files/patch-autogen.sh43
-rw-r--r--databases/firebird-devel/files/patch-src::common::classes::locks.h49
-rw-r--r--databases/firebird-devel/files/pkg-message.in (renamed from databases/firebird-devel/pkg-message)4
-rw-r--r--databases/firebird-devel/pkg-plist173
6 files changed, 129 insertions, 194 deletions
diff --git a/databases/firebird-devel/Makefile b/databases/firebird-devel/Makefile
index fa8bb6cf3328..5495a1b347ed 100644
--- a/databases/firebird-devel/Makefile
+++ b/databases/firebird-devel/Makefile
@@ -6,43 +6,50 @@
#
PORTNAME= firebird
-PORTVERSION= 2.0.a0
-PORTREVISION= 1
+PORTVERSION= 2.0.a1
CATEGORIES= databases
-MASTER_SITES= http://www.aims.net.au/chris/firebird/
-MASTER_SITE_SUBDIR=firebird
+MASTER_SITES= http://www.ramenzoni.com.br/~garga/firebird/
+MASTER_SITE_SUBDIR= firebird
PKGNAMESUFFIX= -devel
-DISTNAME= firebird2-20031110
+DISTNAME= firebird2-20050327
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd@galle.com.br
COMMENT= The open-source InterBase(tm) 6.0 spin-off (Classic version)
-USE_BZIP2= yes
-USE_GMAKE= yes
-WANT_LIBTOOL_VER= 13
-GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+WANT_LIBTOOL_VER= 15
WANT_AUTOCONF_VER= 259
-USE_GCC= 3.4
+GNU_CONFIGURE= yes
+CONFIGURE_SCRIPT= autogen.sh
+CONFIGURE_ARGS= --with-lock-manager --with-editline
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GCC= 3.4
+
+PREFIX?= ${LOCALBASE}/${PORTNAME}
+NO_MTREE= yes
CONFLICTS= firebird-1.*
NO_PACKAGE= pkg-install not finished
WRKSRC= ${WRKDIR}/firebird2
INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/firebird/lib
-MSG_FILE= ${PKGDIR}/pkg-message
+LDCONFIG_DIRS= %%PREFIX%%/lib
+SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build on FreeBSD-4.x"
+.endif
+
pre-everything::
@${ECHO_MSG} "NOTE: If the work directory is on an NFS mount, you will"
@${ECHO_MSG} "require NFS client locking support for the build to"
- @${ECHO_MSG} "succeed. Currently this is only available on FreeBSD 5.0"
- @${ECHO_MSG} "or greater."
+ @${ECHO_MSG} "succeed."
@${ECHO_MSG}
@${ECHO_MSG} "WARNING: The on-disk structure of the databases has"
@${ECHO_MSG} "changed since version 1.0.x."
@@ -52,14 +59,7 @@ pre-everything::
@sleep 10
.endif
-do-configure:
- @(cd ${WRKSRC} && ${ENV} CC=${CC} CXX=${CXX} MAKE=${GMAKE} ./autogen.sh --prefix=${PREFIX}/firebird --with-lock-manager --with-editline)
-
-do-build:
- @( \
- ${SED} 's|%%PREFIX%%|${PREFIX}|g' ${MSG_FILE} > ${PKGMESSAGE}; \
- cd ${WRKSRC}; \
- ${ENV} CC=${CC} CXX=${CXX} ${GMAKE} all; \
- )
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/databases/firebird-devel/distinfo b/databases/firebird-devel/distinfo
index b786b1cdca26..650cb1e13cb4 100644
--- a/databases/firebird-devel/distinfo
+++ b/databases/firebird-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (firebird2-20031110.tar.bz2) = fa8cc0819e0a74278719953cf013bcb1
-SIZE (firebird2-20031110.tar.bz2) = 3682236
+MD5 (firebird2-20050327.tar.bz2) = 93996c74033f0efa180527e69f45196a
+SIZE (firebird2-20050327.tar.bz2) = 4321529
diff --git a/databases/firebird-devel/files/patch-autogen.sh b/databases/firebird-devel/files/patch-autogen.sh
deleted file mode 100644
index 4fc68f20e112..000000000000
--- a/databases/firebird-devel/files/patch-autogen.sh
+++ /dev/null
@@ -1,43 +0,0 @@
---- autogen.sh.orig Sat Nov 1 14:50:38 2003
-+++ autogen.sh Mon Nov 10 16:24:17 2003
-@@ -8,7 +8,7 @@
- SRCDIR=`dirname $0`
- DIE=0
-
--VER=`autoconf --version|grep '^[Aa]utoconf'|sed 's/^[^0-9]*//'`
-+VER=`autoconf259 --version|grep '^[Aa]utoconf'|sed 's/^[^0-9]*//'`
- case "$VER" in
- 0* | 1\.* | 2\.[0-9] | 2\.[0-9][a-z]* | \
- 2\.[1-4][0-9] | 2\.5[0-6][a-z]* )
-@@ -20,7 +20,7 @@
- ;;
- esac
-
--VER=`libtool --version|grep ' libtool)'|sed 's/.*) \([0-9][0-9.]*\) .*/\1/'`
-+VER=`libtool13 --version|grep ' libtool)'|sed 's/.*) \([0-9][0-9.]*\) .*/\1/'`
- case "$VER" in
- 0* | 1\.[0-2] | 1\.[0-2][a-z]* | \
- 1\.3\.[0-2] | 1\.3\.[0-2][a-z]* )
-@@ -50,18 +50,18 @@
-
- # Generate configure from configure.in
- echo "Running libtoolize ..."
--LIBTOOL_M4=`libtoolize --copy --force --dry-run|grep 'You should add the contents of'|sed "s,^[^/]*\(/[^']*\).*$,\1,"`
-+LIBTOOL_M4=`libtoolize13 --copy --force --dry-run|grep 'You should add the contents of'|sed "s,^[^/]*\(/[^']*\).*$,\1,"`
- if test "x$LIBTOOL_M4" != "x"; then
- rm -f aclocal.m4
- cp $LIBTOOL_M4 aclocal.m4
- fi
--libtoolize --copy --force || exit 1
-+libtoolize13 --copy --force || exit 1
-
- echo "Running autoheader ..."
--autoheader || exit 1
-+autoheader259 || exit 1
-
- echo "Running autoconf ..."
--autoconf || exit 1
-+autoconf259 || exit 1
-
- # If NOCONFIGURE is set, skip the call to configure
- if test "x$NOCONFIGURE" = "x"; then
diff --git a/databases/firebird-devel/files/patch-src::common::classes::locks.h b/databases/firebird-devel/files/patch-src::common::classes::locks.h
deleted file mode 100644
index e2948dd4bbd2..000000000000
--- a/databases/firebird-devel/files/patch-src::common::classes::locks.h
+++ /dev/null
@@ -1,49 +0,0 @@
---- src/common/classes/locks.h.orig Sun Aug 17 14:56:47 2003
-+++ src/common/classes/locks.h Wed Nov 12 11:12:25 2003
-@@ -77,7 +77,7 @@
-
- /* Process-local spinlock. Used to manage memory heaps in threaded environment. */
- // Pthreads version of the class
--#ifndef SOLARIS
-+#if !defined(SOLARIS) && !defined(DARWIN) && !defined(FREEBSD)
- class Spinlock {
- private:
- pthread_spinlock_t spinlock;
-@@ -100,6 +100,7 @@
- }
- };
- #else
-+#ifdef SOLARIS
- // Who knows why Solaris 2.6 have not THIS funny spins?
- //The next code is not comlpeted but let me compile //Konstantin
- class Spinlock {
-@@ -123,6 +124,29 @@
- system_call_failed::raise();
- }
- };
-+#else // DARWIN and FREEBSD
-+class Spinlock {
-+private:
-+ pthread_mutex_t mlock;
-+public:
-+ Spinlock() {
-+ if (pthread_mutex_init(&mlock, 0))
-+ system_call_failed::raise();
-+ }
-+ ~Spinlock() {
-+ if (pthread_mutex_destroy(&mlock))
-+ system_call_failed::raise();
-+ }
-+ void enter() {
-+ if (pthread_mutex_lock(&mlock))
-+ system_call_failed::raise();
-+ }
-+ void leave() {
-+ if (pthread_mutex_unlock(&mlock))
-+ system_call_failed::raise();
-+ }
-+};
-+#endif
-
- #endif
- #endif
diff --git a/databases/firebird-devel/pkg-message b/databases/firebird-devel/files/pkg-message.in
index 6f312bfec254..bffa948d78fd 100644
--- a/databases/firebird-devel/pkg-message
+++ b/databases/firebird-devel/files/pkg-message.in
@@ -7,12 +7,12 @@ Firebird.
The symbolic link can be created with:
-% ln -s %%PREFIX%%/firebird /usr/interbase
+% ln -s %%PREFIX%% /usr/interbase
It is STRONGLY recommended that you change the SYSDBA
password with:
-% cd %%PREFIX%%/firebird
+% cd %%PREFIX%%
% gsec -user SYSDBA -pass masterkey
GSEC> modify SYSDBA -pw newpassword
GSEC> quit
diff --git a/databases/firebird-devel/pkg-plist b/databases/firebird-devel/pkg-plist
index 24d16ae63079..f9f237403040 100644
--- a/databases/firebird-devel/pkg-plist
+++ b/databases/firebird-devel/pkg-plist
@@ -1,73 +1,100 @@
-etc/rc.d/000.firebird.sh
-firebird/README
-firebird/UDF/fbudf.so
-firebird/UDF/fbudf.sql
-firebird/UDF/ib_udf.so
-firebird/UDF/ib_udf.sql
-firebird/WhatsNew
-firebird/aliases.conf
-firebird/bin/fb_inet_server
-firebird/bin/fb_lock_mgr
-firebird/bin/fb_lock_print
-firebird/bin/gbak
-firebird/bin/gdef
-firebird/bin/gds_drop
-firebird/bin/gfix
-firebird/bin/gpre
-firebird/bin/gsec
-firebird/bin/gsplit
-firebird/bin/gstat
-firebird/bin/isql
-firebird/bin/qli
-firebird/doc/README.NTSecurity
-firebird/doc/README.build.mingw.html
-firebird/doc/README.build.msvc.html
-firebird/doc/README.coding.style
-firebird/doc/README.instsvc
-firebird/doc/README.makefiles
-firebird/doc/README.user
-firebird/doc/README.user.embedded
-firebird/doc/README.user.troubleshooting
-firebird/doc/sql.extensions/README.aggregate_tracking
-firebird/doc/sql.extensions/README.case
-firebird/doc/sql.extensions/README.coalesce
-firebird/doc/sql.extensions/README.context_variables
-firebird/doc/sql.extensions/README.data_types
-firebird/doc/sql.extensions/README.exception_handling
-firebird/doc/sql.extensions/README.execute_statement
-firebird/doc/sql.extensions/README.explicit_locks
-firebird/doc/sql.extensions/README.nullif
-firebird/doc/sql.extensions/README.order_by_expressions_nulls
-firebird/doc/sql.extensions/README.savepoints
-firebird/doc/sql.extensions/README.universal_triggers
-firebird/firebird.conf
-@unexec rm -f %D/firebird/firebird.log
-firebird/firebird.msg
-firebird/help/help.fdb
-firebird/include/blr.h
-firebird/include/gds.h
-firebird/include/ib_util.h
-firebird/include/ibase.h
-firebird/include/iberror.h
-firebird/include/perf.h
-firebird/intl/fbintl
-@unexec rm -f %D/firebird/isc_event1.`hostname`
-@unexec rm -f %D/firebird/isc_init1.`hostname`
-@unexec rm -f %D/firebird/isc_lock1.`hostname`
-firebird/lib/libfbclient.so
-firebird/lib/libfbclient.so.2
-firebird/lib/libfbclient.so.2.0.0
-firebird/lib/libfbembed.so
-firebird/lib/libfbembed.so.2
-firebird/lib/libfbembed.so.2.0.0
-firebird/lib/libib_util.so
-firebird/security.fdb
-@dirrm firebird/UDF
-@dirrm firebird/bin
-@dirrm firebird/doc/sql.extensions
-@dirrm firebird/doc
-@dirrm firebird/help
-@dirrm firebird/include
-@dirrm firebird/intl
-@dirrm firebird/lib
-@dirrm firebird
+@unexec rm -f %%LOCALBASE%%/etc/rc.d/000.firebird.sh
+README
+UDF/fbudf.so
+UDF/fbudf.sql
+UDF/ib_udf.so
+UDF/ib_udf.sql
+WhatsNew
+aliases.conf
+aliases.conf.sample
+bin/fb_inet_server
+bin/fb_lock_mgr
+bin/fb_lock_print
+bin/gbak
+bin/gdef
+bin/gds_drop
+bin/gfix
+bin/gpre
+bin/gsec
+bin/gsplit
+bin/gstat
+bin/isql
+bin/qli
+doc/README.NTSecurity
+doc/README.Optimizer.txt
+doc/README.Win32LibraryInstallation.txt
+doc/README.build.mingw.html
+doc/README.build.msvc.html
+doc/README.coding.style
+doc/README.instsvc
+doc/README.isql_enhancements.txt
+doc/README.makefiles
+doc/README.performance_monitoring
+doc/README.sha1
+doc/README.user
+doc/README.user.embedded
+doc/README.user.troubleshooting
+doc/README.xnet
+doc/sql.extensions/README.PSQL_stack_trace.txt
+doc/sql.extensions/README.aggregate_tracking
+doc/sql.extensions/README.case
+doc/sql.extensions/README.coalesce
+doc/sql.extensions/README.context_variables
+doc/sql.extensions/README.context_variables2
+doc/sql.extensions/README.cursors
+doc/sql.extensions/README.data_type_results_of_aggregations.txt
+doc/sql.extensions/README.data_types
+doc/sql.extensions/README.ddl.txt
+doc/sql.extensions/README.default_parameters
+doc/sql.extensions/README.derived_tables.txt
+doc/sql.extensions/README.distinct
+doc/sql.extensions/README.exception_handling
+doc/sql.extensions/README.execute_block
+doc/sql.extensions/README.execute_statement
+doc/sql.extensions/README.explicit_locks
+doc/sql.extensions/README.expression_indices
+doc/sql.extensions/README.iif
+doc/sql.extensions/README.keywords
+doc/sql.extensions/README.leave_labels
+doc/sql.extensions/README.null_value
+doc/sql.extensions/README.nullif
+doc/sql.extensions/README.order_by_expressions_nulls
+doc/sql.extensions/README.plan
+doc/sql.extensions/README.rows
+doc/sql.extensions/README.savepoints
+doc/sql.extensions/README.select_expressions
+doc/sql.extensions/README.sequence_generators
+doc/sql.extensions/README.universal_triggers
+doc/sql.extensions/README.view_updates
+firebird.conf
+firebird.conf.sample
+@unexec rm -f %D/firebird.log
+firebird.msg
+help/help.fdb
+include/blr.h
+include/ib_util.h
+include/ibase.h
+include/iberror.h
+include/perf.h
+intl/fbintl
+@unexec rm -f %D/isc_event1.`hostname`
+@unexec rm -f %D/isc_init1.`hostname`
+@unexec rm -f %D/isc_lock1.`hostname`
+lib/libfbclient.so
+lib/libfbclient.so.2
+lib/libfbclient.so.2.0.0
+lib/libfbembed.so
+lib/libfbembed.so.2
+lib/libfbembed.so.2.0.0
+lib/libib_util.so
+security2.fdb.sample
+security2.fdb
+@dirrm UDF
+@dirrm bin
+@dirrm doc/sql.extensions
+@dirrm doc
+@dirrm help
+@dirrm include
+@dirrm intl
+@dirrm lib
+@unexec rmdir %D 2>/dev/null || true