aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-17 02:15:13 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-17 02:15:13 +0000
commit3bdf701a5c55426eb679205359bb384d7019a1a2 (patch)
tree2462f02d26b3d6c876b0b158f0a6aa557f06a219 /databases
parent87b9f8cbd167accbbbbcf020b1dfed71e5f93278 (diff)
downloadports-3bdf701a5c55426eb679205359bb384d7019a1a2.tar.gz
ports-3bdf701a5c55426eb679205359bb384d7019a1a2.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/pear-DB_DataObject_FormBuilder/Makefile19
-rw-r--r--databases/pear-DB_Table/Makefile23
-rw-r--r--databases/pear-XML_Query2XML/Makefile19
3 files changed, 26 insertions, 35 deletions
diff --git a/databases/pear-DB_DataObject_FormBuilder/Makefile b/databases/pear-DB_DataObject_FormBuilder/Makefile
index 3925def2f272..af8b58d8232c 100644
--- a/databases/pear-DB_DataObject_FormBuilder/Makefile
+++ b/databases/pear-DB_DataObject_FormBuilder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pear-DB_DataObject_FormBuilder
-# Date created: 24 August 2004
-# Whom: Antonio Carlos Venancio Junior (<antonio@php.net>)
-#
+# Created by: Antonio Carlos Venancio Junior (<antonio@php.net>)
# $FreeBSD$
-#
PORTNAME= DB_DataObject_FormBuilder
PORTVERSION= 1.0.2
@@ -18,20 +14,21 @@ RUN_DEPENDS:= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickFor
${PEARDIR}/DB/DataObject.php:${PORTSDIR}/databases/pear-DB_DataObject
LATEST_LINK= pear-DB_DataObject_FormBuilder
-OPTIONS= PEAR_DATE "PEAR::Date support" off \
- PEAR_HTML_TABLE "PEAR::HTML_Table support" off
+OPTIONS_DEFINE= PEAR_DATE PEAR_HTML_TABLE
+PEAR_DATE_DESC= PEAR::Date support
+PEAR_HTML_TABLE_DESC= PEAR::HTML_Table support
PEAR_AUTOINSTALL=yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PEAR_DATE)
+.if ${PORT_OPTIONS:MPEAR_DATE}
RUN_DEPENDS+= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date
.endif
-.if defined(WITH_PEAR_HTML_TABLE)
+.if ${PORT_OPTIONS:MPEAR_HTML_TABLE}
RUN_DEPENDS+= ${PEARDIR}/HTML/Table.php:${PORTSDIR}/devel/pear-HTML_Table
.endif
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DB_Table/Makefile b/databases/pear-DB_Table/Makefile
index ec81481d165c..73bdab07e369 100644
--- a/databases/pear-DB_Table/Makefile
+++ b/databases/pear-DB_Table/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-DB_Table
-# Date created: 08 March 2005
-# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
-#
+# Created by: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
# $FreeBSD$
-#
PORTNAME= DB_Table
PORTVERSION= 1.5.6
@@ -17,9 +13,10 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS:= ${BUILD_DEPENDS}
LATEST_LINK= pear-DB_Table
-OPTIONS= PEAR_HTML_QUICKFORM "PEAR::HTML_QuickForm support" off \
- PEAR_DB "PEAR::DB support" off \
- PEAR_MDB2 "PEAR::MDB2 support" off
+OPTIONS_DEFINE= PEAR_HTML_QUICKFORM PEAR_DB PEAR_MDB2
+PEAR_HTML_QUICKFORM_DESC= PEAR::HTML_QuickForm support
+PEAR_DB_DESC= PEAR::DB support
+PEAR_MDB2_DESC= PEAR::MDB2 support
CATEGORY= DB
FILES= Table.php Table/Manager/ibase.php Table/Manager/mysql.php \
@@ -73,19 +70,19 @@ post-extract:
@${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|" \
${WRKSRC}/Table.php
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PEAR_HTML_QUICKFORM)
+.if ${PORT_OPTIONS:MPEAR_HTML_QUICKFORM}
RUN_DEPENDS+= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickForm
.endif
-.if defined(WITH_PEAR_DB)
+.if ${PORT_OPTIONS:MPEAR_DB}
RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
.endif
-.if defined(WITH_PEAR_MDB2)
+.if ${PORT_OPTIONS:MPEAR_MDB2}
RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
.endif
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-XML_Query2XML/Makefile b/databases/pear-XML_Query2XML/Makefile
index 34d82ea98cdf..91b52fa1e213 100644
--- a/databases/pear-XML_Query2XML/Makefile
+++ b/databases/pear-XML_Query2XML/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-XML_Query2xml
-# Date created: 23 March 2008
-# Whom: wenheping<wenheping@gmail.com>
-#
+# Created by: wenheping<wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= XML_Query2XML
PORTVERSION= 1.7.2
@@ -16,8 +12,9 @@ BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
LATEST_LINK= pear-XML_Query2xml
-OPTIONS= PEAR_MDB2 "Add support for pear-MDB2" Off \
- PEAR_Net_LDAP2 "Add support for pear-Net_LDAP2" Off
+OPTIONS_DEFINE= PEAR_MDB2 PEAR_NET_LDAP2
+PEAR_MDB2_DESC= Add support for pear-MDB2
+PEAR_NET_LDAP2_DESC= Add support for pear-Net_LDAP2
FILES= XML/Query2XML.php XML/Query2XML/ISO9075Mapper.php \
XML/Query2XML/Callback.php \
@@ -316,15 +313,15 @@ TESTS= Query2XML_Tests.psql \
XML_Query2XML_ISO9075Mapper/skipif.php
_TESTSDIR= tests
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PEAR_MDB2)
+.if ${PORT_OPTIONS:MPEAR_MDB2}
BUILD_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
.endif
-.if defined(WITH_PEAR_Net_LDAP2)
+.if ${PORT_OPTIONS:MPEAR_NET_LDAP2}
BUILD_DEPENDS+= ${PEARDIR}/Net/LDAP2.php:${PORTSDIR}/net/pear-Net_LDAP2
.endif
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>